multiple boot statements in Cisco 1841

Unanswered Question
Feb 20th, 2007

I've got an 1841 that I'm booting with multiple boot statements and images in flash for some testing. I've found a problem where I have say 6T6 and 6T3 images already in flash, but I then add in 9T1 as my third image. Make the edits to the boot statement to have the 9T1 as the first boot option, and it still boots into the 6T6.

A little investigating, I found that this 1841 boots from the index of the file in the flash. For instance, if index 1 is 6T6, index 2 is 6T3, and index 3 is 9T1 code, even if the 9T1 image is the first boot statement, it refuses to boot it.

But, if I format the flash wiping it out, then tftp to flas in order of the code I want to boot, I can successfully boot the 9T1 code.

Is there any cmd line options to fix this???

Thanks, Jeff

PS the code is all C1841AdvSecurity feature set.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Richard Burts Tue, 02/20/2007 - 12:03

Jeff

I do not have the same symptoms that you describe. Just this morning I was working on an 1841 with the Advanced Security feature set. I had 3 different images in flash. I configured boot system commands to specify third image, second image, first image in that order. The router boot and booted the third image just fine.

I would suggest that you check the syntax very carefully. It would also be helpful if you could capture and post the console output while the router was booting and not booting the image that you specify. Frequently there are messages in the console log if a specified image is not going to be booted.

HTH

Rick

Actions

This Discussion