Problems when I remove a seconday address with EIGRP

Unanswered Question
Feb 21st, 2007

We are transitioning to some new subnets so we have a VLAN with serveral secondary address. When we tried to remove a secondary address, EIGRP removed that VLAN from its interfaces (sh ip eigrp int) and rebooting the switch was the only thing that would fix it. The VLAN was up and if I did a sho ip rou for one of the remaining subnets on that VLAN it showed "connected".

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Richard Burts Wed, 02/21/2007 - 13:38

Harold

This is a kind of strange situation. I have looked at what you posted and on the surface I think it should have worked. But since you say that it did not work, I have an idea about what it might have been. I wonder about the network statement under EIGRP with what appears to be a class C address with a class B mask. I wonder if EIGRP got confused when you removed a secondary and marked the entire interface as not included.

I would suggest that perhaps you try a different configuration in which you configure EIGRP with more specific mask. It would mean multiple network statements but each network statement would be a better match to something within that VLAN interface and might prevent EIGRP from removing the entire interface. I would especially like to see:

network 192.168.14.0 0.0.0.255

and perhaps:

network 192.168.11.0 0.0.0.255

network 192.168.22.0 0.0.0.255

and so on.

HTH

Rick

purohit_810 Wed, 02/21/2007 - 09:20

Yeap... Send your config and Show output.

It is unclear to understand.

Regards,

Dharmesh Purohit

Actions

This Discussion