VTP Trunk

Unanswered Question
Feb 21st, 2007

Hi,

C2821 with a Switchcard - I have got to get VTP flowwing between them - the card is known as GI1/0.

!

!

interface GigabitEthernet0/0

no ip address

shutdown

duplex auto

speed auto

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface GigabitEthernet1/0

no ip address

!

interface GigabitEthernet1/0.1

no ip address

!

interface GigabitEthernet1/0.1

encapsulation dot1Q 1 native

ip address 10.1.1.254 255.255.255.0

no snmp trap link-status

!

interface GigabitEthernet1/0.2

encapsulation dot1Q 2

ip address 10.2.1.254 255.255.255.0

no snmp trap link-status

!

ip classless

!

no ip http server

Show VTP Counters shows this:

VTP pruning statistics:

Trunk Join Transmitted Join Received Summary advts received from

non-pruning-capable device

---------------- ---------------- ---------------- ---------------------------

R-CORE-1#show vtp coun

VTP statistics:

Summary advertisements received : 0

Subset advertisements received : 0

Request advertisements received : 0

Summary advertisements transmitted : 0

Subset advertisements transmitted : 0

Request advertisements transmitted : 0

Number of config revision errors : 0

Number of config digest errors : 0

Number of V1 summary errors : 0

VTP pruning statistics:

Trunk Join Transmitted Join Received Summary advts received from

non-pruning-capable device

---------------- ---------------- ---------------- ---------------------------

R-CORE-1#

What have I done wrong - I cant seem to use trunk commands on this but reading a cisco tech thing the above should work !?!?

I have added a switch to the integrated switch and these are communicating fine:

VTP statistics:

Summary advertisements received : 3

Subset advertisements received : 1

Request advertisements received : 0

Summary advertisements transmitted : 3

Subset advertisements transmitted : 1

Request advertisements transmitted : 11

Number of config revision errors : 0

Number of config digest errors : 0

Number of V1 summary errors : 0

VTP pruning statistics:

Trunk Join Transmitted Join Received Summary advts received from

non-pruning-capable device

---------------- ---------------- ---------------- ---------------------------

Gi1/0/2 0 0 0

Fa1/0/16 0 0 0

Thanks for any help

Ed

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Rolf Fischer Wed, 02/21/2007 - 08:40

I do not know the C2812 but it's a router, right?

The purpose or VTP is distributing the VLAN.dat-File among switches which use to have a VLAN-configuration.

What you did with the router is configuring L3-subinterfaces which add a vlan-tag to the transmitted frames in order to communicate to a (switch-)trunkport.

The trunk should work fine but that has nothing to do with VTP.

A 'dir all-filesystems' on both devices should show that the switch has a file named vlan.dat but the router has not.

glen.grant Wed, 02/21/2007 - 08:42

This is like a regular ios switch . You need to create the vlans. you do not use subinterfaces like on a normal router port. This is on the assumption this is like a 4 or 8 port switchcard . If this is just a router port , this does not apply .

router> vlan database

vlan 2

exit

conf t

vtp domain test

vtp mode transparent

exit

conf t

int vlan 1

ip address ip address 10.1.1.254 255.255.255.0

no shut

int vlan 2

ip address 10.2.1.254 255.255.255.0

no shut

int g1/0

switchport

switchport encapsulation dot1q

switchport mode trunk

switchport trunk allowed vlan 1,2

edw Wed, 02/21/2007 - 08:55

Hi,

Both your answers make sense unfortauntly there seems to be some misrepresentation on this series of router.

It a integrated router 2821 and I tried using int vlan 1 and switchport command and it doesnt recongise them.

Everything works apart from the vlan vtp replication, it seems and there fore I cant assign ports further down the chain to a vlan......

Thanks for any pointer

Ed

edw Wed, 02/21/2007 - 12:38

Is it a problem with the fact that the vtp output shows no trunk ports ?? as the clients do ?

Thanks

Ed

Actions

This Discussion