cisco 1841 router

Unanswered Question
Feb 21st, 2007

hello sir

i had a cisco 1841 router with IOS software version c1841-ipbase-mz.124-1c.bin" Cisco 1841 (revision 6.0)my VPN is not working on this router, can u pls guide me whether it will require a different IOS on this Cisco 1841 router so that i can start the VPN client through this router.also it will be better if u give me the detail about how to configure this router for VPN.waiting for your favourable reply.

Thanking you,

Praveen

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 1 (2 ratings)
Loading.
ggilbert Wed, 02/21/2007 - 13:11

Praveen,

You need to run, either one of these two images.

ADVANCED IP SERVICES

ADVANCED SECURITY

This will enable your router for VPN services. Caution: Please make sure you have enough memory and flash for these images on your router before upgrading.

To configure VPN client connections on this router, please read the sample configuration given below:

http://www.cisco.com/en/US/products/sw/secursw/ps2308/products_configuration_example09186a00801c4246.shtml

Rate this topic, if it helps.

Thanks

Gilbert

praveen.dharne Wed, 02/21/2007 - 19:05

hello sir,

Thanks for replying ,thatmeans i will not require to buy any hardware module for VPN feature only i have to upgrade this IOS on cisco 1841 router right.can u tell me what will be the flash name of this IOS and from where will i get this IOSsoftware whether i have to purchase this IOS or this is the free download .

actually my scenario is my vpn server is in the remote location and from where the VPN client are getting connected to server here there is a cisco 1841 router and on this cisco 1841 router i want the VPN feature to enable.

my Routers memory is as follows

114688K/16384K bytes of memory,will the new IOS can be installed on this router.

waiting for ur reply.

Thanking you

Praveen

ggilbert Thu, 02/22/2007 - 06:41

Praveen,

a. You would need the VPN feature set on your router even to run the VPN module. So, do not worry about the VPN module at the moment.

b. You can go to www.cisco.com and click on Support --> software download and get the software for your specific router and the version you need.

c. If you go to the download section of the page, you will see the names.

d. IF you have a contract with Cisco and the router is tied into the contract, then you can download that image using your CCO login ID for free.

e. Since VPN softwares are cryptographic images, you might have to sign in a cryptographic form to download the image.

f. When you go to the software download and click on the image you want to download, it will say the required memory and flash needed. Compare and do the math with you have in the router.

g. I do not completely understand your scenario.

You want the VPN clients installed on a PC to connect to a Cisco IOS server? IS that correct? If so, the previous post was sent a link on how to configure this on the router.

Please correct me if I am wrong.

Thanks

Gilbert

Rate this post, please!!

praveen.dharne Thu, 02/22/2007 - 10:14

hello

1st i use to coneect with the VPN client through broadband router but now they had purchased the cisco 1841 router and they r using the lease line now so when i m connecting using the VPN client it does not authenticate the user ,so when i checked the configuration through SDM(security device manager)and when i clicked on VPN option it shows the msg VPN feature is not supportable on this IOS .

waiting for ur reply.

Thanking you

Praveen

ggilbert Fri, 02/23/2007 - 07:18

Question 1:

IS this a new implementation

Question 2:

What was the previous implementation you mentioned. Give me a ASCII diagram.

Question 3:

Look at the ASCII diagram given below and let me know if this is how you want it to work.

VPN client ---Internet---Cisco 1841 Router

Is this your setup.

Thanks

Gilbert

Kamal Malhotra Fri, 02/23/2007 - 07:43

Hi Praveen,

Has the headend router changed meaning did you connect your VPN client to a different hardware box earlier?

If yes then then there is a possibility that it does not have the crypto image running. For confirmation do a show version and you should see something like :

System image file is "flash:XXXXXXXXXXXXXXXXXXXXXXXXXXXXX"

I'm interested to know what you see here.

HTH,

Kamal.

ggilbert Fri, 02/23/2007 - 09:14

Kamal - Didnt you read the whole thread?

Praveen stated that through SDM he was able to identify that he wasnt running a VPN supported IOS.

Thanks

Gilbert

Kamal Malhotra Fri, 02/23/2007 - 09:24

Hi Gilbert,

I did read the whole thread but before suggesting a code change, wanted to confirm it was the headend box.

Thanks,

Kamal

praveen.dharne Fri, 02/23/2007 - 10:02

flash:c1841-ipbase-mz.124-1c.bin" Cisco 1841 (revision 6.0) with 114688K/16384K bytes of memory.

just i want to know which IOS will be required here can u pls give me the name of Cisco IOS which i shuld install .and also the detail configuration of this scenario.

thanks

Praveen

ggilbert Fri, 02/23/2007 - 10:14

c1841-advipservicesk9-mz.124-1c.bin - Would be the IOS.

praveen.dharne Fri, 02/23/2007 - 18:10

this is the crypto IOS right and will support VPN feature ok , can u do one favour for me can u give me the detailed configuration of this router.

Thanks

Praveen

Kamal Malhotra Fri, 02/23/2007 - 09:35

Hi Praveen,

You need a different image depending on the memory available.

Regards,

Kamal

Kamal Malhotra Fri, 02/23/2007 - 11:43

Hi Praveen,

I had posted the message when there was no post from Gilbert.

I also looked at you post with the topology. Is it fair to say that the 1841 router is not the headend device rather a passthrough? Meaning, that the VPN connection does not terminate on this 1841 router. If it does then you need to upgrade else not. More important thing to look into here is what the logs say when you try to connect and if there are any access-groups configured on the router. Would it be possible for you to send the running configuration of the router for analysis?

Regards,

Kamal

praveen.dharne Sat, 02/24/2007 - 10:14

This is the show startup-config output of the router:

show startup-config

Using 1294 out of 196600 bytes

version 12.4 service timestamps debug datetime msec service timestamps log datetime msec service password-encryption

hostname ITSHASTRA

boot-start-marker boot-end-marker

enable secret ****

no aaa new-model

resource policy

mmi polling-interval 60

no mmi auto-configure

no mmi pvc mmi snmp-timeout 180

ip subnet-zero ip cef

ip dhcp use vrf connected

ip name-server 203.*.154.2

ip name-server 203.*.154.3

ip name-server 61.*.21.34

interface FastEthernet0/0

ip address 192.168.1.1 255.255.255.0 secondary

ip address 203.*.*.*.255.255.240

ip nat inside duplex auto speed auto

interface FastEthernet0/1

no ip address

shutdown

duplex

auto speed auto

interface Serial0/0/0

ip address 203.*.*.*.255.255.252

ip nat outside

encapsulation ppp no fair-queue

ip classless

ip route 0.0.0.0 0.0.0.0 Serial0/0/0

ip route 192.168.1.0 255.255.255.0 FastEthernet0/0

ip route 203.*.*.*.255.255.240 FastEthernet0/0

no ip http server

ip nat pool ITSHASHTRA 203.196.166.34 203.*.*.34 prefix-length 30

ip nat inside source list 10 pool ITSHASHTRA overload

access-list 10 permit 192.168.1.0 0.0.0.255

control-plane

line con 0

line aux 0

line vty 0 4

password ***

login

end

!This is the show version output of the router: show version !---------------------------------------------------------------------------- Cisco IOS Software, 1841 Software (C1841-IPBASE-M), Version 12.4(1c), RELEASE SOFTWARE (fc1) Technical Support: http://www.cisco.com/techsupport Copyright (c) 1986-2005 by Cisco Systems, Inc. Compiled Tue 25-Oct-05 17:10 by evmiller ROM: System Bootstrap, Version 12.3(8r)T9, RELEASE SOFTWARE (fc1) ITSHASTRA uptime is 1 hour, 13 minutes System returned to ROM by power-on System image file is "flash:c1841-ipbase-mz.124-1c.bin" Cisco 1841 (revision 6.0) with 114688K/16384K bytes of memory. Processor board ID FHK10451008 2 FastEthernet interfaces 1 Serial(sync/async) interface DRAM configuration is 64 bits wide with parity disabled. 191K bytes of NVRAM. 31360K bytes of ATA CompactFlash (Read/Write) Configuration register is 0x2102

users are using internet also through this router only the problem is they are not getting authenticated through this router with the vpn client .

it will be better if u send me the detail configuration of this VPN router with this IP addresses.

Thanks

Praveen

Actions

This Discussion