iBGP configured on loopback address not reachable

Answered Question
Feb 21st, 2007

I have 2 routers connected, can ping each other on the F0/0 interfaces. Each has loopback interfaces which are the only once advertised in BGP (AS1).

Problem: I am not able to ping the loopback addresses.

Any ideas. This should be possible.

Config:

router bgp 1

synchronization

bgp log-neighbor-changes

network 1.0.0.0

neighbor 2.2.2.2 remote-as 1

neighbor 2.2.2.2 update-source Loopback0

no auto-summary

R2#sh run | beg bgp

router bgp 1

synchronization

bgp log-neighbor-changes

network 2.0.0.0

neighbor 1.1.1.1 remote-as 1

neighbor 1.1.1.1 update-source Loopback0

no auto-summary

The routers can ping each other:

R2#ping 192.1.12.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.1.12.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 96/140/220 ms

What did I miss?

Debug message from R1:

*Mar 1 06:59:01.918: BGP: 2.2.2.2 active open failed - no route to peer, open a ctive delayed 29293ms (35000ms max, 28% jitter)

I have this problem too.
0 votes
Correct Answer by sundar.palaniappan about 9 years 7 months ago

Jacob,

What Mike was asking you to do is to establish BGP peering one of two-ways.

1. If you want to use loopback addresses to peer then you need to have a static or another IGP route (not BGP) to the far end loopback address. You would also need to reinstate the 'update-source' command that you removed. You need a config similar to this one;

R1:

ip route 1.1.1.1 255.255.255.255 192.1.12.1

R2:

ip route 2.2.2.2 255.255.255.255 (next_hop_ip)

2. Your second option is to reconfigure, on both routers, the "neighbor (physical_int_IP_address) remote-as 7000' to the physical interface IP on the far end device. This doesn't need any static/IGP routing as the peering IP addresses are directly connected.

HTH

Sundar

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (6 ratings)
Loading.
deilert Wed, 02/21/2007 - 17:01

you can either add a static route to your loopbacks or change the update-cource loopback 0 to 'next hop self"

i.e.

neighbor 1.1.1.1 next hop self

mikedavi1 Wed, 02/21/2007 - 17:07

The adjacency between R1 & R2 does not come up because:

1) update-source Loopback0 tells BGP to establish a connection to/from it's Loopback0

2) BGP doesn't know how to reach the remote Loopback0

*Mar 1 06:59:01.918: BGP: 2.2.2.2 active open failed -

no route to peer, <=== this is the key message

open a ctive delayed 29293ms (35000ms max, 28% jitter)

There are two ways to correct this:

1) Best Practice - You'll need to configure either a static route or an IGP (RIP, OSPF, EIGRP, etc) to exchange the routes from Loopback to Loopback so that BGP can establish that connection.

2) Remove the update-source loopback0 clause from both routers' config. The connection will then be established from the directly connected interfaces. While this approach will fix your back-to-back router issue, it is generally not a recommended approach for real networks because of the potential for broken next-hop information and reliance on the directly connected interface for peering.

HTH,

Mike

mikedavi1 Wed, 02/21/2007 - 17:08

Looks like I didn't type quickly enough - I'm late to the party... :-)

ochiengjo Wed, 02/21/2007 - 17:30

Thanks Guys

What I would like to achieve is the second option given by "mikedavi1"

I have removed "update-source loopback 0"

But I still cannot ping both ends via the loopback interfaces.

R2#sh run | begin bgp

router bgp 1

synchronization

bgp log-neighbor-changes

network 2.0.0.0

neighbor 1.1.1.1 remote-as 1

neighbor 1.1.1.1 next-hop-self

no auto-summary

R2#sh ip route | begin Gateway

Gateway of last resort is not set

C 192.1.12.0/24 is directly connected, FastEthernet0/1

C 2.0.0.0/8 is directly connected, Loopback0

C 192.1.25.0/24 is directly connected, Serial1/0.25

R1#sh run | begin bgp

router bgp 1

synchronization

bgp log-neighbor-changes

network 1.0.0.0

neighbor 2.2.2.2 remote-as 1

neighbor 2.2.2.2 next-hop-self

no auto-summary

R1#sh ip route | begin Gateway

Gateway of last resort is not set

C 192.1.12.0/24 is directly connected, FastEthernet0/1

C 1.0.0.0/8 is directly connected, Loopback0

R1#ping 2.2.2.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:

.....

Any more ideas?

Correct Answer
sundar.palaniappan Wed, 02/21/2007 - 17:58

Jacob,

What Mike was asking you to do is to establish BGP peering one of two-ways.

1. If you want to use loopback addresses to peer then you need to have a static or another IGP route (not BGP) to the far end loopback address. You would also need to reinstate the 'update-source' command that you removed. You need a config similar to this one;

R1:

ip route 1.1.1.1 255.255.255.255 192.1.12.1

R2:

ip route 2.2.2.2 255.255.255.255 (next_hop_ip)

2. Your second option is to reconfigure, on both routers, the "neighbor (physical_int_IP_address) remote-as 7000' to the physical interface IP on the far end device. This doesn't need any static/IGP routing as the peering IP addresses are directly connected.

HTH

Sundar

ochiengjo Wed, 02/21/2007 - 20:17

Thanks everyone, I am well sorted out with this one now.

Regards

yashdedhiya Wed, 02/21/2007 - 23:53

1.First of all for IBGP to work ur synchronisation must be disabled.

no synchronisation.

2. To work IBGP with loopback ip u have to route the loopback ip pointing towards other router.

R1:

ip route 1.1.1.1 255.255.255.255 192.1.12.1

R2:

ip route 2.2.2.2 255.255.255.255 (next_hop_ip)

Rate this if it works.

Thanks.

Yash

Actions

This Discussion