Problem connecting switches in an Etherchannel

Answered Question
Feb 22nd, 2007

I have two Catalyst 2950 switches that I am trying to link together, but when I run a cable between the two (doesn't matter which port)it produces a wierd fast flashing light on the ports and stops all traffic on the switches. As soon as I remove the cable, traffic resumes as normal. Any ideas?

I have this problem too.
0 votes
Correct Answer by jim.coyne about 9 years 7 months ago

no spanning-tree vlan 1 <--- This is the issue. No spanning tree and two connections between switches equals a network loop. Unplug one cable, enable spanning tree and plug the second cable back in. If you do a sh spanning-tree, one of the ports will be forwarding and one of the ports will be blocking. This is spanning-tree in action (stopping that network loop). Delete the etherchannel configuration on port 22 and re-configure it for ports 23 and 24. Spanning-tree no longer needs block any ports, becasue they are now one logical port.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Pwcjayhawk1 Thu, 02/22/2007 - 13:40

Switch 1 is acting as the VTP server and is connected to the network gateway (port 1). Switch 2 is the VTP client and needs to connect to switch 1 so that is can connect to the outside world. I can view the status of the ports and they are both listed as "Down". I'm not a pro at this yet, so I'm not sure what a spanning loop is. I do not have any spanning-tree configured for either switch. The cable I am using to connect them is a regualr cable...not crossover.

Pwcjayhawk1 Thu, 02/22/2007 - 13:42

Which config do you need. Port config ,or switch? Here are the ports:

Rack1Switch1#sho int fa0/23

FastEthernet0/23 is down, line protocol is down (notconnect)

Hardware is Fast Ethernet, address is 0014.1cb3.ae57 (bia 0014.1cb3.ae57)

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Auto-duplex, 100Mb/s, media type is 100BaseTX

input flow-control is unsupported output flow-control is unsupported

ARP type: ARPA, ARP Timeout 04:00:00

Last input 18:58:42, output 18:58:42, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

685119 packets input, 44076711 bytes, 33 no buffer

Received 676443 broadcasts (0 multicast)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 33 ignored

0 watchdog, 18 multicast, 0 pause input

0 input packets with dribble condition detected

933551 packets output, 59750754 bytes, 0 underruns

0 output errors, 0 collisions, 2 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier, 0 PAUSE output

0 output buffer failures, 0 output buffers swapped out

Rack1Switch2#sho int fa0/23

FastEthernet0/23 is down, line protocol is down (notconnect)

Hardware is Fast Ethernet, address is 0013.c304.0197 (bia 0013.c304.0197)

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Auto-duplex, 100Mb/s, media type is 100BaseTX

input flow-control is unsupported output flow-control is unsupported

ARP type: ARPA, ARP Timeout 04:00:00

Last input 19:12:11, output 19:12:12, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

933539 packets input, 59750315 bytes, 34 no buffer

Received 920942 broadcasts (0 multicast)

0 runts, 0 giants, 0 throttles

2 input errors, 1 CRC, 1 frame, 0 overrun, 34 ignored

0 watchdog, 19 multicast, 0 pause input

0 input packets with dribble condition detected

685129 packets output, 44077250 bytes, 0 underruns

0 output errors, 0 collisions, 2 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier, 0 PAUSE output

0 output buffer failures, 0 output buffers swapped out

purohit_810 Thu, 02/22/2007 - 13:46

Hi,

STP running on same switches???

When we are configuring ETHERCHANNEL... STP shouls be disable.

Please do the same.

It will create loop for the time being. It will will aslo stop.

Please look into attached document. It will give you some idea.

Regards,

Dharmesh Purohit

Attachment: 
Pwcjayhawk1 Thu, 02/22/2007 - 13:53

What had happened is this. I had two lines running between switches and both were configured in an etherchannel. I was using ports 23 and 24. I logged in remotely last week and needed to make some changes, so I deleted the Etherchannel from switch 2 and it locked up everything. I got the local tech on the phone and walked him thru some steps. 1. We moved the cable in port 23 over to port 22, but the problem remained. Then, when we removed the cable from port 24 (leaving only one cable connected), everything returned to normal. Now, if I plug that cable back into port 24 (or 23), it locks up the switches until I remove it. I have since created an etherchannel on port 22 of sw1 and sw2, but can't add another line to that wihtout locking up the switches.

glen.grant Thu, 02/22/2007 - 14:21

Post both switch configs please. I would never turn off STP , it is not causing your problems , if you are using pagp or lacp to create the channels and they are not correct it will disable the link , this is just telling you what you configured is not correct . If you are just trying to create a nontrunk etherchannel it should be as simple as putting the following on each of your interfaces " channel-group 1 mode desirable non-silent" . If it is a trunk there is more configuration needed under the port channel interface .

Configure this before applying to the interfaces . The speed and duplex for all ports must be the same and i would make sure the native vlan is the same across all 4 interfaces.

Interface port-channel 1

switchport mode dynamic desirable

Pwcjayhawk1 Thu, 02/22/2007 - 14:41

Switch 1:

User Access Verification

Password:

Rack1Switch1>enable

Password:

Rack1Switch1#sho running-config

Building configuration...

Current configuration : 1832 bytes

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log datetime

service password-encryption

service sequence-numbers

!

hostname Rack1Switch1

!

enable secret ****

!

clock summer-time UTC recurring last Sun Mar 1:00 last Sun Oct 2:00

ip subnet-zero

!

ip host Rack1Switch2 10.4.167.91

ip host Rack1Switch3 10.4.167.92

ip domain-name westernmotorcom

ip name-server 10.4.167.100

!

!

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

no spanning-tree vlan 1

!

!

!

!

interface Port-channel1

switchport mode trunk

flowcontrol send off

!

interface FastEthernet0/1

!

interface FastEthernet0/2

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

duplex half

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

switchport mode trunk

channel-group 1 mode active

!

interface FastEthernet0/23

switchport mode trunk

!

interface FastEthernet0/24

switchport mode trunk

!

interface Vlan1

ip address 10.4.167.90 255.255.255.0

no ip route-cache

!

ip default-gateway 10.4.167.253

ip http server

snmp-server community Public/RO RO

snmp-server community Public RO

snmp-server community Private RW

!

line con 0

password ***

login

line vty 0 4

password ***

login

line vty 5 15

password ***

login

!

!

end

Pwcjayhawk1 Thu, 02/22/2007 - 14:54

Switch 2:

Password:

Rack1Switch2>enable

Password:

Rack1Switch2#sho running-config

Building configuration...

Current configuration : 1869 bytes

!

! Last configuration change at 16:35:11 UTC Thu Feb 22 2007

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log datetime

service password-encryption

service sequence-numbers

!

hostname Rack1Switch2

!

enable secret ****

!

clock summer-time UTC recurring last Sun Mar 1:00 last Sun Oct 2:00

ip subnet-zero

!

ip host Rack1Switch1 10.4.167.90

ip host Rack1Switch3 10.4.167.92

ip domain-name westernmotorcom

ip name-server 10.4.167.100

!

!

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

no spanning-tree vlan 1

!

!

!

!

interface Port-channel1

switchport mode trunk

flowcontrol send off

!

interface FastEthernet0/1

!

interface FastEthernet0/2

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

switchport mode trunk

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

switchport mode trunk

channel-group 1 mode active

!

interface FastEthernet0/23

switchport mode trunk

!

interface FastEthernet0/24

switchport mode trunk

!

interface Vlan1

ip address 10.4.167.91 255.255.255.0

no ip route-cache

!

ip default-gateway 10.4.167.253

ip http server

snmp-server community Public/RO RO

snmp-server community Public RO

snmp-server community Private RW

!

line con 0

password ***

login

line vty 0 4

password ***

login

line vty 5 15

password ***

login

!

!

end

rtford31 Sat, 02/24/2007 - 23:33

why are you configuring Etherchannel? Looking at your config file you have only 1 interface configured in the Etherchannel. Etherchannel is to increase bandwidth by combining multiple interfaces to act as one.

interface Port-channel10

description *****

switchport

interface GigabitEthernet5/5

switchport access vlan 110

channel-group 10 mode on

interface GigabitEthernet5/6

switchport access vlan 110

channel-group 10 mode on

Pwcjayhawk1 Mon, 02/26/2007 - 06:01

That's the whole point. I am trying to set up an Etherchannel using 2 ports, but when I connect the second cable (0/24 of SW1 to 0/24 of SW2), it stops all activity on the switch. There is currently one cable connecting the switches, but in order to utilize an Ethercahnnel, I need 2 or more connected.

Pwcjayhawk1 Mon, 02/26/2007 - 06:08

That's the whole point. I am trying to set up an Etherchannel using 2 ports, but when I connect the second cable (0/24 of SW1 to 0/24 of SW2), it stops all activity on the switch. There is currently one cable connecting the switches, but in order to utilize an Ethercahnnel, I need 2 or more connected.

cristip Mon, 02/26/2007 - 07:17

You either disable STP for all VLANs or you enable it for all of them.

Etherchannel requires the same setting for the agregated ports/links.

Also I believe that the switchport mode trunk is redundant there. You either configure it at port level or at etherchannel level.

Make the two ports explicitly members of the channel group you defined above.

Do these things on both switches.

Correct Answer
jim.coyne Tue, 02/27/2007 - 09:37

no spanning-tree vlan 1 <--- This is the issue. No spanning tree and two connections between switches equals a network loop. Unplug one cable, enable spanning tree and plug the second cable back in. If you do a sh spanning-tree, one of the ports will be forwarding and one of the ports will be blocking. This is spanning-tree in action (stopping that network loop). Delete the etherchannel configuration on port 22 and re-configure it for ports 23 and 24. Spanning-tree no longer needs block any ports, becasue they are now one logical port.

Actions

This Discussion