Please Help me !!!!

Unanswered Question
Feb 22nd, 2007

please i need help urgently...i have a guest wlan that i have created by creating a vlan in my wired network,the vlan is then mapped to the guest interface on the controller and the to the guest wlan.

i want to use web auth for my guests.My problem is that when i enable web auth i do get an ip address from my DHCP server but then i cant browse,ping my default gateway or even authenticate using the web auth after putting the username and password...basically web auth just dont work.

where could i be going wrong ??

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
scottmac Wed, 02/28/2007 - 11:32

Verify that you have a path to your DHCP server and primary destination networks.

Even theough the VLANs exist physically in the same box, they act as if they are totally separate boxes and require a layer 3 device (router or L3 switch) to connect the segments together.

If you're sure you have a good path (via router/L3 Switch), then verify that your DHCP server is providing the correct information (DNS and gateway (which should be a different gateway than the primary VLAN)).

Good Luck

Scott

zhenningx Wed, 02/28/2007 - 11:53

Hello, you said you can not authenticate using the web auth after putting the username and password. What error did you get? Did you get wrong credentials prompt?

Before you login successfully through the web auth, only dns and dhcp are allowed to pass. So if you can not authenticate against the web auth, it is no use to try browsing and pinging. They won't work until you are authenticated.

Try to do nslookup to reslove dns name to see if that works. If you can get correct dns server info through dhcp response, you should be able to reslove dns.

I am still thinking it is the authentication problem. In the WLC web interface clients page, you can see all the clients. Make sure the client is showing as authenticated first.

Zhenning

akobwaycct Thu, 03/01/2007 - 07:14

no i did not get any errors the password and username field went empty after i had put my username and password.

the issue is that when i enable web auth i can no longer ping my dafault gateway form the guest lan basically with web auth enabled i cannot do anything.

zhenningx Fri, 03/02/2007 - 07:44

Again, it is no need to try pinging anywhere before you are successfully authenticated. You should just focus on the authentication part.

What kind of web auth do you use? Internal, downloaded or external? Do you use local datebase or AAA server to authenticate?

akobwaycct Sun, 03/04/2007 - 21:41

am using internal web auth and am using the the local database on the WLC to authenticate

Actions

This Discussion

 

 

Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode