Upgrading 2924-XL IOS

Answered Question
Feb 22nd, 2007

Forgive my newness to Cisco hardware and running managed switches...

Recently purchased a pre-owned Cisco Catalyst 2924-XL switch running IOS version: 12.0(5.2)XU Enterprise Edition.

Is there any need to update this software? And if YES, what is the current version I should be looking for?

Once the upgrade is complete, will I have to re run setup and re-establish my NIC teams on my servers?

My gratitude ahead of time...

I have this problem too.
0 votes
Correct Answer by ahmednaas about 9 years 7 months ago

Shawn,

Don't let that fool you. Most of Cisco's software is not compatible with the latest versions of SUN Java.

The 12.0(5.2)XU is an old release (July 2000):

http://www.cisco.com/en/US/products/hw/switches/ps637/prod_release_note09186a00800d9da3.html

The one you have now is new (Oct 2006):

http://www.cisco.com/en/US/products/hw/switches/ps637/prod_release_note09186a008074c4db.html

It seems there is a newer version, released yesterday (WC17):

http://www.cisco.com/en/US/products/hw/switches/ps637/prod_release_notes_list.html

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
ahmednaas Thu, 02/22/2007 - 11:28

I think the latest version for this switch is:

c2900xl-c3h2l9s-tar.120-5.WC16.tar

The upgrade, if done correctly, doesn't touch your setup. Read the release notes to see if you need to make changes to your config after you install the new IOS.

srberg5219 Thu, 02/22/2007 - 16:43

I downloaded nad intsalled that IOS version and alll went well. I think, though, that may have been a 'backwards' upgrade as I actually had to down load an earlier version of the J2SE plugin in to be able to use the CMS...

Any one know where I can get my original IOS image? I was using 12.0(5.2)XU

Apparently I do not have the appropriate 'clearance' to access any other downloads...

Correct Answer
ahmednaas Thu, 02/22/2007 - 22:44

Shawn,

Don't let that fool you. Most of Cisco's software is not compatible with the latest versions of SUN Java.

The 12.0(5.2)XU is an old release (July 2000):

http://www.cisco.com/en/US/products/hw/switches/ps637/prod_release_note09186a00800d9da3.html

The one you have now is new (Oct 2006):

http://www.cisco.com/en/US/products/hw/switches/ps637/prod_release_note09186a008074c4db.html

It seems there is a newer version, released yesterday (WC17):

http://www.cisco.com/en/US/products/hw/switches/ps637/prod_release_notes_list.html

srberg5219 Fri, 02/23/2007 - 06:41

Being new to Cisco, I pledge my gratitude for your time...

I will just keep the new version running on my switch (WC16). It appears the WC17 release will not be available until The end of March...

Actions

This Discussion