L3 or L2 Lnik?

Answered Question

HI EXPERT's!

Kindly;examine the attachment:

i want etherchannel to load balance across 4 links..EXPERT'S What is ur Suggestion here L3 OR L2 Link between Site 1 & site 2;if so why ?

10xs

sayyed

Attachment: 
I have this problem too.
0 votes
Correct Answer by sachinraja about 9 years 7 months ago

Hello Sayeed,

How are you ?? Here is my suggestion :

It really depends on your requirements to select a L2 or L3 trunk... If you want VLAN propogation across the sites, ie extending the LAN on site 1 to site 2, with both the sites having the same VLANs, you need to go for a L2 trunk solution... In case you have a L2 trunk, you can configure etherchannels and bundle the trunks to a logical BIG pipe.. you can use the load balancing feature in etherchannel to distribute the load based on SRC-DEST MAC or SRC-DEST IP... you just need to configure a simple command for this...

On the other hand.. if you want isolated LANs on site 1 and site 2, you can configure Layer 3 trunks between the sites.. In this model, the VLAN information on site 1 will not be propogated to site 2 and the only way they could reach each other is through L3 routing on the core.. If L3 trunks are configured, you dont need to configure etherchannels.. You can do load balancing using simple static routes:

ip route 10.10.10.0 255.255.255.0 ge0/1

ip route 10.10.10.0 255.255.255.0 ge0/2

ip route 10.10.10.0 255.255.255.0 ge0/3

or do it with any routing protocol if needed...

I would suggest the second method, of configuring L3 between the sites, because the broadcast domains will be limited to the local site and will stop unnecessary broadcasts over the WAN.. this is the best way of doing it...

Hope this helps.. all the best.. rate replies if found useful..

Raj

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.3 (3 ratings)
Loading.
Correct Answer
sachinraja Thu, 02/22/2007 - 17:21

Hello Sayeed,

How are you ?? Here is my suggestion :

It really depends on your requirements to select a L2 or L3 trunk... If you want VLAN propogation across the sites, ie extending the LAN on site 1 to site 2, with both the sites having the same VLANs, you need to go for a L2 trunk solution... In case you have a L2 trunk, you can configure etherchannels and bundle the trunks to a logical BIG pipe.. you can use the load balancing feature in etherchannel to distribute the load based on SRC-DEST MAC or SRC-DEST IP... you just need to configure a simple command for this...

On the other hand.. if you want isolated LANs on site 1 and site 2, you can configure Layer 3 trunks between the sites.. In this model, the VLAN information on site 1 will not be propogated to site 2 and the only way they could reach each other is through L3 routing on the core.. If L3 trunks are configured, you dont need to configure etherchannels.. You can do load balancing using simple static routes:

ip route 10.10.10.0 255.255.255.0 ge0/1

ip route 10.10.10.0 255.255.255.0 ge0/2

ip route 10.10.10.0 255.255.255.0 ge0/3

or do it with any routing protocol if needed...

I would suggest the second method, of configuring L3 between the sites, because the broadcast domains will be limited to the local site and will stop unnecessary broadcasts over the WAN.. this is the best way of doing it...

Hope this helps.. all the best.. rate replies if found useful..

Raj

HI!

just 1 question;if i configure L3 Etherchannel for this 4 links between site 1 & site 2 than let advertise this port-channel into the EIGRP Domain;it works and load balencing?

like

site1

interface port-channel 1

ip address 192.168.1.1 255.255.255.252

router eigrp 1

network 192.168.1.1 0.0.0.0

no auto-summary

site2

interface port-channel 1

ip address 192.168.1.2 255.255.255.252

router eigrp 1

network 192.168.1.2 0.0.0.0

no auto-summary

is EIGRP Load balcing the L3 Etherchannel?

10xs

devang_etcom Fri, 02/23/2007 - 08:02

ali,

here you are advertising your etherchannel in EIGRP update it means you are creating the reachablility for the peritcular network... when you creat the etherchannel it itself a load shareing mechanisam... you can have the loadbalancing in routing protocol when you have multiple path to the same network... but you are now aggregating all the channel in to one logical channel using etherchannel... so now eventhough there are four physical seperate channel but etherchannel made it logically single channel and all other loadbalancing work will heandle by the etherchannel.

etherchannel basic:http://www.cisco.com/en/US/tech/tk389/tk213/technologies_white_paper09186a0080092944.shtml

regards

Devang

devang_etcom Fri, 02/23/2007 - 09:08

no you have to make both the end of the etherchannle reachable to each other as well as for all other host... so you have to use any routing protocol or static route to make the reachability towards the etherchannel...

Actions

This Discussion