7941G/61G Pre-Config SSH client login

Unanswered Question
Feb 22nd, 2007

These phones respond to an SSH client with a login prompt even before they have successfully downloaded a configuration.

Is there a default logon user/pwd in thsi situation?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mchandak Thu, 02/22/2007 - 16:53

are u using a SCCP Phone or SIP. Not sure if anyone has the login info for this one. I tried a good set of username's and non worked. Looks like it is meant for the DE's when they want to do some advanced troubleshooting. Anything specific ur trying to do by doing a ssh login ??

Ian Cowley Fri, 02/23/2007 - 01:05

It was a 7941G SIP (8.0(2)) unit, until I put the wrong firmware on it! DOH!

I'm trying to find a way to recover it with access to a Call Manager, as I don't want to go and mess around on our client's CM systems.

I'm a data networker and just play with voice!

IC

Ian Cowley Fri, 02/23/2007 - 03:15

That should have read :-

...I'm trying to find a way to recover it withOUT access to a Call Manager!!

IC

mchandak Fri, 02/23/2007 - 07:12

try

username: default

password: user

This is the only one I know about. Also, if the Phone is registered, you can access it via web and set the username and password

mchandak Fri, 02/23/2007 - 07:49

try this as well to recover the ip phone

create a SIP.cnf file and have the following lines added to it

image_version:

phone_password: cisco

telnet_level: 2

Copy this file along with the Firmware files (Download the zip file from http://www.cisco.com/cgi-bin/tablebuild.pl/ip-7900ser) and extract it to the TFTP Folder. And save the SIP.cnf file in the same folder.

You dont have to use CallManager for it, but any other TFTP Server should also work.

Have the DHCP Server give the IP Address of this host in option 150.

Ian Cowley Mon, 02/26/2007 - 03:09

Unfortunately when it boots it picks up the HDCP and TFTP info OK, but then tries to download the CM related files not the SIP files

(SIP files and SIPdefault.cnf SIP[MAC].cnf)

Ian Cowley Mon, 02/26/2007 - 09:06

Ironically I want the username and password to try and reset the phone back to SIP.

Anyone know what the username/password is?(default/user isn't it)

Or what an HTTP URL is that by-passes the logon

IC

Ian Cowley Mon, 02/26/2007 - 15:27

Alex

Thanks I have all this.

The phone boots up with DHCP OK and accesses the TFTP server, but tries to download the various, app*, jar* and sm* files. It ignores the SIP files as configured in OS79XX.TXT

Its looking like a fancy doorstop!

Ian Cowley Tue, 02/27/2007 - 05:49

Hardware reset the phone

Power cylce holding '#'

1223456789*0#

TFTP log shows

Feb 27 13:42:03 tftp.rsm.local atftpd[14400.-1208620112]: Serving term41.default.loads to 172.20.1.126:49152

Feb 27 13:44:44 tftp.rsm.local atftpd[14400.-1208620112]: Serving term41.default.loads to 172.20.1.126:49152

Feb 27 13:46:26 tftp.rsm.local atftpd[14400.-1208620112]: Serving term41.default.loads to 172.20.1.126:49152

Phone stays with the 'RAF'[circle with dot] symbol and reboots every few mins.

IanC

Paolo Bevilacqua Mon, 02/26/2007 - 15:59

All failing (but it should not fail) you can try one last method (I take no respectabilities if that turns the phone in a dead doorstop):

Rename the sip files as the files that the telephone is trying to download. That should definitely SIPpify it.

Ian Cowley Tue, 02/27/2007 - 12:53

PB

This was on the right lines I think.

The file cmterm-7941_7961-sip.8-0-4SR3.zip

Contains all the apparent good stuff:-

---------------

apps41.1-1-3-31.sbn

cnu41.3-1-3-31.sbn

cvm41sip.8-0-3-33.sbn

dsp41.1-1-3-31.sbn

jar41sip.8-0-3-33.sbn

SIP41.8-0-4SR3S.loads

term41.default.loads

term61.default.loads

---------------

By running tcpdump I was able to see the 7941G is asking for

1. term41.default.loads OK ..gets that

2. jar41sip.8-0-3-34.sbn NO .. wrong name ... so renamed it and its gets it OK now.

3. cnu41.3-1-3-32.sbn NO .. wrong name .. so renamed it and it fails probably a CRC or something

Anyone got the proper cmterm file, or individual files) as I can't find them on CCO

IC

Ian Cowley Tue, 02/27/2007 - 13:21

PB

The cmterm software I had just didn't work

Eventually found cmterm-7941_7961-sip.8-2-1.zip

That had only one spelling mistake! jar... spelt as Jar...

and I have a booted SIP firware unit with the menus. Keeps looking for:-

XMLDefault.cnf.xml

SEP00192FC56DA4.cnf.xml

CTLSEP00192FC56DA4.tlv

I know that the 1st 2 are the new xml templates. I'll have to search for info on the last

IanC

Actions

This Discussion