7941 Won't Pull Firmware Updates

Unanswered Question
Feb 22nd, 2007

Hi,

I have a newly installed 7941G that won't pull firmware updates. I had one remaining 7940G in my test lab, so I replaced it with a new 7941G. I Changed the ephone type and mac address to the new phone, reset and restarted the phones and the router numerous times. It just won?t pull the newer firmware. I have another 7941G that has been working fine all along.

Running CME.

Any ideas?

Thanks

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
mchandak Fri, 02/23/2007 - 13:44

does the phone pick the info from the DHCP ?? What is being displayed on the phone. Incase the phone is not picking up the IP Address, assign it IP Address Manually, point the TFTP Server to the CME. Also, if this does not work, please mention what is being seen on the phone and "debug ephone register mac-address " and "#debug tftp events"

mchiaravalle_2 Thu, 03/01/2007 - 16:31

Hi thanks for replying.

Yes the phone does display correct DHCP, TFTP, and Default Router IP's. and subnet. However Load File, App Load ID, JVM load ID, OS Load ID, and Boot Load ID are all the older factory loads, and DPS Load ID is missing.

I compared debug tftp events and debug ephone register mac-address with a good 7941G and could only see the one interesting FAILED: line. What do you think?

Thanks

Paolo Bevilacqua Thu, 03/01/2007 - 17:36

If you do "more system:/its/XMLDefault7941.cnf.xml" do you see the correct load information ?

Beside the phone is running 7.0(3)s that should be fine for CME 4.0

mchiaravalle_2 Fri, 03/02/2007 - 07:54

Yes, the output of "more system...." does show the correct load (SCCP41.8-0-4ES4-0-1S)and this is what my other 7941G's are on. The bad one has a load of (TERM41.7-0-3-OS.

I agree with you that running 7.0(3) should work, but this was causing other issues in the field and in our lab. We had to upgrade to 8.0 loads because our 7941G/61G's would not display the correct time or the Local Speed Dial Directory that I created. This forum suggested upgrading to 8.0 and it worked. This newly installed 7941G is exibiting the same two problems.

Is ther a way to delete out the firmware on these phone so maybe then it would pull the correct one?

Thanks

12.4(4)XC4

CME 4.0(3)

Paolo Bevilacqua Fri, 03/02/2007 - 10:52

Yes I agree there are issue with older loads and in fact it might be me that suggested to upgrade :)

Is the time stamp in the config file correct ? Perhaps the phone has been initilized with a timestamp with a future date and is ingoring the current one.

Have you tried the reset sequence at boot ?

holding down "#" as it powers up at which point you then dial 123456789*0#.

Then there is another sequence for reset but with the order of keys swapped around, let me know if you can't find it.

mchiaravalle_2 Fri, 03/02/2007 - 11:38

Yes the factory reset sequence did the job. I feel kinda dumb for not trying that earlier.

Thanks very much.

Actions

This Discussion