Trunk Speed/Duplex settings

Unanswered Question
Feb 22nd, 2007

Trunk doesnt establishes when the ports are set to Manual 100 Mbps and Full Duplex.

combinations

Sw 1 -> Sp - 100, Du - Full

Sw 2 -> Sp - 100, Du - Full

Result - trunk fails

Sw 1 -> Sp - A, Du - A

Sw 2 -> Sp - 100, Du - A

Result - trunk establishes in Half duplex, 100 MBPS

why the trunks do not establish when both sides are set for manual speed and duplex? it is recommended this way but trunk doesnt establish.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
purohit_810 Thu, 02/22/2007 - 18:02

First How can you say trunk don't establish?

Please tell me error or behaviour ... that switch shows?

Regards,

Dharmesh Purohit

jaravinthan Mon, 02/26/2007 - 12:49

The switch ports are now set to Auto for speend and duplex. In this case the trunk establishes between switches if the switch port mode is set to trunk. If at one end the spped or duplex is set manually the trunk disconnects and the port status says "disconnected"

glen.grant Thu, 02/22/2007 - 19:07

My guess is that you have auto mdix on and you are using a straight thru cable . Auto mdix will only work when the ports are set as auto . Turn auto mdix off on the ports , use a crossover cable and you should be able to hardcode the ports if you want though you really don't need to between pieces of cisco gear as their autonegotiate function works well. If you set both ports in your current setup to auto for speed and duplex the trunk should work normally also .

jaravinthan Mon, 02/26/2007 - 12:53

i am not sure of the cable as these devices are remotely managed. Auto mdix is not on. The port configuration is as follows

== port on one end==

switchport trunk encapsulation dot1q

switchport mode trunk

macro description cisco-switch

auto qos voip trust

spanning-tree portfast trunk

spanning-tree link-type point-to-point

==

==settings on other end==

switchport trunk encapsulation dot1q

switchport mode trunk

macro description cisco-switch

auto qos voip trust

spanning-tree link-type point-to-point

===

glen.grant Mon, 02/26/2007 - 17:41

Are you sure auto mdix is not on ? Normally it will say it on the port interface if it is not on . there is no other reason 2 hardcoded ports would not come up as trunks...

Actions

This Discussion