CCM - Presence Server - LCS

Unanswered Question
asigachev Mon, 07/23/2007 - 08:01

hi fellas

I have the same task. I've performed all the configuration tasks. Now i can make a call on directory number from Microsoft Communicator and the associated IP Phone rings. But another communicator doesn't catch the call, only the remote phone rings.

The problem occurs when CUPS tries to send call info to MS LCS. Nothing comes to LCS.

What i see in traces is:

07/20/2007 05:36:05.398 ESP|PID(20290) sip_dns.c(830) "SRV" Query for WS03R2EEEXCHLCS.contoso.com failed

|

07/20/2007 05:36:05.400 ESP|PID(20290) sip_dns.c(800) Type "A" query for WS03R2EEEXCHLCS.contoso.com failed

WS03R2EEEXCHLCS.contoso.com is the actual name of MSLCS server and my domain server as well. But i guess the DNS queries should go to contoso.com not WS03R2EEEXCHLCS.contoso.com. The thing is this name doesn't appear in any configuration of either CCM or CUPS and I don't see it in packet sniffer output also. Does anyone know where CUPS gets this name?

ivillagomez Fri, 08/03/2007 - 10:00

I had the same problem and instead of using a certificate i use TCP very easy and works very good.

1 Microsoft employee told me that in order to recognize the certificate from MS you need an application to sign the certificate in Unix Format.

tahequivoice Thu, 08/02/2007 - 12:24

I tried and gave up, could not get the servers to play nice with each other. Went the full Cisco route using the Personal Communicator, and still having issues getting them all to play nice. At least I got phone control working, even though logins fail.

asigachev Thu, 08/02/2007 - 13:55

I think i have won. Everything works. I can send you screenshots of my settings if needed.

ybanezc Tue, 12/04/2007 - 01:39

Hi

Can you please send me the screenshot because Im also doing this one.

thanks

feisalb Thu, 01/24/2008 - 04:05

Hello Asigachev

Can you also send me the screenshots of your configuration. I have the problem where the MOC client is not being paired with the Cisco phone.

Moc rings out using but destination moc does not ring only the destination cisco phone. And the calling moc displays "dialling" even thought the call connects.

Thanks

Feisal

ivillagomez Fri, 08/03/2007 - 10:01

The guide is very good, just need to formet about signing a certificate.

I have all the screenshots for this instalation, and i also have the screenshots of this installation using CCM 6.0 and Presence 6.0

jchorlton Fri, 09/07/2007 - 11:08

Is there any chance someone could send me a set of screen shots? The CCM 5.1/1.0.3 version would be fine.

Thanks

Tommer Catlin Mon, 12/03/2007 - 10:56

has anyone got this to work? I have a CUCM 6 and CUPS and LCS 2005. I have the CUPS/CUCM working and integrated. (or so it seems)

Im trying to figure out how the MOC client actually works with CUPS. I have my SIP extension programmed into the MOC client for remote call control, but on the MOC client, "Call" is grayed out, so I cant dial anything. I figure if the CALL button was at least there, then maybe it would work.

Anyways... thought I would post

Tommer Catlin Tue, 12/04/2007 - 09:25

yeah, I found the new guide. Going through it last night. seems to be something on the LCS side I believe. My Troubleshooter is all green.. so I know CUPS/CUCM is working.

Tommer Catlin Wed, 12/05/2007 - 08:36

Just to let everyone know,I got mine working. The problem was that LCS user name is what the CUPS is looking for to match with the CUCM End User name. THey say "Active Directory account" but that is not true, I had to use my LCS account name. (what you use to sign into MOC) Then I changed my CUCM End User account and it all started to work.

NT Account = BAD

MOC Sign in Account = Good!

MOC Signin Account= CUCM End User account

cheers!

edip.gumuskaya Wed, 01/02/2008 - 09:46

Hi,

I have OCS 2007, CUP 6.02 and CUCM 5.1.2.

I cannot get the OCS 2007 integrated with CCM.

I have followed the Documentation and the Picture Screenshot that is distributed on the Cisco Website.

I have an error message "Cannot connect to the phone system"

Anyone got any ideas on this?

Thanks,

edip.gumuskaya Wed, 01/02/2008 - 10:14

Thanks for replying

I have the OCS 2007 Client connected on my workstation

With the username: [email protected]

It logins ok and I am to contact other users in the organisation using IM facility.

In the notification of the client. I have an error:

No Phone System Connection - Click to display. I click then get an error.

"Cannot connect to the phone system. The call control server may be temporarily unavailable"

Under the phone integration advanced options. I have configured:

Remote call control URI (sip): sip:[email protected]

Phone URI (tel): tel:2750;phone-context=dialstring

Callmanager Config:

I have configured a SIP trunk to the CUPS Server

i have created a CTiGw with the correct roles

i have created an application rule for 5 number striping the first character which "+"

CUPS Config

*I have added the ACL incoming / Outgoing. I have even included a wildcard in each of theses ("*")

*The presence Gateway is set to the CCM IP address

*The proxy server is set to On and Preferred Proxy Listener: Default Cisco SIP Proxy SIP Listener

*AXL username added as the CCMadmin

* I have added the Preferred Proxy Listener *CTiGw Gateway configured with username and password pointing to the publisher and subscriber.

*MOC assigments have been assignment

I can assign CUPS presence from the phone Service button

OCS Config

I have added a static route *@* to go to the CUPS server on port 5060 TCP

The user has been enabled with the same settings as in the client settings

User Details in OCS:

sign-in name: sip:lon-admin @ domain.local

Server or pool: OCS.domain.local

Server URI: sip:[email protected]

Line URI: tel:2750;phone-context=dialstring

Enable Remote call control

Active Directory Config

User logon name: lon-admin @domain.local

Let me know what else you need? Screenshots??

Thanks

My msn is [email protected] if that helps

ryan_oconnell Wed, 01/09/2008 - 13:40

Do you also need this application for signing certificates for CUPS 6 / CM 6 to OCS with MOC?

Tommer Catlin Wed, 01/09/2008 - 13:42

It's not required because you are not use TLS. If you are using TLS, then you may need certs. I ran without certs. I would recommend getting it running with just IP no TLS, then once running try locking it down.

ryan_oconnell Wed, 01/09/2008 - 13:52

Yeah I'm having an issue with my OCS to CUPS / CCM 6 integration using MOC for RCC.

When I try to call another user from within MOC that is also setup for RCC I get a fast busy on MOC with the following error message

'Cannot locate "John Doe"' , There may be an error in the address, Check the address and then try again"

The number assoicated to John Doe is +2004, and I have applicaiton rule in CCM to strip the +. But I think the integration is not working anyway since I'm getting busy signal coming from MOC.

Has anyone experienced this?

Tommer Catlin Wed, 01/09/2008 - 13:58

The way I found out my problems was to use the Real time monitoring tool on my desktop and attach it to Presence. Watch the incoming SIP invites from OCS and you will see what is actually being sent. They you do not have to guess what is being stripped or added in the dial plan.

ryan_oconnell Wed, 01/09/2008 - 14:06

Good idea, yeah I feel like I'm flying blind with this stuff, no debugs to tell me what's going wrong. I wonder if you can use RTMT to see what's going on with the CTI stuff as well.

As a follow up to my issues. My MOC client is not giving me issues when I tell it to RCC my CISCO phone but it is simply ignoring anything my phone does. If I ring my phone it doesn't give me a "toast" that a new call is coming in. If I CFWD my phone, my MOC indicator turns green, but my IP PHONE doesn't cfwd.

One other issue I'm having not sure if it is related or not, but in CUPS 6 when I do "System" "Troubleshooter" the "sync agent" comes back failed. It says to got to servicability to start the Sync agent service but when I do this the service will not start.

Thoughts?

feisalb Thu, 01/24/2008 - 04:12

Hello Ryan et al

I had a similar issue with the Sip proxy server not running. Used the bug tool kit to find bug id CSCsi40623, syntax error on Proxy acl.

Haven't checked the bug tool kit for your specific service but its a good place to go if you already haven't done so.

t.hartley Mon, 03/17/2008 - 03:00

Ryan,

Did you make any progress with your problem ?

I have a similar situation here. Basically everything works from MOC -> CUCM (ie RCC & call forward etc)

but not from CUCM -> MOC: if I hang up a phone that was dialled via MOC, MOC doesn't know the call has been ended, or if I cancel cfwd on a handset it doesn't cancel on MOC.

Any ideas ?

Actions

This Discussion