HOW TO LOAD BALANCE TRAFFIC WITH OSPF?

Unanswered Question
Feb 23rd, 2007

Hello

I have the following scenario

N. 2 Router 7513

N.2 ATM link of 24 Mb/s

In this two links the traffic ( the Ospf cost is the same and is set to default)pass for 90% only on the one link

ATM and the other is around 10%.

The problem is to balance this two WAN ATM Links ...

I would like to have 60 % and 40 % on the two links is it possible using OSPF ??( I know its possible under BGP )

Any suggestion is appreciated !

Regards

Alberto

FIRST ATM

interface ATM8/1/0.33 point-to-point

description PVC verso TO0MA02P P2/8

bandwidth 24000

ip address 10.224.0.x 255.255.255.252

ip mtu 1500

pvc 0/33

vbr-nrt 26400 24000 33

oam-pvc manage

oam retry 3 3 3

encapsulation aal5snap

Second ATM (90% of traffic )

interface ATM8/1/0.36 point-to-point

description PVC verso TO0MA02P P3/10 ---

bandwidth 24000

ip address 10.224.0.x 255.255.255.252

ip mtu 1500

pvc 0/36

vbr-nrt 26400 24000 33

oam-pvc manage

oam retry 3 3 3

encapsulation aal5snap

++++++++++++++++++++++++++++

Routing ( similiar for both routers)

router ospf 69

log-adjacency-changes

area 9 range 10.156.0.0 255.255.192.0

area 9 range 10.156.64.0 255.255.192.0

area 9 range 10.156.128.0 255.255.192.0

area 9 range 10.156.192.0 255.255.192.0

network 10.156.215.0 0.0.0.15 area 9

network 10.156.215.16 0.0.0.15 area 9

network 10.156.255.52 0.0.0.3 area 9

network 10.156.255.76 0.0.0.3 area 9

network 10.156.255.0 0.0.0.255 area 9

network 10.224.0.112 0.0.0.3 area 0

network 10.224.0.116 0.0.0.3 area 0

network 10.224.1.36 0.0.0.3 area 0

network 10.255.0.15 0.0.0.0 area 9

!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (2 ratings)
Loading.
mheusinger Fri, 02/23/2007 - 02:24

Hello,

can you post the routing tables as well?

OSPF will load balance two pathes with exact the same metric by default. In addition you need to check your CEF load balancing, which is deciding, which traffic goes through which link if both pathes are in the routing table.

The default is "per destination" but can be changed to "per packet". So a traffic analysis might help to understand the different load on the two links.

A good starting point for reading is "How Does Load Balancing Work?"

http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a0080094820.shtml

and "Load Balancing with CEF"

http://www.cisco.com/en/US/products/hw/modules/ps2033/prod_technical_reference09186a00800afeb7.html

Hope this helps!

Regards, Martin

intesiseng Fri, 02/23/2007 - 02:30

Hello

thanks you for yor prompt reply

The routing table is a list of 3 pages !!!!

We have around 700 cisco in our WAN

The point of Cef was also considered . You intend that I have to change the Ip cef per destination and then analyze the traffic?

Or this can also distribuite better the balancing over this 2 links?

Thanks a lot !

intesiseng Fri, 02/23/2007 - 02:32

wpoz-noc-01-abr# sh ip cef 10.55.207.11

10.55.192.0/18, version 1256, epoch 0, cached adjacency to ATM8/1/0.36

0 packets, 0 bytes

via 10.224.0.117, ATM8/1/0.36, 0 dependencies

next hop 10.224.0.117, ATM8/1/0.36

valid cached adjacency

Router 2

wpoz-noc-02-abr#sh ip cef 10.55.207.11

10.55.192.0/18, version 9114, epoch 0, cached adjacency to ATM8/1/0.33

0 packets, 0 bytes

via 10.224.0.201, ATM8/1/0.33, 0 dependencies

next hop 10.224.0.201, ATM8/1/0.33

valid cached adjacency

mheusinger Fri, 02/23/2007 - 02:43

Hi,

Thank you for the "sh ip cef" posting of only ONE network :-)

As you have two routers (did not realize this o far), load balancing will be decided elsewhere. Each of your routers will just forward the traffic down its own WAN link. If 90% of all traffic is sent to router one then 90% will go through link 1.

So the real question is: How does the traffic get to the WAN routers? HSRP (f.e. use GLBP instead to achieve better load balancing), OSPF to other routers?

Regards, Martin

intesiseng Fri, 02/23/2007 - 02:56

Dear

I know how GLBP works. But its a LAN side protocols

So I need to replace all the VLAN balancing in the WS-C6513 Switch ( On the routing Module )

Do you think that make a round- robin over a GLBP MULITIGORUP can fix my problem ?

Here it is the scenario in the MSFC of the 6513.

************************************

wpoz-csb-02-cstel#sh standby

Vlan1 - Group 2

Local state is Listen, priority 70, may preempt

Hellotime 3 sec, holdtime 10 sec

Virtual IP address is 10.156.242.254 configured

Active router is 10.156.242.251, priority 200 expires in 7.472

Standby router is 10.156.242.250 expires in 7.320

0 state changes, last state change never

IP redundancy name is "hsrp-Vl1-2" (default)

Vlan10 - Group 10

Local state is Listen, priority 70, may preempt

Hellotime 3 sec, holdtime 10 sec

Virtual IP address is 10.156.205.254 configured

Active router is 10.156.205.250, priority 100 expires in 9.684

Standby router is 10.156.205.251 expires in 9.172

0 state changes, last state change never

IP redundancy name is "hsrp-Vl10-10" (default)

Vlan20 - Group 20

Local state is Listen, priority 80, may preempt

Hellotime 3 sec, holdtime 10 sec

Virtual IP address is 10.156.207.254 configured

Active router is 10.156.207.251, priority 100 expires in 8.260

Standby router is 10.156.207.250 expires in 7.908

0 state changes, last state change never

IP redundancy name is "hsrp-Vl20-20" (default)

Vlan30 - Group 30

Local state is Listen, priority 70, may preempt

Hellotime 3 sec, holdtime 10 sec

Virtual IP address is 10.156.201.254 configured

Active router is 10.156.201.250, priority 100 expires in 8.924

Standby router is 10.156.201.251 expires in 8.504

0 state changes, last state change never

IP redundancy name is "hsrp-Vl30-30" (default)

Vlan40 - Group 40

Local state is Listen, priority 80, may preempt

Hellotime 3 sec, holdtime 10 sec

Virtual IP address is 10.156.211.254 configured

Active router is 10.156.211.251, priority 100 expires in 7.976

Standby router is 10.156.211.250 expires in 7.532

0 state changes, last state change never

IP redundancy name is "hsrp-Vl40-40" (default)

Vlan60 - Group 60

Local state is Listen, priority 70, may preempt

Hellotime 3 sec, holdtime 10 sec

Virtual IP address is 10.156.214.254 configured

Active router is 10.156.214.250, priority 100 expires in 8.956

Standby router is 10.156.214.251 expires in 7.588

0 state changes, last state change never

IP redundancy name is "hsrp-Vl60-60" (default)

Vlan220 - Group 192

Local state is Listen, priority 70, may preempt

Hellotime 3 sec, holdtime 10 sec

Virtual IP address is 10.156.192.254 configured

Active router is 10.156.192.250, priority 100 expires in 8.044

Standby router is 10.156.192.251 expires in 7.556

0 state changes, last state change never

IP redundancy name is "hsrp-Vl220-192" (default)

Vlan221 - Group 193

Local state is Listen, priority 80, may preempt

Hellotime 3 sec, holdtime 10 sec

Virtual IP address is 10.156.193.254 configured

Active router is 10.156.193.251, priority 100 expires in 7.508

Standby router is 10.156.193.250 expires in 7.756

0 state changes, last state change never

IP redundancy name is "hsrp-Vl221-193" (default)

........

....... etc ..etc..

************************

Thanks

mheusinger Fri, 02/23/2007 - 03:40

Hi,

my first question would be to understand why traffic distribution is 90-10 at the moment. Replacing GLBP with HSRP can help from the LAN side. The rest is IP routing. I still do not understand your topology. There is one 6513 as a default gateway with all the PCs connected (through L2 trunks maybe)?

And the 6513 has one link to each WAN router?

Or does it look different? Load balancing is strongly dependant on the underlying topology and involved protocols.

Regards, Martin

intesiseng Fri, 02/23/2007 - 05:38

Hello

you can find the info you need in the attach

Regards

What I had thought is to place this command on the both sides of the WAN ATm links

What do you think about:

Router(config-if)# ip load-sharing per-packet

in the attach I place a sample ( Sorry its not a Visio doc )!

mheusinger Fri, 02/23/2007 - 02:24

Hello,

can you post the routing tables as well?

OSPF will load balance two pathes with exact the same metric by default. In addition you need to check your CEF load balancing, which is deciding, which traffic goes through which link if both pathes are in the routing table.

The default is "per destination" but can be changed to "per packet". So a traffic analysis might help to understand the different load on the two links.

A good starting point for reading is "How Does Load Balancing Work?"

http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a0080094820.shtml

and "Load Balancing with CEF"

http://www.cisco.com/en/US/products/hw/modules/ps2033/prod_technical_reference09186a00800afeb7.html

Hope this helps!

Regards, Martin

intesiseng Fri, 02/23/2007 - 07:54

Wait for your confirm about my propose:

wpoz-noc-02-abr# conf t

Enter configuration commands, one per line. End with CNTL/Z.

wpoz-noc-02-abr(config)#int ATM8/1/0.33

wpoz-noc-02-abr(config-subif)#ip load-sharing ?

per-destination Deterministic distribution

per-packet Random distribution

wpoz-noc-02-abr(config-subif)#ip load-sharing per-packet

ruwhite Fri, 02/23/2007 - 12:55

I would be careful with per packet load sharing.... In most situations, per packet load sharing will cause TCP packets to be received our of order, which actually produces lower performance even with higher network utilization.

:-)

Russ

intesiseng Mon, 02/26/2007 - 01:09

Hello

so what you suggest ?

GLBP on the LAN side?

This need to modify the whole architecture.

Thanks

Alberto

ruwhite Mon, 03/05/2007 - 05:15

As long as both of the routes are installed in the local routing table, it doesn't matter what routing protocol installs them--OSPF and BGP act the same in this regard. If you are getting 90/10 load sharing, you might want to try the "tunnel" algorithm for per destination load sharing under CEF, as a start.

Another option would be to try and change the "seed" CEF is using to run its load sharing algorithm off of.

:-)

Russ

rohan.jhaveri Mon, 03/05/2007 - 22:19

Hi

From the diagram I understand that the 2 routers are not interconnected directly,if done then that would solve the problem.If possible interconnect 2 routers with a cross cable,make them ospf neighbor,tweak the cost for the destination router's loopback(router connected to other end of the WAN link) such that for that loopback address router sees 2 paths one via its own link and second via the second interconnected router.This would cause traffic coming to R1 to be shared with R2 via cross cable.Traffic coming to R2 wont be shared with R1 as tweaking of cost is done only on R1.Thi sshould result in a utilisation of 60/40.

Actions

This Discussion