LinkSys SPA941 with CME

Unanswered Question
Feb 23rd, 2007

i have registred de SPA941 in the CME, but outgoing call doesn't work.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.7 (3 ratings)
Loading.
Paolo Bevilacqua Fri, 02/23/2007 - 15:43

Hi,

Until CME supports third-party SIP phones (LAter this years, and yes linksys is thrid-party to CME eyes), you will need an IP-to-IP gateway image for SIP-phone to ITSP service. Calls to PSTN should work with the standard image, would you post output of "debug ccsip message" and "debug vpm signal"

k.elharkati Mon, 02/26/2007 - 08:49

i have modified the configuration, i still have the same problem in outgoing calls, but now the call is not rejected, i call my mobile phone, the linksys is ringing but not my mobile, and it's also the same problem for others destinations !!!!

you will find in attached files the debug messages for incoming and outgoing calls.

Paolo Bevilacqua Mon, 02/26/2007 - 09:21

hi,

Looks like the ITSP (not surprisingly) wants authentication for outgoing calls, you should configure authetication username/password/realm under sip-ua.

I'm a little surprised that the linksys is registering OK to CME, which CME is this ? can you post output of "show voice register statistics" ?

Finally it seem that the CME registration to ITSP also fails, if you need registration let us know, else you can just disable with "no-reg" under "voice register dn".

k.elharkati Mon, 02/26/2007 - 10:14

i have configured the same authetication username/password/realm that i have under dial-peer voice 20209003 pots under sip-ua, and i disabled no-reg under voice register dn.

Now i have one call works correctly, and the second no with the same problem, it's rining witout ringing in the called phone.

Paolo Bevilacqua Mon, 02/26/2007 - 10:44

Ok, now one should check again with "debug ccsip message" that CME is providing authentication to the ITSP for outgoing calls.

The fact that you have ringback in the calling phone just means the chain of session progress isn't working correctly across networks, as the correct behavoir should be silence before actual ring/ringback.

Also your pots dial-peer are trying to register to ITSP and as this not wanted you should configure no-register for them as well.

k.elharkati Tue, 02/27/2007 - 10:20

hi,

now the LinkSys SPA941 work correctly with CME for both: outgoing/incoming calls, you find the configuration in the attached file.

i want to add others LinkSys phones to the CME, i want to ask you if i can add others authentication username/password/realm under sip-ua ???

the objectif is to have each phone registred with it own authentication username/password/realm.

thanks for your help.

Paolo Bevilacqua Tue, 02/27/2007 - 13:20

Hi,

authentication in sip-ua is for placing outbound calls to ITSP. Local phones do not register directly to the ITSP.

Instead, configure them as voice register pool devices with username and password (no realm needed).

Remember to rate useful posts.

k.elharkati Wed, 02/28/2007 - 08:14

hi,

can i use the same authentication userna/pass/realm under sip-ua for all sip phone registred in CME to make outging calls ??

Paolo Bevilacqua Wed, 02/28/2007 - 08:40

Yes, the CME will use authentication as configured in sip-ua for all outgoing calls using sip-server.

This is not directly related to registration, that is used only to tell ITSP where to receive calls.

In other words, in most cases you don't need to be registered to place calls.

k.elharkati Thu, 03/01/2007 - 09:37

HI,

now i have 2 LinkSys SPA941 registred in the CME, with extensions 1000 and 2000.

my ITSP guives mi this number 020209003 that i configured it under a SIP-UA, and i have configured translation rules for outgoing calls, and it work correctly, both 1000 and 2000 translate with 020209003.

but i still have problem in incoming calls, i can't join any phone even if i configured translation rule for incoming calls.

Attachment: 
Paolo Bevilacqua Thu, 03/01/2007 - 10:05

Hi,

whhat happens is that dial-peer 2 is not being used, because it needs to have "incoming called-number 020209003" and no "destination-pattern".

Once this is done it should correctly translate the called number to extension per profile "ENTRANT" and that should make phone to take the call.

I'm not sure why the phone replies with "bad request" instead of "not found", but the first step is the above anyway.

k.elharkati Fri, 03/02/2007 - 04:12

it's crazy,

i still have the same problem and i have the same messeges in debug ccsip, even if i configured the "incoming called-number 020209003" under "dial-peer 2" and i disabled "destination-pattern" !!!

Attachment: 
Paolo Bevilacqua Fri, 03/02/2007 - 10:59

Can you check with "debug ccsip message" that the phone is now being called with the correct extension number ?

And compare the message when calling from ITSP with one local call to see what is the difference.

k.elharkati Tue, 03/13/2007 - 05:31

now all works correctly and fine,

the Linksys SPA 941 are registred in the CME and the CME is registred to the ITSP with sip-ua, and incoming/outgoing calls works witout problems.

there are 2 configuration , one for translation using the same number registred in the ITSP for many linksys phones and the second configuration using one sip-ua for one linksys.

netflight Thu, 02/28/2008 - 03:08

hello! i need some help! i have one linksys spa 921 and UC500. i can't put my phone work. i'll send you my running configuration. what iam doing wrong on my sip phone ?

Attachment: 
Paolo Bevilacqua Thu, 02/28/2008 - 03:40

What the phone is doing ? If it is local to the cme lan you don't even need username and password and it should register.

Paolo Bevilacqua Thu, 02/28/2008 - 06:25

As a minimum, your number, proxy and register address.

If you do not want to do these things, use cisco IP phones, as they are controlled by the router and do not need additional configuration.

netflight Thu, 02/28/2008 - 07:45

i have been try that too, but nothing. In the web of the phone i have to configure any user or password? i didn't see that menu

netflight Fri, 02/29/2008 - 00:40

the configuration on the router are all right ? i don't have line on the phone. i have configurated the phone on web brower but still don't work! what iam doing wrong ?

Paolo Bevilacqua Fri, 02/29/2008 - 03:28

Router seems right. Do the phone register ok ?

"debug ccsip message" and "term mon" will tell.

Actions

This Discussion