Error copying flash

Unanswered Question
Feb 24th, 2007

Hello All,

I have a 3640 router with 128MB DRAM and 32MB FLASH. It is currently running IOS c3640-jk9o3s-mz.123-19.bin. I am trying to copy a new image into flash (c3640-ik9o3s-mz.124-7.bin) and receive the following output:

%Error copying flash:c3640-ik9o3s-mz.124-7.bin (No space left on device)

This is what I get when a show flash command is issued:

3640_1#sh flash

System flash directory:

File Length Name/status

1 25690048 c3640-ik9o3s-mz.124-7.bin [deleted]

[25690112 bytes used, 7340028 available, 33030140 total]

32768K bytes of processor board System flash (Read/Write)

How come the entire image does not fit into flash when there is enough room?

Thank you in advance.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
ahmednaas Sat, 02/24/2007 - 07:32

are copying using tftp?

If you have a copy of the old image, try to load it and see what happens.

MikeC5000 Sat, 02/24/2007 - 07:35

I am using tftp. I have no problem restoring 12.3(19) when 12.4-5(a) fails. I also cannot execute the format command to reformat the flash memory.

ahmednaas Sat, 02/24/2007 - 07:55

This might indicate a faulty flash. The fault is at a higher address than the size of the smaller old image. You hit the faulty spot when you copy the larger image.

Also make sure the image is not corrupt. It is a zipped file, so try opening it with winzip or winrar. If you can see the uncompressed file inside then it is ok.

Also you can test the image by loading it in Dynamips.

MikeC5000 Sat, 02/24/2007 - 08:43

I can decompress the image fine. I was thinking it was the flash. I wanted to get the opinions of my peers to make I'm not crazy. I appreciate everyone's contribution to this post. Thank you all.

b.petronio Fri, 03/02/2007 - 17:10

Im i seeing this wrong ?

3640_1#sh flash

System flash directory:

File Length Name/status

1 25690048 c3640-ik9o3s-mz.124-7.bin [deleted]

Try to squeeze command the (deleted) image in the flash, and try again.

MikeC5000 Sat, 03/03/2007 - 05:03

I have done that already. It still fails. I have an RMA going for my flash memory. I will post what happens. Thank you all for your efforts.

cratejockey Sat, 03/03/2007 - 08:12

I just wanted to chime in really quick. It looks like you have tried all the normal stuff and your RMA of your flash is the logical step. I am assuming that your 32MB of flash is internal correct? If that is the case the 3640 has two slots on the front for Flash Cards. I have a bunch of 16 and 24MB that I keep around to do basic testing if internal flash is flaky. Also you can pick up 128MB Simpletech Flash Cards in the PC Card format that will work in this router. I know that there are several of the images that require at least 64MB. Good locations for these simpletech 128 cards are;

http://www.thenerds.net/index.php?page=productpage&pn=STIATAFL128

http://www.cdw.com/shop/products/default.aspx?EDC=108457

Compared to the Cisco branded PC Card Flash Cards these are a bargain at about $70. I also have tried using Compact Flash to PC Card Adaptors and for whatever reason Cisco equipment does not like this and wont read the memory.

Best of luck.

www.staticnat.com

Actions

This Discussion