HSRP Problems

Unanswered Question
Feb 25th, 2007

Hi misters, I configured a hsrp in a 1800 router, the router funcion perfect, but after 4-5 hours, the data stop to go to the fibre channel, but I still can ping the other line router and the show standby all still show me the active router 1800.

Here is the hsrp conf from the two routers from my location, anyone could se a problem in this conf ?

thanks.

backup router

interface FastEthernet0/0

description Conexao DMZ Actionline

ip address 192.168.202.8 255.255.255.0

speed 100

full-duplex

standby 31 ip 192.168.202.10

standby 31 preempt

standby 31 track FastEthernet0/1 11

!

interface FastEthernet0/1

description Conexao WAN Fibra Telefonica

ip address 172.16.100.25 255.255.255.252

no ip redirects

no ip unreachables

no ip proxy-arp

speed 10

full-duplex

no mop enabled

active router

interface FastEthernet0/0

description CONEXAO COM LAN

ip address 192.168.202.9 255.255.255.0

speed auto

full-duplex

standby 31 ip 192.168.202.10

standby 31 priority 110

standby 31 preempt

standby 31 track Serial0/0 11

standby 31 track Serial0/2 11

standby 31 track Serial0/1 11

!

interface Serial0/0

description CONEXAO COM WAN

bandwidth 2048

ip address 172.16.100.9 255.255.255.252

ip load-sharing per-packet

encapsulation ppp

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/1

description CONEXAO COM WAN

bandwidth 2048

ip address 172.16.100.13 255.255.255.252

ip load-sharing per-packet

encapsulation ppp

!

interface Serial0/2

description CONEXAO COM WAN

bandwidth 2048

ip address 172.16.100.17 255.255.255.252

ip load-sharing per-packet

encapsulation ppp

!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Richard Burts Sun, 02/25/2007 - 09:18

Eduardo

I agree that looking at the syntax of your HSRP I do not see a problem. But since we do not know your topology or exactly what you want it to accomplish we can not judge whether there are any issues with it.

I will note that the standby router is tracking the other FastEthernet interface. Tracking an Ethernet interface can be problematic because there are many situations in which you lose the ability to communicate with devices over the Ethernet but the Ethernet does not lose link and therefore does not go protocol down. Until the interface goes protocol down, then track will not detect a problem. I do not know if that is part of your issue or not.

The primary router tracking point to point interfaces with PPP encapsulation would not have this issue.

Also I am not clear about your description of the problem. You say that after several hours that data stops going to the fibre channel. But I can not tell what or where the fibre channel is. Perhaps you can clarify a bit.

HTH

Rick

duzolini01 Sun, 02/25/2007 - 09:34

I have a site in Campinas and other in Cajamar.

All my applications are in Cajamar.

I have a fibre channel 10 mb and other 3 link with 2 mb.

I use the fibre as the active link but after I started it, above some hours, I can?t open the app from Campinas, but I still can telnet the router in Cajamar.

So if a Change the priority to the router with 3 links, everything works fine and don t stop.

Do you think I must remove the track or not ?

silrodri05 Fri, 03/23/2007 - 11:46

Eduardo,

You can change the track configuration, if you use "track 31 interface Fastethernet0/1 line-protocol", so you can change to "track 31 interface Fastethernet0/1 ip routing" or even to "track 31 ip route ip-address/prefix-length reachability".

Best regards,

Rodrigo

Actions

This Discussion