Cisco 1841, unable to assign more than 2 of 5 static ips to network

Unanswered Question

On my business SBC static plan I have 5 static ips.

I have the 2wire modem setup as a bridge, a gateway address assigned to the cisco router, a public ip assigned to the cisco router, and a public ip assigned to the firewall that then does NAT to private addresses.

I setup the cisco router to assign an IP from SBC automatically via PPPOE on the Dialer1 interface that is assigned to the 0/1 ethernet interface. The address assigned is xx.xx.xx.230/32.

I TRY to set the 0/0 ethernet statically to xx.xx.xx.225 255.255.255.248, which is the subnet SBC provides me. The router throws an error: xx.xx.xx.224 overlaps with Dialer1.

I can set the router to xx.xx.xx.225 or xx.xx.xx.226 with subnet 255.255.255.252, and everything works.

However I need all of my 5 IP addresses. Setting the subnet mask to 255.255.255.252 does not allow me the full range: 225 to 229.

Anyone have any idea what is going on here?

Current configuration : 1248 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname xxxxxxxxxx

!

boot-start-marker

boot-end-marker

!

enable secret 5 xxxxxxxxxxxxxx

!

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

no aaa new-model

ip subnet-zero

ip cef

!

!

!

vpdn enable

!

vpdn-group 1

request-dialin

protocol pppoe

!

no ftp-server write-enable

!

!

!

!

interface FastEthernet0/0

description LAN

ip address xx.xx.xx.225 255.255.255.252

duplex auto

speed auto

!

interface FastEthernet0/1

description WAN

no ip address

speed auto

pppoe enable

pppoe-client dial-pool-number 1

!

interface Dialer1

ip address negotiated

ip mtu 1492

encapsulation ppp

no ip mroute-cache

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication pap callin

ppp chap hostname [email protected]

ppp chap password 0 apasswordishere

ppp pap sent-username [email protected] 0 apasswordishere

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

ip http server

!

!

dialer-list 1 protocol ip permit

!

control-plane

!

!

line con 0

password apasswordishere

login

line aux 0

line vty 0 4

password apasswordishere

login

!

end

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jon Marshall Mon, 02/26/2007 - 00:09

Hi

it looks like your ip address that is getting dynamically allocated is coming out of the same subnet that has been allocated to you. So when you try and configure your internal interface with a /29 mask it overlaps with your dialer interface ie.

subnet = x.x.x.224

broadcast = x.x.x.231

Useable address = x.x.x.225 -> x.x.x.230

You cannot configure the same subnet on two different router interfaces.

Does your firewall sit behind your router and do you want to use the /29 network between the internal interface of your router and the external interface of your firewall ?.

If so you need to talk to your provider to understand why the address your negotiating on your dialer interface is out of the /29 network.

HTH

Jon

pstebner1 Fri, 03/02/2007 - 07:25

Quick note-

You can have SBC set up the DSL modem so that the PPPoE session is always on, so the router doesn't need to send the CHAP info to it to initiate the session. Then you don't even need to use a dialer interface - you can just put one of the static IPs on your FastE interface.

It'll take you 20 minutes to get to SBC tier 2 support, and then 20 seconds for them to make the change!

P

Actions

This Discussion