CallManager 4.1(3) Dial From Outlook

Unanswered Question
Feb 25th, 2007

I've seen information before about installing the Cisco TSP software to dial from Outlook. The document I seen in the past is for an old version of CallManager. Does this also work in 4.1(3)? I installed it on my computer, but the TSP doesn't see my phone. I enabled CTI Application use on my CallManager user account. Is there anything I need enabled on my phone? Do you know what TCP IP ports are used for this? Thanks!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Chris Deren Mon, 02/26/2007 - 06:55

It is the same procedure, make sure to reboot the PC after installing the tsp.

Chris

gogasca Mon, 02/26/2007 - 07:06

Does this also work in 4.1(3)? Yes

The Cisco TSP makes a TCP connection through port 0xABC.

You can find out what ports SoftPhone is automatically using by checking the Network Audio, (UDP Port Setting) you can fix this value.

TSP Traces (Tsp001Debug0000000x.txt)are located in C:\Temp.

MikeTomasko Mon, 02/26/2007 - 09:02

Here is the error I'm getting in my debug log:

02/25/2007 17:32:38.600 CiscoTSP001.tsp| SelsiusTSP::InitializeComObjects() *ERROR* CoInitializeSecurity() return 0x80010119

Brandon Buffin Mon, 02/26/2007 - 10:29

Mike,

Take a look at the following file on your PC after installing the TSP.

C:\program files\cisco\ciscotsp.txt

Specifically, look at the "Configuring the TSP" and "Installing the Wave Drivers" sections.

Hope this helps.

Brandon

MikeTomasko Mon, 02/26/2007 - 11:27

Still no luck. When I go into my Dialing Options when I go to Call Contact in Outlook, I only have H323 Line and IPCONF LINE listed as options. Here's my latest log:

02/26/2007 13:53:21.156 CiscoTSP001.tsp| TSPI_lineNegotiateTSPIVersion()

dwDeviceID =0xFFFFFFFF

dwLowVersion =0x00010003

dwHighVersion =0x00030000

lpdwTSPIVersion =0x010A48B8

02/26/2007 13:53:21.366 CiscoTSP001.tsp| SelsiusTSP::InitializeComObjects() *ERROR* CoInitializeSecurity() return 0x80010119

02/26/2007 13:53:23.810 CiscoTSP001.tsp| TSPI_lineNegotiateTSPIVersion()

TSPI_lineNegotiateTSPIVersion returns = 0x00000000

TSPI return version = 0x00020001

02/26/2007 13:53:23.840 CiscoTSP001.tsp| TSPI_providerEnumDevices()

dwPermanentProviderID = 0x00000006

hProvider = 0x010A48A8

lpfnLineCreateProc = 0x66DFAA08

lpfnPhoneCreateProc = 0x66E0807B

02/26/2007 13:53:23.880 CiscoTSP001.tsp| TSPI_providerEnumDevices()

TSPI_providerEnumDevices returns = 0x00000000

dwNumLines = 0

dwNumPhones = 0

02/26/2007 13:53:23.880 CiscoTSP001.tsp| TSPI_providerInit()

dwTSPIVersion = 0x00020001

dwPermanentProviderID = 0x00000006

lpfnCompletionProc = 0x66E0CE4D

02/26/2007 13:53:23.880 CiscoTSP001.tsp| TSPI_providerInit()

TSPI_providerInit returns = 0x00000000

dwLineDeviceIDBase = 0x00000005

dwPhoneDeviceIDBase = 0x00000000

dwNumLines = 0

dwNumPhones = 0

lpdwTSPIOptions = 0x010A48B4

02/26/2007 14:22:04.374 CiscoTSP001.tsp| TSPI_providerUIIdentify()

TSPI_providerEnumDevices returns = 0x00000000

lpszUIDLLName = C

Am I correct in assuming the phone connected to my computer should be listed as one of the Connect Using options?

MikeTomasko Mon, 02/26/2007 - 13:05

Great document, but I still don't have the option to select my phone line.

My user is setup for CTI Application Use, my phone as the Associated Device, Device Manager shows the Cisco TAPI Wave Driver if I view hidden devices. I reset my Password and PIN just to be sure I had it right.

My phone is a 7970, is there anything that needs enabled or configured for the device profile? Our phone system is pretty locked down by a firewall, is there a chance there's a port that's blocked that I need or is it direct PC to phone communication? Thanks!

jeremy.guenthner Tue, 03/27/2007 - 12:25

First off-- great document. But I have a problem when I get to the portion that is labeled "Varifying the Cisco TSP Installation". Step 4 reads "In the Line Used For area, choose one Cisco Line in the Phone Calls drop-down menu. I don't have any Cisco Lines to choose from. I only have-- , Conexant HDA D110 MDC V.92 Modem, H323 Line, and Standard Modem. I tried H323 line, but that does not work. Ideas? I really need this and I appreciate any time in advance.

Aaron Dhiman Wed, 10/24/2007 - 09:35

Nice document. I was having the same problem, but turns out I hadn't installed the Wave Driver. Your doc helped straighten it out.

budmiller Wed, 01/07/2009 - 13:42

Very nice document. Does anybody happen to know where I can find one for callmanager version 6.X?

jmujica Mon, 02/26/2007 - 19:06

Hi.

I'm having the same problem on a CCM 4.1(3) system and also on a CCM 4.2(3) cluster. On the trace file I'm seeing exactly the same as yours. I rebooted my pc, also verify the user in DC Directory, etc.. but the Phone Device doesn't shows up in the drop down on dialing properties from outlook.

The weird stuff is that on another CCM 4.1(3) Cluster is working as expected on my laptop.

MikeTomasko Mon, 02/26/2007 - 19:12

I tried it on my lab system which is the same version and it worked fine. I'm thinking it's a firewall issue. I'm gonna try and do some traces or sniffing.

Actions

This Discussion