Incomplete ARP Entry

Unanswered Question
Feb 26th, 2007

Hello,

I have a Cisco router trying to communicate to a remote host on the Internet through our gateway Router. Both routers are on the same subnet. We kept having intermittent communication issues. During our troubleshooting, we noticed that the ARP table entry for the gateway router on the internal router kept showing it as "INCOMPLETE".

The only thing that would fix it would be performing a "CLEAR ARP" on the router.

Why would there be ARP issues between Routers on the same subnet? Is there a setting on the router that I need to verify/change on the interface of router ? Anyone else ever have this problem?

Regards,

Mujeeb

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
hoogen_82 Mon, 02/26/2007 - 04:10

Can you post the interface configuration of both your router. Is your ip proxy-arp disabled on the interface?

Cheers

Hoogen

rmujeeb81 Mon, 02/26/2007 - 21:47

Hello Hoogen,

Below is the interface conf of both routers.

Gateway Router Fast ethernet:

no ip redirects

no ip proxy-arp

ip accounting output-packets

ip route-cache same-interface

ip route-cache policy

no ip mroute-cache

full-duplex

no cdp enable

Requesting Router:

no ip unreachables

ip directed-broadcast

ip load-sharing per-packet

ip route-cache same-interface

no ip mroute-cache

duplex full

Regards,

Mujeeb

Rolf Fischer Mon, 02/26/2007 - 22:43

For some reason the ARP-sending router doesn't receive a reply.

You could run a 'debug arp' on the router(s) to verify ARP-requests are received and/or replies are transmitted.

HTH

Rolf

weerapatr Mon, 02/26/2007 - 22:59

Hi Mujeeb

Are you using default route point to Gateway Router?

If yes

What is next-hop's type which you use?

1. Next-hop IP address

ip route 0.0.0.0 0.0.0.0 a.b.c.d

2. Connected interface

ip route 0.0.0.0 0.0.0.0 fastEthernet x/x

If you use 2 then you can change to 1 for test?

Or Can you enable proxy arp on gateway's interface( Fastethernet)?

Please test and let us know

HTH

hoogen_82 Tue, 02/27/2007 - 02:32

Mujeeb please enable your ip proxy-arp on the gateway router fast ethernet.

HTH

Hoogen

Do rate if this helps :)

rmujeeb81 Tue, 02/27/2007 - 03:02

Dear Hoogen,

I want to ask a question before enabling proxy-arp that what would happen if I set arp time-out value to zero. Will it work for me ?

and one more question is that Proxy-arp is a mechanism in which a device sends its MAC address on behalf of someone else ip address. A router which is working as gateway to Internet should have proxy-arp enabled or not ? why network peoples recommends that proxy-arp should be disabled on core routers ?

Regards,

Mujeeb

rmujeeb81 Wed, 02/28/2007 - 03:57

Hello,

I removed the arp timeout 0 command from interface and after that I tried another thing that I put down static ARP entries on both routers for each other ip addresses which is working fine for us.

Now the same issue is occuring with secondary ip addresses. Gateway Router is unable to get mac address for secondary ip address of Internal Router , I know problem will be solved if I put down static ARP entry for secondary ip address but the question I want to ask that what is the cause of this behaviour and problem is at Gateway router or at Internal Router as we have been using same routers since long.

Note: I have attached a file to show ARP entries.

Regards,

Mujeeb

Actions

This Discussion