international dialing issue with ATT

Unanswered Question
Feb 26th, 2007

I am running a CME at one remote location. The carrier is ATT and I am having issues with dialing internationally. When we debug the call we see the CME flags it as international and the digits its sending is 011 and then 011 <then the full number).

Att is stating we need to drop the 011 because they state we are sending it twice.

Can someone give me pointers on how to do this please?

Thanks

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Paolo Bevilacqua Mon, 02/26/2007 - 08:02

Hi,

How is this currently configured on the router? The only way to send 011 twice, would be "no digit-strip" AND "prefix". Obviously, this doesn't work.

There are a couple of options, one is to dial as "unknown" type/plan with 011 as prefix. Possibly, even "international" type will work.

Another option is to drop prefix 011, and place call like an E.164 number.

All depends on how you have configured dial-peers and voice translation rules, and how ATT likes international calls to be placed. There may be more than one setting that work, too.

D0nprintup_2 Mon, 02/26/2007 - 11:37

Currently this is the debug output:

Feb 26 18:41:40.516: ISDN Se0/3/0:23 Q931: Applying typeplan for sw-type 0xD is

0x2 0x1, Calling num 614XXXXXXX

Feb 26 18:41:40.520: ISDN Se0/3/0:23 Q931: Applying typeplan for sw-type 0xD is

0x1 0x1, Called num 011442074999000

Feb 26 18:41:40.520: ISDN Se0/3/0:23 Q921: User TX -> INFO sapi=0 tei=0, ns=15 n

r=42

Feb 26 18:41:40.520: ISDN Se0/3/0:23 Q931: SETUP pd = 8 callref = 0x0AD3

Bearer Capability i = 0x8090A2

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA98397

Exclusive, Channel 23

Progress Ind i = 0x8183 - Origination address is non-ISDN

Calling Party Number i = 0x2180, '614XXXXXXX'

Plan:ISDN, Type:National

Called Party Number i = 0x91, '011442074999000'

Plan:ISDN, Type:International

Feb 26 18:41:40.536: ISDN Se0/3/0:23 Q921: User RX <- RR sapi=0 tei=0 nr=16

Feb 26 18:41:40.564: ISDN Se0/3/0:23 Q921: User RX <- INFO sapi=0 tei=0, ns=42 n

r=16

Feb 26 18:41:40.564: ISDN Se0/3/0:23 Q931: CALL_PROC pd = 8 callref = 0x8AD3

Channel ID i = 0xA98397

Exclusive, Channel 23

Feb 26 18:41:40.568: ISDN Se0/3/0:23 Q921: User TX -> RR sapi=0 tei=0 nr=43

Feb 26 18:41:40.568: ISDN Se0/3/0:23 Q921: User RX <- INFO sapi=0 tei=0, ns=43 n

r=16

Feb 26 18:41:40.568: ISDN Se0/3/0:23 Q931: PROGRESS pd = 8 callref = 0x8AD3

Cause i = 0x829F - Normal, unspecified

Progress Ind i = 0x8488 - In-band info or appropriate now available

Feb 26 18:41:40.568: ISDN Se0/3/0:23 Q921: User TX -> RR sapi=0 tei=0 nr=44

we are sending 011442074999000 along with Plan:ISDN, Type:International.

Now ATT wants us to drop the 011 but still send the ISDN international plan.

How do I go abouts doing it. I created

dial-peer voice 105 pots

description International

preference 1

destination-pattern 9011T

direct-inward-dial

port 0/3/0:23

forward-digits 12

but it will forward 442074999000 but the isdn plan is now unknown.

is there a easy way to correct this?

mchandak Mon, 02/26/2007 - 11:40

remove the forward digits command and that solve the problem with 011 being sent to the telco. Also, add the command

isdn map address ^011* plan ISDN type International

Paolo Bevilacqua Mon, 02/26/2007 - 12:23

The easier way would be "numbering-type international" under dial-peer 105.

There are more ways ... :)

Also, probably you want "forward-digits all"

Please rate useful posts.

D0nprintup_2 Mon, 02/26/2007 - 12:28

so if I add that it would look like

dial-peer voice 105 pots

description International

numbering-type international

preference 1

destination-pattern 9011T

direct-inward-dial

port 0/3/0:23

forward-digits 12

this should work where it will send the 44* and international type?

mchandak Mon, 02/26/2007 - 12:38

When you changed the forward-digits, Did you use the option "default forward-digits" or "no forward-digits". Note that if you use the 2nd option, the configuration would show "forward-digits 0", which means do not forward digits. You need to use "default forward-digits" with the above config instead of "forward-digits 12"

Paolo Bevilacqua Mon, 02/26/2007 - 13:14

Yes. In my post above, I was already saying that what telco likes is E.164 format with international type (you can think about international as being the + in E.164).

Note that unless you have multiple dial-peers to same destination, preference is not needed.

thack Mon, 02/26/2007 - 08:52

Hi,

I did an install of CME in Texas, and had a similiar problem, and i think the config below fixed the issue.

(8 is used to access the pstn)

interface Serial0/0/0:23

no ip address

encapsulation hdlc

isdn switch-type primary-ni

isdn incoming-voice voice

isdn map address 011* plan unknown type unknown

no cdp enable

dial-peer voice 12 pots

translation-profile outgoing OutBound

destination-pattern 8011T

progress_ind alert enable 8

progress_ind progress enable 8

progress_ind connect enable 8

incoming called-number .

direct-inward-dial

port 0/0/1:23

prefix 011

Cheers

Tony

Actions

This Discussion