Voice VLAN support with Alcatel phones

Unanswered Question
Feb 26th, 2007

Does anyone know if Cisco switches support Alcatel phones for voice vlans?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
mchandak Mon, 02/26/2007 - 16:23

Voice VLAN would only work with IP Phones which can support CDP. If the IP Phones does not support CDP, I dont think it would work. You will have to configure the port as trunk port.

pbosio Wed, 03/21/2007 - 20:43

I'm doing the same thing.

Have a Cisco 3560-48PS-S switch with Alcatel IP phones.

I'm assuming the config would be the same as the old Cisco 3524 switches.

interface FastEthernet0/1

switchport trunk encapsulation dot1q

switchport trunk native vlan 4

switchport mode trunk

switchport voice vlan 3

spanning-tree portfast

end

Vlan 4 is the Data vlan

vlan 3 is the voice vlan

I plug my laptop in and get connected to the data vlan so I know that bit is OK.

Can anyone confirm if this is correct as I don't have an Alcatel IP phone to test with.

Thanks

Paul

lwai Thu, 03/22/2007 - 08:23

Hi Paul,

It will work, but I prefer access mode instead of trunk mode. I had tested both setting, both will work. together, don't forget to turn on the QOS and trust dscp.

Remark: voice vlan 60, data vlan 40

interface GigabitEthernet0/42

switchport access vlan 40

switchport mode access

switchport voice vlan 60

ip access-group 140 in

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

queue-set 2

priority-queue out

mls qos trust dscp

auto qos voip trust

storm-control broadcast level 0.30

storm-control multicast level 0.50

spanning-tree portfast

pbosio Thu, 03/22/2007 - 14:22

lwai,

The config you show here looks more like what is required for an cisco ip phone. The only difference being that the "auto qos voip cisco-phone" is missing.

Are you saying that config you posted works with Alcatel IP phones?

Thanks

Paul

patcbr600 Thu, 03/22/2007 - 14:57

I have tested this config with alcatel phones and work wit no problems, the only thing tha you have to put is the voice vlan id in the alcatel phones.

interface FastEthernet2/2

description IP-TOUCH

switchport access vlan 230

switchport mode access

switchport voice vlan 410

switchport port-security

switchport port-security maximum 3

switchport port-security violation restrict

qos trust dscp

tx-queue 3

priority high

shape percent 33

spanning-tree portfast

The only thing that the voice vlan do is that the port will accept 801.q traffic for that vlan id(410) in a access port.

lwai Thu, 03/22/2007 - 18:21

Yes, the switchs WS-C3560G-48PS x 6 sets works fine with the Alcatel ip phone sets.

In my case, one point to share with you, the connection cable bundle with Alcatel is cat5e, if your cable structure is cat6, please don't use the cat5e cable, otherwise some ip phone sets ( long distance away from closet) cannot connect to the system. And LED of the switch port will turn on in orange colour.

The phone cannot work.

rsabapathee Sun, 03/25/2007 - 07:41

" The only thing that the voice vlan do is that the port will accept 801.q traffic for that vlan id(410) in a access port."

Now this is interesting. This is the info I was looking for a while back.

This means if I have a non-cisco ip phone (vlan 100) and PC on native vlan (1)connected to PC port on ip phone, both will work if I set Voice VLAN to 100 and leave access vlan to native. (NO NEED TO SET THE PORT TO 802.1q TRUNK , which i am currently doing).

I have 2924, 2950 switches which has IOS 12.0 and cannot enter the mls qos or qos trust commands.

The only issue is the CoS. My previous question which is still unanswered is as follows:

I have set the phone to VLAN 100 from its menu. Since the phone does not support CDP and is set to the VLAN which matches the Voice VLAN in the switch, is the Cisco switch smart enough to automatically assign a Voice CoS (default 5 i believe) to that VLAN when it sees traffic from the phone?

ronbuchalski Sun, 04/29/2007 - 08:49

Are your Alcatel phones the former Avaya phones? We use Avaya phones in our network.

What we do is utilize DHCP to tell the phone which VLAN to use for tagging, and the configuration file it downloads from the TFTP server contains info for the phone to tag CoS and DSCP values. Use DHCP Option 176 to do this. PCs and other devices that don't need the Option 176 information simply ignore it.

Regarding your switches not being able to support the mls qos trust commands, these are only supported in the Enhanced Image, not the Standard Image. Certain 2950 switches support both images, while others only support the Standard Image.

We have some 2950 switches which only support the Standard Image. Since we set out CoS and DSCP values via DHCP, the ports connected to the phones are configured with:

mls qos trust cos pass-through dscp

This allows the dscp value set by the phone to be retained as the frames are switched through the 2950.

Hope this helps.

Ron Buchalski

patcbr600 Sun, 04/29/2007 - 22:56

Hello,

I have tested cisco voice vlan with alcatel ipphones and worked fine, you just have to put the switchport in the voice vlan and than configure the phone with that vlan, if you want you can use a alcatel feature that gives the vlan id to the phone by dhcp.

Actions

This Discussion