Cisco 806 for 8 static IP setup

Unanswered Question
Feb 26th, 2007

Hi,

I have obtained this 806 basic router, and I would like to use it for my 8 static IPs at home. This is the first time I am configuring a Cisco router, so it gives me a pretty tough challenge. I basically need it to have my 8 IPs going through. One will land on this device, or maybe 2? Does the internal interface need to be a Static IP, if I want to have static IPs beneath it?

Another IP would be for a different firewall, which connects a portion of my network to a corporate VPN solution. One IP would be for my home WLan router, and some other IPs for Mail, web, etc survers.

How do I go about configuring this? I am unabe to find info, or not searching with the right keywords. This is how my config looks like now, which connects me to my ADSL PPPoE line, but currently doesnt allow me anything else. I cannot even ping addresses outside. You will see that my Eth0 interface is configured for an internal Fake address now, but this isnt my end goal.

Thanks for any help,

Ben

!

version 12.2

no parser cache

no service single-slot-reload-enable

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname routername

!

logging buffered 4096 informational

!

ip subnet-zero

!

!!!!!!!!!!!!! This is the ISP's DNS IP addresses

ip name-server XXX.xxx.xxx.xxx

ip name-server xxx.xxx.xxx.xxx

!!!!!!!!!!!!!

vpdn enable

!

vpdn-group 1

request-dialin

protocol pppoe

!

!

!

!!!!!!!!!!!! This is the LAN side

interface Ethernet0

!!!!!!!!!!!! The IP address for the router

ip address 192.168.1.254 255.255.255.0

!!!!!!!!!!!!

ip nat inside

ip tcp adjust-mss 1452

no cdp enable

hold-queue 32 in

!

!!!!!!!!!!!! Note that e1 has no IP address

interface Ethernet1

no ip address

!!!!!!!!!!!!

pppoe enable

pppoe-client dial-pool-number 1

no cdp enable

!

!!!!!!!!!!!! The ISP's given IP address will be configured via d1

interface Dialer1

ip address negotiated

!!!!!!!!!!

ip mtu 1492

ip nat outside

encapsulation ppp

ip tcp adjust-mss 1452

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication chap pap callin

ppp pap sent-username loginname password 0 passwordincleartext

ppp ipcp route default

!

ip nat inside source list 102 interface Dialer1 overload

ip classless

ip http server

!!!!!!!!!

!

no cdp run

!

line con 0

exec-timeout 120 0

stopbits 1

line vty 0 4

exec-timeout 0 0

login local

length 0

!

scheduler max-task-time 5000

end

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
bence8810 Fri, 03/02/2007 - 12:12

Hi

Thanks, in the meantime I solved with another approach.

I didnt know enough about networks it seems, and I thought if I get one IP of a subnet on the WAN side, I can get the rest on the LAN side by default in the DMZ. As my 8Static IP is just a regular and not professional package it isnt a point-to-point thing, where you have 2 subnets, one on the WAN side, and your real IPs appear on the LAN side.

What I did was I used on my dialer interface the

ip unnumbered ethernet 0

And for the ethernet 0 I added

ip address mystaticip mysubnet

This allows now to have a mirrored IP address from the WAN side to the LAN side, and therefore I am able to use the rest of the IPs on my LAN.

Here is the related configuration that belongs here:

[code]

interface Dialer1

ip unnumbered Ethernet0

[/code]

[code]

interface Ethernet0

ip address xx.xx.xx.65 255.255.255.248

[/code]

Thanks to the nice people at broadband help forums for the solution.

Best,

Ben

Actions

This Discussion