Media Master Bar with Unity in voice only domain

Unanswered Question
Feb 26th, 2007

I have a Unity server in a seperate voice domain. When a user tries to use the media master bar from the desktop, IE sends the data domain credentials instead of using the voice domain credentials which were already supplied. Has anyone got a workaround for this?

Thanks!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Tommer Catlin Mon, 02/26/2007 - 14:44

it's an IIS setting somewhere. I can't recall where though. I had that problem with 4.2 SA from my desk. I would login, then as soon as I click on a subscriber in my search and pull them up, a second login would occur (or at the search). I would login into that domain and it would be fine until I closed that window.

Search for IIS issues and you should be able to fix it.

Ginger Dillon Wed, 05/02/2007 - 15:26

Hi -

If these are two domains, same forest, you don't need trusts set up. You should be able to run the grantunityaccess utility to associate the user's data domain credentials to the voice domain credentials, which if I understand correctly, is where your users are enabled in Unity. Check it out on the Unity server, Unity Tools Depot, in Diagnostic Tools (if I remember correctly).

Ginger

neesharm Thu, 05/03/2007 - 02:07

when you are checking the subscriber or call handler screens on the Web administration interface.

This is expected behavior what is happening is that the client (whether it is SA, AA or VMO form) uses the media master ActiveX control (the one that you use to record prompts/greetings) to connect directly to the TRAP connection server to make the connection.

When using NTLM (aka Integrated Windows Authentication) authentication for the SA, the

ActiveX control will need to authenticate a 2nd time when the client and the Unity server

are in separate domains since it is not able to ?piggy back? on the NTLM challenge and

response authentication the user had to supply when first accessing the page, it needs its

own security token.

Is the computer you are logging in from on a separate domain that the Unity Server is at ?

If it is then there is no way we can change this, is just the way windows works with

authentication.

First of all the reason it may not be working on some computers is that DCOM

communication between the PC and the Unity server is blocked. The Media Master control bar

relies on DCOM communication to communicate with the Cisco Unity server. Make sure those

computers do not have an integrated firewall or A/V software that prevents this type of

communication or that there is a firewall in the middle.

Check these links

http://www.ciscotaccc.com/voice/showcase?case=K15820605

http://www.cisco.com/en/US/products/sw/voicesw/ps2237/products_white_paper09186a00801c129d.shtml#34843

Actions

This Discussion