Redistribution problem

Unanswered Question
Feb 26th, 2007

Hi, I've got a classic core-distribution, with a FW in access layer.

EIGRP between core-distribution and OSPF between FW/access-distribution.

configs as follows:

core:

router eigrp 1

network 172.16.0.0

no auto-summary

interface fa0/1

ip address 172.16.1.1 255.255.255.254

-----

distribution:

router eigrp 1

network 172.16.1.0 0.0.0.1

network 172.16.165.0 0.0.0.3

no auto-summary

eigrp stub connected static

router ospf 1

area 1 stub

network 172.16.165.1 0.0.0.0 area 1

network 172.16.22.1 0.0.0.0 area 0 (just a loopback interface)

int fast0/1

ip address 172.16.1.2 255.255.255.254

int fast0/2

ip address 172.16.165.2 255.255.255.254

The OPSF network exists on the distribution switch, but it will not redistribute it into the core, can anyone explain what I'm doing wrong?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
deilert Mon, 02/26/2007 - 16:39

i do not see where there is any redistribution configured. Do you want the 172.16.22.1 in EIGRP ? If so add a network statement in EIGRP 172.16.22.1 0.0.0.0

770801tvdhaar Tue, 02/27/2007 - 00:19

Sorry forgot the redistribute part!!!!

I want to redistribute OSPF into EIGRP.

distribution:

router eigrp 1

network 172.16.1.0 0.0.0.1

network 172.16.165.0 0.0.0.3

no auto-summary

eigrp stub connected static

redistribute ospf 1 metric 100000 100 255 1 1500

router ospf 1

area 1 stub

network 172.16.165.1 0.0.0.0 area 1

network 172.16.22.1 0.0.0.0 area 0 (just a loopback interface)

int fast0/1

ip address 172.16.1.2 255.255.255.254

int fast0/2

ip address 172.16.165.2 255.255.255.254

deilert Tue, 02/27/2007 - 03:57

The subnet mask of ip addresses you have on the Fe's should be 255.255.255.252 not 254

can you change them and change the network statement in OSPF to 172.16.165.0 0.0.0.3 area 1 then paste in a sh ip eigrp top 172.16.165.0 255.255.255.252

Richard Burts Tue, 02/27/2007 - 04:29

Tyrone

There are several parts of this config that may be problems. Here it is for reference:

router eigrp 1

network 172.16.1.0 0.0.0.1

network 172.16.165.0 0.0.0.3

no auto-summary

eigrp stub connected static

redistribute ospf 1 metric 100000 100 255 1 1500

router ospf 1

area 1 stub

network 172.16.165.1 0.0.0.0 area 1

network 172.16.22.1 0.0.0.0 area 0 (just a loopback interface)

int fast0/1

ip address 172.16.1.2 255.255.255.254

int fast0/2

ip address 172.16.165.2 255.255.255.254

- As noted before the mask of 254 on both fastethernet interfaces is problematic.

- the network statement in eigrp network 172.16.1.0 0.0.0.1 would seem to intend to match fastethernet0/1, but the mask used of 0.0.0.1 will match only 0 and 1 in the last octet and the interface is .2. The fact that it is not included in eigrp can be confirmed by show ip eigrp interface. This means that there is no eigrp running between distribution and core.

- it appears that the intent is to have interface fastethernet0/2 in both eigrp and ospf. I wonder why it is intended to be in both. And in fact the network statement mask used in ospf does not quite match that interface:network 172.16.165.1 0.0.0.0 area 1

- and perhaps the most important issue is one that we do not have enough information to answer yet. What ospf routes are known on the distribution that would be redistributed. The output of show ip route ospf on distribution would show what routes have been learned by ospf and could be redistributed to eigrp. Without knowing that we can not know whether redistribution is working or not. The syntax of the redistribute command looks ok, but the question is: are there ospf routes to redistribute. (Given that the only ospf network statement that seems to match is to a loopback, I am doubtful that there are ospf routes to redistribute.)

HTH

Rick

Actions

This Discussion