as5350xm: myphone cannot use g711ulaw

Unanswered Question
Feb 26th, 2007

myphone -> as5350xm -> pstn

if i enable all codecs in myphone, "show call active voice brief" shows g729r8. outbound call is ok.

But, if we enable only g711ulaw, call is dropped immediately (ring once or no ring happened). I do have the same problem with Asterisk if i enable only g711ulaw.

Since it is a LAN, i want to use low complexity codec only.

For dial-peer voip, i could specify codec preference or codec used. But for dial-peer pots, i do not know how to enable a specific codec.

pls advise.

**** running-config ***

dial-peer voice 100 pots

destination-pattern 49

no digit-strip

direct-inward-dial

port 2/1:D

forward-digits 8

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Paolo Bevilacqua Mon, 02/26/2007 - 21:01

Configure a voip dial-peer for incoming called-number. Can be the same for outbound. Configure codec or voice class codecs in there.

aclhkaclhk Mon, 02/26/2007 - 22:46

I have added a dial-peer voip as below:

voice service voip

h323

sip

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g711alaw

dial-peer voice 100 pots

destination-pattern 49

no digit-strip

direct-inward-dial

port 2/1:D

forward-digits 8

dial-peer voice 4 voip

voice-class codec 1

incoming called-number .

Call is still not established. Attached is the debug log.

Myphone calls dial-peer 100 by typing "[email protected]".

pls kindly advise.

Attachment: 
mchandak Tue, 02/27/2007 - 07:42

can u attach all the following debugs. From what you have attahced, does confirm that H245 is causing the call failure.

debug voip ccapi inout

h225 q931

h245 asn

cch323 session

aclhkaclhk Wed, 02/28/2007 - 03:00

attached is full debug log.

myphone-h245-full-debug.TXT (Disconnect Cause=65)

gridorg-h245-full-debug.txt (Disconnect Cause=172)

The 2nd log is from Gridborg (asterisk-like software) making outbound pstn call via as5350xm using g711ulaw. Result is same as myphone.

Pls advise

aclhkaclhk Thu, 03/01/2007 - 02:51

pls advise what configuration could make the outbound call work. i have tried either or both of the following but without success:

h245 caps mode restricted

h245 tunnel disable

If we allow g723 or g729, there is no problem at all.

*** asterisk config ***

h323.conf

disallow=all

allow=ulaw

**** show voice dsp for myphone/gridborg/asterisk ***

DSP DSP DSPWARE CURR BOOT PAK TX/RX

TYPE NUM CH CODEC VERSION STATE STATE RST AI VOICEPORT TS ABRT PACK COUNT

===== === == ========= ======= ===== ======= === == ========= == ==== ============

C5510 001 01 None 8.4.1 busy idle 0 0 23 0 0/0

If we use sip (using gridborg/asterisk), the codec is automatically g711ulaw and call is ok.

*** asterisk config ***

h323.conf

allow=all

attached pls find the debug log for asterisk.

Actions

This Discussion