QoS on MPLS

Unanswered Question
Feb 27th, 2007

Hi, i have configured QoS on a small MPLS cloud. i have a policy defined on CE routers and PE routers. However i need to test the voice QoS, but packets do not seem to be getting marked. The class I expected traffic to match is using IP precedence value 5.

Can i initiate an extended ping with a TOS value specified that will match ip precedence 5? i tried specifying 5 as the TOS value but this did not match the policy. The policy and classes are as below.

class-map match-any HIGH

match precedence 5

match dscp ef

class-map match-any MEDIUM

match precedence 3 4

class-map match-all LOW

match precedence 2

!

policy-map CE_OUT

class HIGH

priority percent 20

set ip precedence 5

class MEDIUM

bandwidth remaining percent 50

set ip precedence 4

class LOW

bandwidth remaining percent 20

set ip precedence 2

class class-default

bandwidth remaining percent 30

random-detect

!

Service-policy output: CE_OUT

Class-map: HIGH (match-any)

0 packets, 0 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: precedence 5

0 packets, 0 bytes

5 minute rate 0 bps

Match: dscp ef (46)

0 packets, 0 bytes

5 minute rate 0 bps

I tried setting a policy on a loopback to match any packets and set ip precedence 5, but this did not work.

This is basically to test QoS before i actually have the phones etc.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
Loading.
pankajkulkarni Tue, 02/27/2007 - 21:04

Hello,

In the configuration provided above you haven't mentioned if you have applied the policy-map to the egress interface on the CE and corresponding interface on the PE.

The PE router automatically maps the incoming DSCP/IP Precedence values into the MPLS EXP bits.

You haven't mentioned the hardware platform used in within the network.

Here is a sample configuration -

http://www.cisco.com/en/US/partner/products/hw/switches/ps708/products_configuration_guide_chapter09186a008038720d.html#wp1442020

mheusinger Wed, 02/28/2007 - 05:26

Hello,

First, applying the policy to an interface will ONLY match traffic across this interface in the specified direction. If you really applied this policy to a Loopback, there will be no traffic across the interface and thus no matches.

Second, make sure there is already marked traffic. Usually all traffic is marked with precedence 0 (except routing with cs6).

To test your policy you could use an access-list to match f.e. ICMP and set some marking for it. Or you use an extended ping across the interface, where the policy is applied, to set the TOS value in the ICMP packets (f.e. TOS 184 will give you DSCP EF). This way you can generate marked packets, which then should lead to matches.

Third, be aware, that all Catalyst ports by default are set to "untrusted", i.e. all markings will be reset to 0, if not configured otherwise.

Last (for now), also be aware, that queueing only is invoked, if the interface is overloaded. If no overload condition exists, all packets are sent with wire speed, no queueing is needed.

Hope this helps! Please use the rating system.

Regards, Martin

Actions

This Discussion