IPCC Express third party integration

Unanswered Question
Feb 27th, 2007

I try to find out a way to send information collected from an IPCC Express script to a WEB Application.

I first thought that I should use one of the HTTP steps, but I realized that the purpose of these steps are to answer HTTP Request.

I then choose to use the "Create URL" step combined with the "Voice Browser" step and this solution works fine.

The drawback of it is when you need to send a last request AFTER the caller hungup, the Voice Browser raise an Exception.

In fact, the Voice Browser step required a valid triggering contact.

After further reading I thing that I should have use the Java Step for this

Am I right ?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
l.mourits Fri, 03/02/2007 - 11:06

Hi,

Depends what you want to achieve, if the mentioned script is a JTAPI triggered script you probably best of by adding a call to another script which is HTTP triggered, then this HTTP triggered scipt would be able to send output to the webpage...., not sure what you want to achieve though...

HTH,

Leo

rainvillem Fri, 03/02/2007 - 11:19

Hi,

Thanks for your reply Leo.

Yes my script is a JTAPI triggered script.

It's a good Idea to call an HTTP triggered script to call my appl (do an http get) I didn't think about it and I will keep that solution in my mind for next time.

In my way to find a solution, I finaly used a Create XML Document step since the targeted url (my app) returned XML. and its working well.

(I didn't take time to post this solution to the forum though)

Thanks again

Michel

o-campbell Thu, 03/08/2007 - 07:18

Michel,

I am working on the same issue almost exactly. I have a web app on customers server that is retruning an xml doc for me to pull a couple of items out to variables and do some inteligent call routing. I have the steps as follows.

create url document

create xml document

get xml document data

I don't think I am actually submiting the url for processing that is created in the create url doc step. What am I missing?? Any assistance would be very much appreciated!!

rainvillem Thu, 03/08/2007 - 07:35

Owen,

When I worked on this, I first tried with the following two step:

create url document

create xml document

I realized later that the http request is sent only if I use the get xml document data.

After using the get xml document data it started to work for me.

Can you tell me what is your XML Path.

I think that it should be a valid XPath expression.

My script is using XML Path="/descendant::_node_" (including the double quote)

In that XML Path, _node_ is an XML element present in the XML response.

Hope this help

Michel

o-campbell Thu, 03/08/2007 - 08:21

Michel,

Thanks. My setup is as follows... The web service url used in the create url document step is "http://crm-01:5555/LexjetCrm/LexjetWebServiceCrmCustom/LexjetCrmTelephoneNumber.asmx/GetCiscoTelephoneRoutingInformation"

This is saved to a doc variable and then processes by the create xml document step. In the get xml document data step the xml path is

"/descendant::CiscoRoutingInfo_OwnerTelephone_"

I am doing reactive debuging and the script fails at the get xml doc data step with an IO error.

Is you web service local or on another machine??

Thanks!!

rainvillem Fri, 03/09/2007 - 07:54

Owen,

My Web App is local, but it should not matter.

Did you activated the trace to see more of that IO Error ?

When I get that error, I can clearly see that the WEB Appl (WEB service) result in an http 500 (Internal Server Error).

I suggest you to first try with a simple page that return a simple XML doc.

Last thing, the test you made with IE, did you make it from the CRS ?

I think that you are really near...

Michel

o-campbell Fri, 03/09/2007 - 09:21

Michel,

Thanks, I have it retruning the XML data and parsing it with the create xml document step correctly, but when I try to read the information from xml into my variables I get a null value. This is what the web service returns to me...

<?xml version="1.0" encoding="utf-8" ?>

- http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

{75394DD1-A5AF-DB11-9BF7-0015C5EA5C46}

East

0

Large Format

3334

I think the get xml data step can not deal with the SOAP header information which is standard xml stuff. when I delete the following lines from the file and load it from the local drive I can read the variables fine.

xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"

Do you have any info on the form an xml document is acceptable??

Hi,

I'm trying to do something similar but is not working.

I'm trying to send a parameter to an ASP webpage to make it run. All I want is to deliver it.

I was reading the cisco guide and it says to use the Create URL Document + the Send HTTP Response step but it doesn't work.

my Create URL Document:

URL= http://x.x.x.x/webpage.asp

Method = Post

Parameters = name = f, values = "something"

document = doc

Send HTTP Response step:

Document = doc

Any help will be greatly appreciated.

thank you

rainvillem Tue, 05/22/2007 - 02:54

Hi,

My understanding is that HTTP steps are all for HTTP contact *not* voice contact.

The only way it works for me was using the Create XML document followed by a Get XML Document data.

Hope this help

castrillor Mon, 06/25/2007 - 08:01

Hi all,

I have asimilar problem with soap web services. The headers seems not to be "parseable" by crs.

Does anyone knows if soap interface is compatible with CRS.

In adition how are parameters passed to a soap web service?

Thanks in advance

Raul

Actions

This Discussion