How do I configure my 851W to support both DHCP and Static Global IP

Unanswered Question
Feb 27th, 2007

Hello,

I have set up my 851W connected to a Cisco 24 port switch and everything is working fine. The router is issuing ip address by dhcp to hosts on th 192.168.0.1 range.

However I need to have 2 hosts with registered global static IP addresses connected to my switch. My ISP has supplied me with the addresses, where and how do I configure it in the router?

They are required for IP cameras.

Rds!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
devang_etcom Tue, 02/27/2007 - 13:41

hi,

you can have like this...

you have internal ip address range of 192.168.1.0/24 right...

now you can define your ip address range of 192.168.1.2 to 192.168.1.254... it means you are excluding two ip address which are 192.168.1.1 and 192.168.1.2... now assign this two ip address to your cameras... and configure the Static nat in router with the global ip address bound to the cameras ip address...by using the

"ip nat inside source static"

make sure you are configuring the static NAT okay...

this is the link where you can find more detail to configure the NAT: http://www.cisco.com/warp/public/556/12.html

regards

Devang

microtek Tue, 02/27/2007 - 14:13

Thanks that is sorted.

However I have another question. I have upgraded my IOS to ver 12.4.11.T1. I am trying to load SDM 2.2.3 into flash and theere is no enough space. I tried squeeze flash command but not recognised.

Does anyone has an answer for this?

Regards!

devang_etcom Tue, 02/27/2007 - 14:25

hi...

will you please type "squeeze ?" on router command prompt... and if there are no options come up or after typing sque press tab button and if command not show up then this feauture is not supproted...

just try it... i m not sure

regards

Devang

devang_etcom Tue, 02/27/2007 - 14:37

one more try is just go for only "?" on router prompt and if you not find anything like squeez tehn its not supported...

regards

Devang

microtek Tue, 02/27/2007 - 14:49

Nop! Not available. So there is no way to reclaim space from the flash then for the 800 series?

Thanks anyway!

devang_etcom Tue, 02/27/2007 - 14:51

no problem... you are welcome at any time...

yes... if the command is not there then you cannot configure that feature...

thanks and regards

Devang

BillBores Tue, 02/27/2007 - 14:47

I have some questions regarding your configuration question. From the reading of your post, you have defined a 192.168.0.0 network serviced by the 851W which is connected to a Cisco 24 port switch (layer 2). The you also have 2 hosts that need to have public / global IP addresses issued to them as well. If this is what you are seeking to do, then here is my reply.

Because these are two different IP networks, your DHCP server within the 851 will not have any way to service them. A DHCP request is received by the 851 on a physical port and cannot do both.

What I would suggest you do is apply these two IP address to the hosts statically.

If the two hosts are on the same switch that has a different VLAN, then that would be serviced from a different port on the 851 but I don't see that specified in your question.

Bill

microtek Tue, 02/27/2007 - 14:58

All my hosts and The two hosts are on the same switch. I linked the 851 to the switch via FastE0. FastE1-E3 are empty doing nothing.

I suppose I can create a reservation in the DHCP pool for the 2 hostd, and NAT in to them?

What do you think?

Rgds!

devang_etcom Tue, 02/27/2007 - 15:02

hi...

will you please tell me what kind of connectivity or topology you have?

i also would like to know your ISP connectivity (ADSL or what?

and if its ADSL then provider must have provided some router kind of device...

and if yes... then if that router has multiple ethernet port then you can directly connect your host to it... and assign that public ip address...

regards

Devang

microtek Tue, 02/27/2007 - 15:09

Ethernet topology. BT ADSL via BT voyager modem connected to 851w Router working in bridged mode for the wireless. The router has 4 Inside ports for LAN and 1 port for WAN. No dialer port.

Are you suggesting that I should connect the camera directly to the Router port rather than via the switch?

Rgds!

devang_etcom Tue, 02/27/2007 - 15:12

yes... exectly...

because finally switch will be working as only layer 2... right... so its of no use...

please rate the post if it helps

regards

Devang

microtek Tue, 02/27/2007 - 15:33

So do I then give the 2 host a global static or local static address considerng they are now directly connected to the router port?

Rgds!

microtek Wed, 02/28/2007 - 16:25

Is it really possible to allocate IP addresse to FastE0-4 interface?

Rgds!

Actions

This Discussion