cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
548
Views
0
Helpful
2
Replies

Why can't I use the same encapsulation tag on different subinterfaces?

jkeeffe
Level 2
Level 2

This is on a 6509/Sup720 IOS 12.2(18)SXF5 and 12.2(18)SXE, and a WS-X6548-GE-TX and a WS-X6724-SFP blade.

I'm trying to create two sub-interfaces on each port, tag one for a data vlan and one for a voice vlan. Each port will then connect to a 3750 switch where IP phones and PC's will be connected to the same port. This is the typical IP phone/PC architecture. I was hoping to use the same vlan numbers on each switch so we don't have to keep track of which vlan is which switch - this works in the layer 2 world because the vlan stops at the layer 3 router port.

Well on the 6509 port this is what I have for the first port:

interface GigabitEthernet2/14

description to SW-232.15

no ip address

no ip route-cache

speed 1000

duplex full

mls qos trust dscp

spanning-tree portfast

!

interface GigabitEthernet2/14.10

encapsulation dot1Q 10

ip address 162.*.*.1 255.255.255.128 (the data vlan)

no ip route-cache

!

interface GigabitEthernet2/14.910 (the voice vlan)

encapsulation dot1Q 910

ip address 172.*.*.1 255.255.255.128

no ip route-cache

Now when I go to the next interface and do the same thing this is the error msg I get:

ENGLAB-6513-Native(config-if)#int g2/16.10

ENGLAB-6513-Native(config-subif)#encapsulation dot1Q 10

Command rejected: VLAN 10 not available

I can put some other dot1q tag on here but not 10 which I've already used.

Aren't these dot1q tags used only between the interface and the layer 2 switch connected to it? Aren't the tags stripped off when packets switch from one interface to another?

If so shouldn't I be able to use the same dot1q tag on different sub-interfaces?

Or am I not understanding things correctly?

2 Replies 2

swyka
Level 1
Level 1

I have set up 3750s connecting to 6509s with IPT before & usually Dot1q trunk to the 3750 with the 6509 as a VTP server & the 3750s are VTP clients. Then on the 3750 ports, use the following:

switchport access vlan 10

switchport voice vlan 910

Here's a sample from one of my old production configs:

6509 Vlans:

!

interface Vlan103

description 3rd floor

ip address 10.0.x.x 255.255.248.0

ip helper-address 10.x.x.x

ip helper-address 10.x.x.x

no ip redirects

ip route-cache flow

end

!

!

interface Vlan186

description 3rd Floor VOICE

ip address 10.x.x.2 255.255.254.0

ip helper-address 10.x.x.x

ip helper-address 10.x.x.x

no ip redirects

ip route-cache flow

no ip route-cache cef

end

6509 to 3750:

(6509 port)

!

interface GigabitEthernet3/7

description UPLINK.TO.CLOSET.3C - G1/0/1

switchport

switchport access vlan 999

switchport trunk encapsulation dot1q

switchport trunk native vlan 999

switchport mode trunk

spanning-tree link-type point-to-point

spanning-tree port-priority 32

end

(3750 port)

!

interface GigabitEthernet1/0/1

description UPLINK.TO.6509-1 - G3/7

switchport trunk encapsulation dot1q

switchport trunk native vlan 999

switchport mode trunk

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

queue-set 2

mls qos trust cos

auto qos voip trust

end

All other 3750 ports:

!

interface FastEthernetx/x/x

switchport access vlan 103

switchport voice vlan 186

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

mls qos trust cos

auto qos voip trust

spanning-tree portfast

!

LMK if this helps.

Thanks for the information - I'll give it a try and let you know how it works for me.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card