7960 and 7920 not getting DHCP address

Unanswered Question
Feb 28th, 2007

I am setting up an office with several IP phones. I 7941s, 1 7960 and one 7920. I have set the same system up at 3 of our other offices and everything has worked fine. The 7941s get DHCP fine, but the 7920 and 7960 do not. I have tried different ports on the switch and have verified that the port the 7960 is connected to is working using the 7941. I have verified the DHCP on the wireless for the 7920 by setting the SSID on a computer for the voip network and it gets an IP address. My router trunked to the switch and I have an IP helper set up on the voice vlan interface pointing to my server on the native vlan. Anybody have an idea why this isn't working?

Thanks,

Jack

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mchandak Wed, 02/28/2007 - 14:51

what is the current firmware on the Phones ?? Also, are you using the same VLAN for all the phones, if yes, and a Data and Voice VLAN is configured, you might need to configure option 150 on DHCP of the Data VLAN as the 7960 6.x firmware version had a bug where it could not pickup option 150 from the Voice VLAN, but would try to pick it from the Data VLAN

jfarrer Wed, 02/28/2007 - 15:01

The firmware version on the 7920 is 7920.4.0-03-00 and the firmware on the 7960 is 8.0(4.0). I did put the TFTP option on the Data VLAN. I have also forced both phones over to the Data vlan and they are now working fine.

Thanks,

Jack

mchandak Wed, 02/28/2007 - 15:34

that is strange. I've done a lot of upgrade/downgrade on this load and never seen this issue. Anyways, 8.0(4) is now deferred. I'd recommend either upgrading it to 8.0(4)SR3/8.0(5)/8.2(1)

Actions

This Discussion