ISDN Dialer Config ??????

Unanswered Question
Feb 28th, 2007

Hi

I have following ISDN Dialer Backup config (plz chk below) my serearl Links is down between my two router ABC and XYZ. kindly chk the config and tell is theresome thing worng becoz i could not Connect my tow differnt network on the ISDN plz chk and suggest.

waiting for ur ans.

Router ABC

nterface Serial1

bandwidth 2048

backup delay 1 1

backup interface Dialer1

ip address 192.168.240.1 255.255.255.252

no ip directed-broadcast

!

interface BRI0

no ip address

no ip directed-broadcast

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

ppp authentication chap

!

interface Dialer1

ip address 192.168.10.1 255.255.255.252

no ip directed-broadcast

encapsulation ppp

dialer remote-name XYZ

dialer idle-timeout 300

dialer string 0212740020

dialer pool 1

dialer-group 1

ppp authentication chap

dialer-list 1 protocol ip permit

ip route 192.168.223.16 255.255.255.240 Dialer1

Router XYZ

interface Serial0

bandwidth 2048

ip address 192.168.240.2 255.255.255.252

no ip directed-broadcast

no ip route-cache

no ip mroute-cache

backup delay 1 1

backup interface Dialer0

!

interface BRI0

no ip address

no ip directed-broadcast

encapsulation ppp

no ip route-cache

no ip mroute-cache

dialer pool-member 1

isdn switch-type basic-net3

ppp authentication chap

!

interface Dialer0

ip address 192.168.10.2 255.255.255.252

no ip directed-broadcast

encapsulation ppp

dialer remote-name ABC

dialer idle-timeout 300

dialer string 0514409044

dialer pool 1

dialer-group 1

ppp authentication chap

dialer-list 1 protocol ip permit

ip route 192.168.223.0 255.255.255.240 Dialer0

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
smothuku Wed, 02/28/2007 - 23:12

Hi ,

Have you configured username XXXX password XXXX on both routers as you are using chap for authentication.

Make the following changes and check the isdn status.

Router ABC

username XXXX (router XYZ hostname) password XXXX

interface Serial1

bandwidth 2048

backup delay 1 1

backup interface Dialer1

ip address 192.168.240.1 255.255.255.252

no ip directed-broadcast

!

interface BRI0

no ip address

no ip directed-broadcast

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

ppp authentication chap

!

interface Dialer1

ip address 192.168.10.1 255.255.255.252

no ip directed-broadcast

encapsulation ppp

dialer remote-name XYZ

dialer idle-timeout 300

dialer string 0212740020

dialer pool 1

dialer-group 1

ppp authentication chap

dialer-list 1 protocol ip permit

ip route 192.168.223.16 255.255.255.240 Dialer1 130

Router XYZ

username XXXX (router ABC hostname) password XXXX

interface Serial0

bandwidth 2048

ip address 192.168.240.2 255.255.255.252

no ip directed-broadcast

no ip route-cache

no ip mroute-cache

backup delay 1 1

backup interface Dialer0

!

interface BRI0

no ip address

no ip directed-broadcast

encapsulation ppp

no ip route-cache

no ip mroute-cache

dialer pool-member 1

isdn switch-type basic-net3

ppp authentication chap

!

interface Dialer0

ip address 192.168.10.2 255.255.255.252

no ip directed-broadcast

encapsulation ppp

dialer remote-name ABC

dialer idle-timeout 300

dialer caller 0514409044

dialer pool 1

dialer-group 1

ppp authentication chap

dialer-list 1 protocol ip permit

ip route 192.168.223.0 255.255.255.240 Dialer0 130.

Try to dial from router abc to router xyz...I changed dialer string to dialer caller under di0 of router xyz so that router abc can dial router xyz.

You are using isdn as a back up for serial so use floating static routes for isdn.I've added AD value of 130 at the end of ip route.

still you are facing the problem , paste the output of " debug isdn q931"

check the below link.

http://www.cisco.com/en/US/products/sw/iosswrel/ps1828/products_command_reference_chapter09186a00800ca52a.html

HTH

satish

afzaalq007 Wed, 02/28/2007 - 23:48

hi

thanks for the ans i will chk and will tell you the results.

one thing more I have usermane and password on the my router we are using them so want to ask you e,g on router ABC have follwing user name and passwords and same onthe xyz.

username zubair password ***

username admin1 privilege 9 password ***

will these work or not should i define more username and password fo r dialer CHAP ?????

waiting for ur response

Thanks and regaards

smothuku Wed, 02/28/2007 - 23:57

Hi ,

I think the username and passwords configured on both routers are for users who are accessing those routers , not for isdn call authentication.

Configure the following things on both routers.

Router ABC :

username XXXX (hostname of router XYZ) password XXXX.

Router XYZ

username XXXX(hostname of router ABC) password XXXX.

Note : password must be same on both routers and username must be hostname of the other end router.

dialer-remote name XXXX configured under dialer interface and username XXXX must be same.

HTH

satish

Actions

This Discussion