Still got PXE problems

Unanswered Question
Mar 2nd, 2007

Hi

We have put a PXE server in a LAB net.

The DHCP and the PXE isnt on the same server so I have configured two helper adresses on a 2611. Ive also starter ip mulsticast-routing and ip pim dense on the interfaces.

But still the PXE boot doesnt work.

I get DHCP and it recognise the pxe. But I cant download new images. I get PXE-E53 cant find file....

If i connect the client to the server vlan the everytthing work.

In my real net I use 3750 and the only thing thats configured there is a helper adress to the dhcp..

Any suggestions on problemsolving...

Thanks

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
dsweeny Fri, 03/09/2007 - 11:10

Pre-Execution Environment (PXE) allows a workstation to boot from a server on a network prior to booting the operating system on the local hard drive. A network administrator does not have to physically visit the specific workstation and manually boot it. Operating systems and other software, such as diagnostic programs, can be loaded onto the device from a server over the network. PXE environment uses DHCP to configure it's IP address.

The DHCP/BootP Relay Agent configuration must be done on the router if the DHCP server is located on another routed segment of the network. The ip helper address command on the local router interface must be configured.

Refer to http://www.cisco.com/en/US/tech/tk648/tk361/technologies_tech_note09186a00800f0804.shtml#configdhcpbootpciscoios for configuration information.

killroy Sat, 03/10/2007 - 06:22

Hi

But Ive already got a ipaddress from the dhcp. And I think I have contact whith pxe.

cratejockey Sat, 03/10/2007 - 14:34

I'm sure you have already done this step but you stated you think you have contact with the PXE, plug in a functioning workstation and verify that you are getting the correct IP and that you are able to ping the PXE server. Also from past experience if you have speed and duplex set to anything other than auto on the switch that can cause PXE issues. The the final point you mention this is working fine in production for you...what are the differences in hardware and configuration between you prod and test networks.

Good luck.

www.staticnat.com

Amit Singh Sat, 03/10/2007 - 23:54

in addition to the above posts, make sure that you have STP portfast enabled on the switch ports.

-amit singh

killroy Tue, 03/20/2007 - 03:10

What Ive found out is that the client is in contact with both dhcp and pxe servers.

But when the pxe script is trying to use:

net use h:xxxxx

It cant map h: to get a the image file

This works if you are on the same vlan as the servers.

Netbios problem??????

Actions

This Discussion