External mask...

Unanswered Question
Mar 2nd, 2007

I want to specify an external mask for my lines... but when I do this on my own DN for example, on my 7940 display in the upper right, it displays my number as my external mask too.

How can I have my phones' display only display my actual 4 digit DN, but have my number properlly mask for an external call.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Brandon Buffin Fri, 03/02/2007 - 07:02

One option is to set the Calling Party Transform Mask at the Route Pattern level. You could use 111222XXXX, for example which would give an external phone number of 111222 plus your 4 digit extension. This could also be done at the route list level.

Hope this helps. If so, please rate the post.

Brandon

censanian Fri, 03/02/2007 - 07:40

Somethings fishy. Weeks ago, external masks displayed fine(and our phone displays only displayed our 4 digit extensions) Then we had a second CM installed - and it seemed after this that the external masks stopped working correctly. So I took your advice and looked at the route-list and route-patterns.. and nothing was set... so ok... i entered on the route-list what external mask i wanted... when i saved the settings, and tried to place an outside call.. i got a busy signal right away and the call wouldnt place... when i removed the mask and set it how it was... I could then place an outside call.. BUT ALSO the external mask we original lost was restored! No idea how this happend... because I see no external masks set on the route-list, the route-pattern, or the phone DNs themselves. So Im stummped for the moment. Ill try to dig into things more and figure out where our mask is now coming from.

THanks much for the help Brandon!

Brandon Buffin Fri, 03/02/2007 - 07:45

Check the Caller ID DN on the gateway and the Caller ID service parameter (Service -> Service Parameters -> Callmanager Service -> Advanced -> Search for Caller ID).

Brandon

censanian Fri, 03/02/2007 - 09:45

nothing entered for caller id under the advanced parameters....

let me mention this... (excuse my newbie-ness, our phone guy who deployed our voip pilot quit and im picking up for him until we hire someone new, and i dont know everything there is to know about call manager and voip).. but..

voip is only deployed to a handfull of departments on our campus, the rest still on our legacy analog phone system... so our gateway runs into our legacy pbx, then out our carrier line... is it possible there is a setting on the pbx that is masking my voip calls?

Brandon Buffin Fri, 03/02/2007 - 10:23

Could be on the PBX or the trunk to the PBX. Also possible it could be hitting a translation pattern.

Brandon

Actions

This Discussion