1841 Routing Between Fast Ethernets

Unanswered Question

I have a probably simple problem with some. But here is what I have a 1841 router with Frame-Relay link to main office and Pix Firewall connected to a internet connection with VPN to main location.

What I am trying to accomplish but failing is have the serial connection the main for all internal traffic and the Pix (6.254) for the internet traffic. But when the serial goes down I want it to route the internal traffic over the VPN connection.

So right now I have the following config in a extra router and a pix hooked the 192.168.6.0 network on FastEthernet0/0 with laptop in that network also. On Fa0/1 I have the Corporate network hooked up for testing purposes then when I get it working I will put the correct information so the serial connection works.

I can ping the corporate through the pix but if I disconnect the pix I can not ping to any 172.16.0.0 address from the fa0/0 to fa0/1.

I am sure I have left something out but reply back if you have any other questions. I will attach current config below.

Building configuration...

Current configuration : 2379 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

!

resource policy

!

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

ip subnet-zero

ip cef

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.6.0 192.168.6.199

ip dhcp excluded-address 192.168.6.231 192.168.6.255

!

ip dhcp pool 0

network 192.168.6.0 255.255.255.0

domain-name test.com

dns-server 172.16.1.3 204.189.82.12

default-router 192.168.6.1

!

!

!

username admin privilege 15

!

!

class-map match-any VOIP

match access-group 105

match access-group 106

!

!

policy-map PriorityRoutes

class VOIP

priority percent 75

!

!

!

!

interface FastEthernet0/0

description InsideNetwork

ip address 192.168.6.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

description TestNetwork

ip address 172.16.13.10 255.255.0.0

duplex auto

speed auto

!

interface Serial0/0/0

description Frame-Relay

bandwidth 512000

ip address 192.168.250.5 255.255.255.0

encapsulation frame-relay

service-module t1 timeslots 1-8

frame-relay class FRTS

frame-relay map ip 192.168.250.1 33 broadcast

frame-relay map ip 192.168.250.2 34 broadcast

frame-relay lmi-type ansi

service-policy output PriorityRoutes

!

router eigrp 1

network 172.16.0.0

network 192.168.6.0

network 192.168.250.0

auto-summary

!

ip classless

ip route 0.0.0.0 0.0.0.0 FastEthernet0/0 192.168.6.254 permanent

ip route 172.16.0.0 255.255.0.0 Serial0/0/0 192.168.250.1 permanent

ip route 172.16.0.0 255.255.0.0 FastEthernet0/1 172.16.0.8 100

ip route 172.16.0.0 255.255.0.0 FastEthernet0/0 192.168.6.254 150

!

ip http server

!

!

map-class frame-relay FRTS

!

control-plane

!

!

line con 0

login local

line aux 0

line vty 0 4

login

!

end

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Anonymous (not verified) Thu, 03/08/2007 - 06:41

The default route to the corporate network is pointing through the PIX connection becuase of that when pix is removed it is not able to to connect to the corporate netwrok

Actions

This Discussion