Route-map probleme

Answered Question
Mar 3rd, 2007

we have a cisco 2801 with 2 WAN interface

isdn and ADSL

and all data comming from eth0/1 is routed to te serial 0/2/0

i try to redirect all data comming frome

eth 0/0 to ADSL with route-map lan0

it doesn't work untill i create a default

route 0.0.0.0 0.0.0.0 dialer 0

and if i did it :

0.0.0.0 0.0.0.0 dialer 0

all traffic coming frome eth 0/1 is blocked

normely if i did a route map it doesn't need a default route i think ?

her is my configuration (when i can't be connect to the internet frome eth 0/0 lan 10.10.10.0

Building configuration...

Current configuration : 5276 bytes

!

version 12.4

no service pad

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

service password-encryption

service sequence-numbers

!

hostname Router

!

boot-start-marker

boot-end-marker

!

no aaa new-model

!

resource policy

!

clock timezone PCTime 0

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

ip subnet-zero

no ip source-route

ip cef

!

!

ip tcp synwait-time 10

no ip dhcp use vrf connected

!

!

no ip bootp server

ip domain name yourdomain.com

ip name-server ip @ domain 1

ip name-server ip @ domain 2

ip ssh time-out 60

ip ssh authentication-retries 2

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address 10.10.10.1 /24

ip access-group sdm_fastethernet0/0_in in

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

ip route-cache flow

ip tcp adjust-mss 1412

ip policy route-map lan0

duplex auto

speed auto

no mop enabled

!

interface FastEthernet0/1

description $ETH-LAN$

ip address IP @ A

ip access-group 100 in

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

ip route-cache flow

ip tcp adjust-mss 1412

duplex auto

speed auto

no mop enabled

!

interface ATM0/1/0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip route-cache flow

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0/1/0.1 point-to-point

pvc 8/35

oam-pvc manage

pppoe-client dial-pool-number 1

!

!

interface Serial0/2/0

ip address IP @ B

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat outside

ip route-cache flow

!

interface Dialer0

ip address negotiated

ip mtu 1452

ip nat outside

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication chap pap callin

!

ip classless

ip route 0.0.0.0 0.0.0.0 Serial0/2/0

!

!

ip http server

ip http access-class 1

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

ip nat inside source list ACL_10 interface Dialer0 overload

!

ip access-list extended ACL_10

remark SDM_ACL Category=2

permit ip 10.10.10.0 0.0.0.255 any

ip access-list extended sdm_fastethernet0/0_in

remark SDM_ACL Category=1

permit ip any any

!

logging trap emergencies

access-list 120 permit ip 10.10.10.0 0.0.0.255 any

dialer-list 1 protocol ip permit

no cdp run

route-map lan0 permit 10

match ip address 120

set ip next-hop ip@ of my ISP

!

!

!

!

control-plane

!

!

end

could you help me

thank's

I have this problem too.
0 votes
Correct Answer by kunalpurk about 9 years 7 months ago

What i understanf from ur scenario is that ur outbound traffic towards the internet is taking the ADSL link as the primary and the ISDN link as the secondary link.Now , u want ur traffic coming from 10.0.0.0/24 network to always take the ADSL link to go outside and in case of any failure in the primary link, it would take the ISDN link.

Change ur route-map a bit :-

route-map lan0 permit 10

match ip address 120

set ip next-hop ip@ of my ISP

route-map lan0 permit 20

match ip address 130

access-list 130 permit ip any any

moreover, use 2 default routes ( one towards serial and one towrads dialer with a hiher AD value)

ip route 0.0.0.0 0.0.0.0 Serial0/2/0

ip route 0.0.0.0 0.0.0.0 dialer0 10

Note: Remember the route-map always gets the priority over any other type of routes during the route lookup.

Hope this works out for u.Rate the post if it works or else get back with some further details.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (2 ratings)
Loading.
Correct Answer
kunalpurk Mon, 03/05/2007 - 03:41

What i understanf from ur scenario is that ur outbound traffic towards the internet is taking the ADSL link as the primary and the ISDN link as the secondary link.Now , u want ur traffic coming from 10.0.0.0/24 network to always take the ADSL link to go outside and in case of any failure in the primary link, it would take the ISDN link.

Change ur route-map a bit :-

route-map lan0 permit 10

match ip address 120

set ip next-hop ip@ of my ISP

route-map lan0 permit 20

match ip address 130

access-list 130 permit ip any any

moreover, use 2 default routes ( one towards serial and one towrads dialer with a hiher AD value)

ip route 0.0.0.0 0.0.0.0 Serial0/2/0

ip route 0.0.0.0 0.0.0.0 dialer0 10

Note: Remember the route-map always gets the priority over any other type of routes during the route lookup.

Hope this works out for u.Rate the post if it works or else get back with some further details.

youssef_bensouda Wed, 03/07/2007 - 02:37

thank's for all this informations

it work's now the probleme was wen i use the next-hop ip addresse

i use the "set interface (adsl)"

thank's

Oscar Cardiel Mon, 03/12/2007 - 09:29

Hi there,

I think that your route-map is wrong, it would be:

route-map lan0 permit 10

match ip address 120

set interface dialer 0

youssef_bensouda Wed, 03/14/2007 - 07:08

Exactly that was the problem i put set ip interface (next hop)

when i made set interface it works

thank's for ur advice

thank's ALL

Actions

This Discussion