cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
390
Views
0
Helpful
5
Replies

Vlan issue

smothuku
Level 7
Level 7

Hi All,

I am facing problem with vlan's.Setup is as follows.

2950 switch (f0/3)-- (f0/0.14)R1 (s0/0/0:0)--s0/0/0:0 R2 router.

R1 and R2 are 2811 routers.

The config is as follows.

2950 switch:

nterface FastEthernet0/1

switchport access vlan 12

switchport mode access

!

interface FastEthernet0/2

switchport mode access

!

interface FastEthernet0/3

switchport access vlan 14

switchport mode access

.

.

interface Vlan11

ip address 10.105.40.11 255.255.255.0

no ip route-cache

!

ip default-gateway 10.105.40.2

R1 router:

interface FastEthernet0/0

no ip address

duplex full

speed 100

!

interface FastEthernet0/0.11

encapsulation dot1Q 11 native

ip address 10.105.40.2 255.255.255.0

no snmp trap link-status

standby 1 ip 10.105.40.1

standby 1 priority 105

standby 1 preempt

!

interface FastEthernet0/0.12

encapsulation dot1Q 12

ip address 10.105.41.2 255.255.255.128

no snmp trap link-status

standby 2 ip 10.105.41.1

standby 2 priority 105

standby 2 preempt

!

interface FastEthernet0/0.13

encapsulation dot1Q 13

ip address 10.105.41.130 255.255.255.128

no snmp trap link-status

standby 3 ip 10.105.41.129

standby 3 priority 105

standby 3 preempt

!

interface FastEthernet0/0.14

encapsulation dot1Q 14

ip address 10.105.42.2 255.255.255.0

no snmp trap link-status

standby 4 ip 10.105.42.1

standby 4 priority 105

standby 4 preempt

!

interface FastEthernet0/0.101

description ****Existing Technical SRV Zone Subnet ************

encapsulation dot1Q 101

ip address 192.0.100.11 255.255.255.0

no snmp trap link-status

standby 5 ip 192.0.100.10

standby 5 priority 105

standby 5 preempt

!

interface FastEthernet0/0.102

description ****Existing Tech DMZ Subnet****

encapsulation dot1Q 102

ip address 10.104.9.11 255.255.255.0

no snmp trap link-status

standby 6 ip 10.104.9.10

standby 6 priority 105

standby 6 preempt

!

interface FastEthernet0/0.103

description ****Existing Comverse Subnet****

encapsulation dot1Q 103

ip address 192.9.205.11 255.255.255.0

no snmp trap link-status

standby 7 ip 192.9.205.10

standby 7 priority 105

standby 7 preempt

!

interface FastEthernet0/0.104

description ****Existing Vlan****

encapsulation dot1Q 104

ip address 192.0.196.11 255.255.255.0

no snmp trap link-status

standby 8 ip 192.0.196.10

standby 8 priority 105

standby 8 preempt

!

interface FastEthernet0/1

no ip address

duplex full

speed 100

!

interface Serial0/0/0:0

description **** E1link to AND_DR02_HYD ****

ip address 10.254.238.6 255.255.254.0

encapsulation ppp

!

interface Serial0/0/1:0

no ip address

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.0.100.13

ip route 10.105.3.0 255.255.255.0 Serial0/0/0:0

5 Replies 5

smothuku
Level 7
Level 7

sorry for lenghty config....

R2 router:

interface GigabitEthernet0/0

description CONNECTED TO AND_CS01_HYD

ip address 10.105.3.9 255.255.255.128

no ip proxy-arp

duplex full

speed 1000

media-type rj45

no negotiation auto

standby 2 ip 10.105.3.7

standby 2 priority 105

standby 2 preempt

!

interface GigabitEthernet0/1

description CONNECTED TO AND_DR01_HYD

no ip address

no ip proxy-arp

duplex full

speed 1000

media-type rj45

no negotiation auto

!

interface Serial0/0/0:0

description **** E1link to AND_DR02_ABI ****

ip address 10.254.238.9 255.255.254.0

encapsulation ppp

!

ip classless

no ip route static inter-vrf

ip route 0.0.0.0 0.0.0.0 Serial0/0/0:0

ip route 10.104.9.0 255.255.255.0 10.254.238.10

ip route 10.105.40.0 255.255.255.0 10.254.238.10

ip route 10.105.41.0 255.255.255.0 10.254.238.10

ip route 10.105.42.0 255.255.255.0 10.254.238.10

ip route 192.0.100.0 255.255.255.0 10.254.238.10

ip route 192.0.196.0 255.255.255.0 10.254.238.10

ip route 192.9.205.0 255.255.255.0 10.254.238.10

1.when i am trying to ping serial ip (10.254.238.9 and 10.254.238.9) from 2950 switch , it is not pinging.

2.I am not able to reach 10.105.3.1 (host connected to 3750 switch which is in vlan) from siwtch as well as R1 router.

Is there any wrong in the config.

Thanks,

satish

Shouldn't be the Switch 2950 fa0/3 in 802.1q trunk since the Router R1 fa0/0.14 is encapsulated to 802.1q?

i.e.

!

interface FastEthernet0/3

switchport trunk encapsulation dot1q

switchport mode trunk

Hi Medan,

Thanks you very much for reply and info.

Suppose if i want use f0/3 of 2950 switch in val14 what could be the config of 2950 and R1 router.(i don't want to use f0/3 as trunk port)

Can you give me an example of configuring vlan between 2950 switch and 2811 router.

Cheers,

satish

Hi Satish,

Don't use sub-interface with encapsulation or sub-interface in R1. But your R1 sub-interfaces are in HSRP with another Router?

Else, find another port in Switch 2950 that you can connect to R1 and trunk

Dandy

Satish,

Create a trunk between R1's port and the 2950 switchport. Also configure the Native vlan as 11 on the trunk link, otherwise the link will not work properly and you will see a lots of issue.once the trunk is up, you should be fine.

-amit singh

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card