branch office cant dial 9.411

Unanswered Question
Mar 5th, 2007

can you guys point me in the right direction - i have a branch office that cant dial information. the route patterns dial peers are not a strong point for me. i have read some cisco white papers concerning dial plan but it is so complicated - i need to begin at the very basic level - recommendations?

thanks in advance

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
lfulgenzi Mon, 03/05/2007 - 16:13

It would help if you post the dial-peer config, but I'll make a guess and try to help out. Also, you mention route patterns, typically it's one or the other.

First, I agree, it takes a while to get dial-peers straight, especially after you've worked with CallManager for so long.

I've just gone through a crash course of learning how to program dial-peers because we're implementing SRST on the branch router.

The one thing that slipped by me is how a POTS dial-peer behaves over a voip dial-peer. With a POTS dial-peer, only the non-explicity matched digits are forwarded by default. So, if you have a dial-peer that is 9411 then it is explicitly matching all digits and none are forwarded. You would need to add a "prefix 411" or "forward digits 3" to the dial-peer to make it work.

A sample is below:

dial-peer voice 411 pots

destination-pattern 9411

port 3/0:23

forward-digits 3

If you are using CoR lists, then I would suggest removing the CoR lists and getting things working simply.

Once you get dial-peers working, then you can revisit CoR lists.

If you are having problems getting 9.411 to work with CallManager route patterns, i.e. CCM controlled gateways, then you'll have to look at your transformations on your route pattern, route list and route groups.

Again, make it simple, point the route pattern to the gateway directly if you can to simplify things. Otherwise, remember that the settings of a route list overwrite those of the route pattern. Depending on your trunk, you'll likely need to do a 'drop pre-dot' on the pattern.

Let us know how that helps or doesn't and we'll follow up.

jerry.mcrae Mon, 03/05/2007 - 16:29

our branch office is conneted via a t1. it doesnt have a connection to the pstn so all calls must route over the t1 and out our gateway in my office where call manager lives.

lfulgenzi Mon, 03/05/2007 - 16:33

If you are connecting via a data T1, i.e. the phone appears almost as if it was oncampus, then it's likely a partition and calling search space issue.

Have you tried assigning one of the phones a calling search space that an oncampus phone has?

thisisshanky Mon, 03/05/2007 - 16:17

I have had a client where they could dial 411 only if they prefix a 0 in front of it. Telco accepted the 411 call as long as they see 0411..

Tommer Catlin Mon, 03/05/2007 - 16:22

And to even throw a bigger wrench, someone could have had the local telcos block 411 access to your trunks. So no matter what combo you dialed in CCM, the LEC would bounce it.

Actions

This Discussion