CUE integrated with CCM (JTAPI) and 6608 transcoder

Answered Question
Mar 5th, 2007
User Badges:
  • Silver, 250 points or more

Hi,


I am getting a capabilities mismatch error when an IP Phone tries to call a CUE registered as JTAPI to CCM (CTI Route Point). The IP Phone and CUE CTI port are in different device pools and regions, and need to use G729 to communicate. Both have the same MRGL and have access to same 6608 transcoder. Region config is set up so it is G729 between both regions. IP Phone calls between regions work fine, is just a issue with the CUE.


When the IP Phone calls the CUE CTI RP it rings once, then gets busy signals. If we put IP Phone in same device pool (same region) where it is all G711 it works fine.


Does anyone know if there is issue with CUE w/JTAPI integration and using 6608 as a transcoder? This is also on CCM 4.0(2a)sr2b. I have not been able to find anything as of yet.


In the CCM trace seeing capabilities mismatch, I am seeing the below.


Portion from CCM Detailed trace:


03/02/2007 15:50:59.466 CCM|MediaResourceCdpc::device_lookup_DmPidRes

MtpResource=MTP001300307A12

Cepn={2CBE4616-8F14-4E1E-A398-FE29553084BA}|<CLID::StandAloneCluster><NI

D::10.10.11.13><CT::1,200,10,1.1971746><IP::10.12.10.6><DEV::CTI_po

rt_1045>


03/02/2007 15:50:59.466

CCM|MediaTerminationPointControl(3)::waiting_AllocateMtpResourceReq -

(capCount,region),A(8,WAN),B(2,SiteD), reqDtmfCapability=0|

<CLID::StandAloneCluster><NID::10.10.11.13><CT::1,200,10,1.1971746><I

P::10.12.10.6><DEV::CTI_port_1045>


03/02/2007 15:50:59.466 CCM|RegionsServer::MatchCapabilities -- kbps=8,

capACount=8, capBCount=11|<CLID::StandAloneCluster><NID::10.10.11.13>


03/02/2007 15:50:59.466 CCM|RegionsServer::MatchCapabilities -- kbps=8,

capACount=2, capBCount=11|<CLID::StandAloneCluster><NID::10.10.11.13>


03/02/2007 15:50:59.466

CCM|MediaTerminationPointControl(3)::waiting_AllocateMtpResourceReq -

ERROR - mismatch cap. match1=4,

match2=0|<CLID::StandAloneCluster><NID::10.10.11.13><CT::1,200,10,1.1

971746><IP::10.12.10.6><DEV::CTI_port_1045>



Anyone know what the mismatch code above decodes to?

Correct Answer by gogasca about 10 years 1 month ago

Ah ok, check the Device Pool of the 6608XCODER its region should speak G711 with CUE and G729 with IP Phones|GW.


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
gogasca Mon, 03/05/2007 - 22:12
User Badges:
  • Green, 3000 points or more

Hi...

Could you please make sure that 6608 speaks G711 to CUE and G729 to IP Phones...

if all is good there could you please upload the complete CCM detailed trace.

Erick Bergquist Mon, 03/05/2007 - 22:21
User Badges:
  • Silver, 250 points or more

How do I go about double checking that? It is a 6608 so is all done from CCM. I thought I looked everywhere, but just in case.

Correct Answer
gogasca Tue, 03/06/2007 - 07:18
User Badges:
  • Green, 3000 points or more

Ah ok, check the Device Pool of the 6608XCODER its region should speak G711 with CUE and G729 with IP Phones|GW.


Erick Bergquist Tue, 03/06/2007 - 07:35
User Badges:
  • Silver, 250 points or more

Ahh... I was 3/4 of the way down that path but did not put that piece of the puzzle together.


Right now the CUE is in same device pool as remote sites with the phones, etc so what needs to be done is:


Create separate device pool and region for CUE

Set up 6608 device pool so it speaks to CUE region as G711

Maybe put the 6608 transcoder in it's own device pool/region also, depending on how much they want to separate things.


Thanks for your help.


Actions

This Discussion