Priotry QoS on My multiple traffic

Unanswered Question
Mar 6th, 2007
User Badges:

Hi

I am hving P2P connectivity between my head office and remote office with 128 kbps link.


they are access database server & lotus notes mail server .


They r facing issue facing data base server .


I have found my mail traffice is using most of the bandwidth.


I like to apply PQ on the basis of ACESS LIST .


mY FOUR DATA BASE SERVER IS


10.10.10.1

10.10.10.2

10.10.10.3

10.10.10.4


i LIKE TO GIVE HIGH Priority to this traffic


Can any body advice how i can achive.


Can u tell me on which site i hve to applied this Priority List.




  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Anonymous (not verified) Tue, 03/06/2007 - 02:50
User Badges:

First create an access list:

access-list 10 permit 10.10.10.1

access-list 10 permit 10.10.10.2

access-list 10 permit 10.10.10.3

access-list 10 permit 10.10.10.4


Then create a priority list linked to the access list:

priority-list 1 protocol ip high list 10

priority-list 1 default low


then assign priority-group 1 to your external interface.


Hope this helps

jitendra_pipalia Tue, 03/06/2007 - 08:54
User Badges:

hi


Actully I have created access list as below


access list 101 permit ip any host 10.10.10.1

access list 101 permit ip any host 10.10.10.2

access list 101 permit ip any host 10.10.10.3

access list 101 permit ip any host 10.10.10.4


Will be right ?


and I have applied this priority list to serail interface of my remote router.


Can u tell me i hve to applied on both the router?


One which is in my head office and other in my remote office.


mY Main concern that my remote site users should get this server application faster.

Anonymous (not verified) Tue, 03/06/2007 - 23:51
User Badges:

Its best to stick with a standard access list, not an extended one.

Yes you should apply it to both routers.

jitendra_pipalia Wed, 03/07/2007 - 09:59
User Badges:

hi


thnaks for the information.


But today it was same issue .no much improvement on performance.


Any other way of queuing method to resolve issue ?



csco10387876 Thu, 03/08/2007 - 02:12
User Badges:

Hi,


I think the best solution would be if applicable :


you should apply classification and marking of your mail traffic on both user port and server port with a priority of AF31 or CS3


then on both side of your wan link you should apply LLQ (CBWFQ+PQ) with a class for mail and for this class in your policy map use priority percent.


if you look on the cisco website you should find some sample config.


Luc


hope it helps

mheusinger Thu, 03/08/2007 - 02:35
User Badges:
  • Green, 3000 points or more

Hi,


First, are you sure your ACL on BOTH sides describe the traffic correctly? As the traffic direction is different you need to exchange source and destination on one of your routers. Do you get matches (show ip access-list)?


Second, there are better queueing methods (depending on your IOS version), like CBWFQ.

If you like, then try CBWFQ, which could look like this in your case:


Server side router

ip cef


class-map match-all Mail

match ip address 100


policy-map Mypolicy

class Mail

bandwidth percent 50 !adjust to your needs up to 75%

class class-default

fair-queue

random-detect


interface Serial0/0

description line to your branch office

bandwidth 128

ip address 10.0.0.1 255.255.255.252

no fair-queue

service-policy output Mypolicy


access-list 100 permit ip host 10.10.10.1 any

access-list 100 permit ip host 10.10.10.2 any

access-list 100 permit ip host 10.10.10.3 any

access-list 100 permit ip host 10.10.10.4 any





Branch office router:

ip cef


class-map match-all Mail

match ip address 101


policy-map Mypolicy

class Mail

bandwidth percent 50 !adjust to your needs up to 75%

class class-default

fair-queue

random-detect


interface Serial0/0

description line to head office

bandwidth 128

ip address 10.0.0.2 255.255.255.252

no fair-queue

service-policy output Mypolicy


access-list 101 permit ip any host 10.10.10.1

access-list 101 permit ip any host 10.10.10.2

access-list 101 permit ip any host 10.10.10.3

access-list 101 permit ip any host 10.10.10.4


You need to adjust interface namings, IP addresses and the like to your envitonment.


I would also advise you to read f.e. "Enterprise QoS Solution Reference Network Design Guide Version 3.3" and especially the section about brach office QoS.

http://www.cisco.com/application/pdf/en/us/guest/netsol/ns432/c649/ccmigration_09186a008049b062.pdf


Finally: QoS does NOT create bandwidth! So if your line is too small for the traffic you have, only a line upgrade can help. QoS just sorts out, which traffic gets the little bandwidth available. 128k maybe not enough, taking into account emails with tens of MB attachements.


Hope this helps! Please use the rating system.


Regards, Martin

Actions

This Discussion