VLAN over WAN

Answered Question
Mar 6th, 2007

Hello all,


I have the following situation. I have 2 locations connected as described in the attached image, via a 2Mbps leased line. Both routers are connected each to a switch (non-cisco at the moment) and I have a server attached to those switches, one in each location.


My problem is that the servers have to be in the same vlan. How would I go about configuring that ? How do I transport VLAN information across the leased line ? Any help is appreciated.


Thanks,

Stefan



Attachment: 
Correct Answer by Amit Singh about 9 years 11 months ago

Please follow the link that I pasted above. There is not virtual BVI interface on your routers. Please configure an BVI interface on both the routers.


-amit singh

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
rts-net-support Tue, 03/06/2007 - 06:47

Thank you for the link. So basically I create a BVI interface and assign the Serial0/0 to the bridge group. Then create dot1q ethernet subinterfaces for the trunking to the switches. Does that make sense? Could you possibly post a sample configuration ?


Thanks,

Stefan

rts-net-support Wed, 03/07/2007 - 03:32

Some follow up on this issue. On both routers, I put the ethernet and serial interfaces in the same bridge group and I believe the bridging works fine now. If I do debugging on STP, I see topologies changes, events and so on. However, nothing else works. ARP requests wont get through for example. I can't reach IPs from the other side also. Here's the config I have now:


Router 1

--------

bridge irb


interface FastEthernet0/0

ip address 172.16.3.34 255.255.255.0

bridge-group 2


interface Serial0/0

bandwidth 2048

ip address 192.168.10.5 255.255.255.0

bridge-group 2


bridge 2 protocol ieee

bridge 2 route ip


Router 2

--------

bridge irb


interface Ethernet0/0

ip address 172.31.3.250 255.255.255.0

bridge-group 2


interface Serial0/0

bandwidth 2048

ip address 192.168.10.6 255.255.255.0

bridge-group 2


bridge 2 protocol ieee

bridge 2 route ip



router1#show bridge


Total of 300 station blocks, 298 free

Codes: P - permanent, S - self


Bridge Group 2:


Address Action Interface Age RX count TX count

0000.d1ef.4a44 forward FastEthernet0/0 0 253 0

0009.3d13.5c77 forward FastEthernet0/0 0 661 0

router1#show bridge group


Bridge Group 2 is running the IEEE compatible Spanning Tree protocol


Port 4 (FastEthernet0/0) of bridge group 2 is forwarding

Port 6 (Serial0/0) of bridge group 2 is forwarding



router2#show bridge


Total of 300 station blocks, 299 free

Codes: P - permanent, S - self


Bridge Group 2:


Address Action Interface Age RX count TX count

0030.0528.002a forward Ethernet0/0 0 499 0


router2#show bridge group


Bridge Group 2 is running the IEEE compatible Spanning Tree protocol


Port 2 (Ethernet0/0) of bridge group 2 is forwarding

Port 6 (Serial0/0) of bridge group 2 is forwarding


Any ideas ?



Correct Answer
Amit Singh Wed, 03/07/2007 - 10:14

Please follow the link that I pasted above. There is not virtual BVI interface on your routers. Please configure an BVI interface on both the routers.


-amit singh

rts-net-support Mon, 03/12/2007 - 07:33

Just wanted to follow up on this. The problem was finally solved. Here is the config that i have now on both routers:


bridge irb


interface Ethernet0/0

no ip address

half-duplex

bridge-group 1

!

interface Serial0/0

bandwidth 2048

bridge-group 1


interface BVI1

ip address 172.16.3.40 255.255.255.0


bridge 1 protocol ieee

bridge 1 route ip


Thanks Asingh2.


Regards,

Stefan

Actions

This Discussion