VLAN doesn't get transmitted over trunk; 'error' message

Unanswered Question
Mar 8th, 2007

I have DLSWitchA = Cat 3550.

ALSwitchA1 and ALSwitchA2 are Cat 2912 connected via crossover cable to Cat 3550 ports fa0/1 and fa0/2 respectively.

Then I configured the port on the cat 3550 as

int fa0/1

switchport encap dot1q

switchport trunk

Then I go to my cat 2912, and I make it as a vtp client, I put 'vtp domain mynameasCat3550'.

Then I do #show vlan on my C2912, but I see that there is no vlan info propagated from the vtp server.

I noticed that on my ALSwitch (Cat 2912), the trunk negotiation=disabled. So far I have been researching how I should adjust this on the c2912 to "on" but I can't find the command. Please advise.

Output from Cat 3550

DLSwitchA#show int fa0/1 switchport

Name: Fa0/1

Switchport: Enabled

Administrative Mode: trunk

Operational Mode: trunk

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: On

Access Mode VLAN: 1 (default)

Trunking Native Mode VLAN: 1 (default)

Voice VLAN: none

Administrative private-vlan host-association: none

Administrative private-vlan mapping: none

Administrative private-vlan trunk native VLAN: none

Administrative private-vlan trunk encapsulation: dot1q

Administrative private-vlan trunk normal VLANs: none

Administrative private-vlan trunk private VLANs: none

Operational private-vlan: none

Trunking VLANs Enabled: ALL

Pruning VLANs Enabled: 2-1001

Capture Mode Disabled

Capture VLANs Allowed: ALL

Protected: false

Unknown unicast blocked: disabled

Unknown multicast blocked: disabled

Appliance trust: none

DLSwitchA#

DLSwitchA#

Output from Cat 2912

ALSwitchA2#show int fa0/1 switchport

Name: Fa0/1

Switchport: Enabled

Administrative mode: trunk

Operational Mode: trunk

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: Disabled

Access Mode VLAN: 0 ((Inactive))

Trunking Native Mode VLAN: 1 (default)

Trunking VLANs Enabled: ALL

Trunking VLANs Active: 1,10,20

Pruning VLANs Enabled: 2-1001

Priority for untagged frames: 0

Override vlan tag priority: FALSE

Voice VLAN: none

Appliance trust: none

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
hoogen_82 Thu, 03/08/2007 - 23:14

Hi,

The link errors, please check your duplex and speed settings again on your trunks, possibly hard code them. Post the show interface output.

In some command outputs, *-inconsistent STP state is referred to as ?broken.?

HTH

Hoogen

news2010a Thu, 03/08/2007 - 23:38

Please see that I updated my message after submitting it; I did 'show int fa0/1 switchport' and I noticed that the trunk negotiation=disabled on the cat 2912. On the cat 3550 is set to 'on'.

Can you please tell me whether the negotiation is the problem and how I can issue the command to adjust this on my cat 2912? I can't find that sucker command.

Find below result of the show int fa0/1 on both switches just in case. It seems that the duplex settings and speed are OK.

ALSwitchA2#show int fa0/1

FastEthernet0/1 is up, line protocol is up

Hardware is Fast Ethernet, address is 0004.c09e.ad01 (bia 0004.c09e.ad01)

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive not set

Auto-duplex (Full), Auto Speed (100), 100BaseTX/FX

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:20, output 00:00:01, output hang never

Last clearing of "show interface" counters never

Queueing strategy: fifo

Output queue 0/40, 0 drops; input queue 0/75, 0 drops

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

1772 packets input, 160645 bytes

Received 1281 broadcasts, 0 runts, 0 giants, 0 throttles

86 input errors, 86 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 1276 multicast

0 input packets with dribble condition detected

7215 packets output, 268984 bytes, 0 underruns

0 output errors, 0 collisions, 1 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier

0 output buffer failures, 0 output buffers swapped out

ALSwitchA2#show int fa0/1

FastEthernet0/1 is up, line protocol is up (connected)

Hardware is Fast Ethernet, address is 0011.2192.3681 (bia 0011.2192.3681)

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 100Mb/s

input flow-control is off, output flow-control is off

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:00, output 00:00:09, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 1000 bits/sec, 2 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

2690 packets input, 240001 bytes, 0 no buffer

Received 2690 broadcasts (0 multicast)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 2684 multicast, 0 pause input

0 input packets with dribble condition detected

6876 packets output, 511782 bytes, 0 underruns

--More--

news2010a Thu, 03/08/2007 - 23:46

Hey never mind. I see that the vlans are being propagated to the cat 2912 vtp client just OK now in spite of the trunk mode=disabled on the cat 2912. Interesting...

Thanks again and sorry for my mistakes. The initial problem is that the trunk was set to 'isl' on the cat 2912 and 'do1q' on the cat 3550.

flashsplash Fri, 03/09/2007 - 01:43

a recomendation is that if u'll use the port as trunkports just hardcode them as trunk and disable the negociation proces to reduce overhead.

Actions

This Discussion