H323 Gateway Call Preservation Failure

Unanswered Question
Mar 9th, 2007
User Badges:

Have CallManagers at central site and an H323 gateway with PRI at remote site. All devices are registered to the Subscriber with Publisher as secondary.


When remote site is on an active PRI and the SUB goes down, the call is preserved. However, if the SUB comes back online during the same call, the call terminates right at 10 seconds every time. The same thing happens if the WAN fails and the remote site goes into SRST. The call is preserved during failure but if the WAN comes back up during the same call, again, the call terminates right at 10 seconds of the SUB coming online. Is there a setting/timer on the gateway or within CallManager that is missing?


Here is the config for the remote gateway:


voice service voip

h323

no h225 timeout keepalive


voice class codec 1

codec preference 1 g729r8

codec preference 2 g711ulaw


voice class h323 1

h225 timeout tcp establish 3


dial-peer voice 7 voip

description Subscriber

destination-pattern 2...

voice-class codec 1

voice-class h323 1

session target ipv4:192.168.1.2

incoming called-number .

dtmf-relay h245-alphanumeric

no vad


dial-peer voice 8 voip

description Publisher

preference 1

destination-pattern 2...

voice-class codec 1

voice-class h323 1

session target ipv4:192.168.1.1

incoming called-number .

dtmf-relay h245-alphanumeric

no vad


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
mparekh Fri, 03/09/2007 - 09:15
User Badges:
  • Bronze, 100 points or more

If you have IOS version 12.4 you can try to use the call preserve command that was introduced:

http://www.cisco.com/en/US/products/ps6441/products_feature_guide09186a008069ad1b.html


I also bind h323 to our loopback address, ex:

interface Loopback0

description Management Interface

ip address 10.1.29.233 255.255.255.255

h323-gateway voip interface

h323-gateway voip bind srcaddr 10.1.29.233

johnnylingo Mon, 05/21/2007 - 12:16
User Badges:
  • Bronze, 100 points or more

When configuring "call preserve", I get the following message:


Warning: Configuring media inactivity detection to avoid hung calls is highly recommended.


I've been looking through the docs on media inactivity detection, however I'm running IOS 12.4(11)T2 and the syntax seems different.


Does anybody have a working config example they could share?



keanej Fri, 10/03/2014 - 03:58
User Badges:

 

The config below is the config for media inactivity detection !

 

application

package callfeature

param med-inact-det enable

param med-inact-disc-cause 16

param med-inact-action disc

gogasca Mon, 05/21/2007 - 14:24
User Badges:
  • Green, 3000 points or more

http://www.cisco.com/en/US/products/sw/iosswrel/ps5207/products_configuration_guide_chapter09186a00802b45e0.html#wp1149764


You need to enable the call preserve CLI on the router running 12.4(11)T or later and be running CM 4.1(3)sr2 or later with the call preservation service parameter enabled (Allow Peer to Preserve H.323 Calls) which is under

CallManager advanced service parameters.


johnnylingo Mon, 05/21/2007 - 16:21
User Badges:
  • Bronze, 100 points or more

Right, so the configuration for H.323 call preservation is:


voice service voip

h323

call preserve

!


I also configured this:


application

package callfeature

param med-inact-det enable

param med-inact-disc-cause 16

param med-inact-action disc

!

!


However, I'm skeptical it's working. If I make an outbound call and then put both sides on mute, the call stays up whereas I would think the gateway detect the media inactivity and disconnect it.

Actions

This Discussion