RIPv2 Deafult route problem

Unanswered Question
Mar 9th, 2007

RIP Default Problem:

I am having a network between two routers A and B. There are three connectivities exist.

a) Serial link between A and B

b) Two Layer 2 path between A and B via Fiber.

I want to run RIPv2 only for my fiber path and utilise the fiber path as well and the default traffic from B should be via fiber through RIP. Higher AD static default has been put pointing to the Serial to A. But after the config also i m not learning the default path via my fiber (still its preferring Serial). Apart from that the customer static routes in router B are getting learned in Router A.

I attached the config template here.

At Router A:

interface Serial 1

ip address 1.1.1.1 255.255.255.252

router rip

version 2

timers basic 5 15 15 22

network 10.10.10.0

default-information originate route-map RIP

no auto-summary

route-map RIP, permit, sequence 10

Match clauses:

ip address prefix-lists: RIP

Set clauses:

Policy routing matches: 0 packets, 0 bytes

ip prefix-list RIP: 2 entries

seq 5 permit 0.0.0.0/0

seq 10 deny 0.0.0.0/0 le 32

Fiber Interfaces:

interface GigabitEthernet0/2

ip address 10.10.10.1 255.255.255.252

no ip split-horizon

no cdp enable

end

interface GigabitEthernet0/3

ip address 10.10.10.5 255.255.255.252

no ip split-horizon

no cdp enable

end

The Default route for router A is pointed to its upstream router.

In Router A, the default route is not showing in the RIP database.

sh ip rip database 0.0.0.0 0.0.0.0

%Route not in database

At Router B:

interface Serial 1

ip address 1.1.1.2 255.255.255.252

router rip

version 2

timers basic 5 15 15 22

redistribute connected

redistribute static

network 10.10.10.0

no auto-summary

interface FastEthernet0/0

ip address 10.10.10.2 255.255.255.252

ip rip advertise 5

no ip split-horizon

no cdp enable

end

interface FastEthernet0/0.703

ip address 10.10.10.6 255.255.255.252

ip rip advertise 5

no ip split-horizon

no cdp enable

end

ip route 0.0.0.0 0.0.0.0 1.1.1.1 150

Default route at Router B is pointed to Serial 1 with AD 150, but the default route that should be learning via RIP is not learning. Still its showing the static default pointed to Serial 1.

sh ip rip datbase 0.0.0.0 0.0.0.0 command at Router B shows:

0.0.0.0/0 redistributed

[1] via 0.0.0.0,

[1] via 0.0.0.0,

I tried by

a) putting the no split-horizon command on all the fiber interfaces of both the routers but in vain. In Router A, i'm not able to issue the command "ip rip advertise".

b) issued the neighbor command in router rip config on both the routers.

c) whenever im denying the static deafult configured on router B, the rip database doesnt show the default route entry.

At router B:

sh ip rip database 0.0.0.0 0.0.0.0

%Route not in database

what could be the possible cause for this issue.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
kyawzawhtut Sun, 03/11/2007 - 23:31

What exactly is your reason to put route-map?

Try to take out route-map and see what you get in Rtr B.

HTH

Cheers

Kyaw

Actions

This Discussion