DST Phone Time not updating

Answered Question
Mar 11th, 2007

Phone time not updating. CM Server time is correct.

Running CM OS 4.4SR4, CM 4.2.3ES20

I have this problem too.
0 votes
Correct Answer by mchandak about 9 years 7 months ago

upgrade the phones to the latest firmware and that should solve the issue.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (4 ratings)
tboynton Sun, 03/11/2007 - 06:26

On 5.1 a reset of the phone will cause it to update the time. A restart does not change the time. trying to find information about how often the phones update their time from callmanager.

ava5868112 Mon, 03/12/2007 - 10:14

Same here with 7912g. installed new firmware and still no change.

ischarcm Sun, 03/11/2007 - 06:22

same here cm 3.3.3. DId manual work around of changing time on CM... phones have not updated as stated they would...

rob.huffman Sun, 03/11/2007 - 07:24

Hi Guys,

Java based phones (7911,7941,7961,7970 etc) should have updated immeadiatly if they have the latest phone firmware (either 8.2.1 or 8.0.4-2) Other phones like 7912,7940 and 7960 will take awhile. The phone updates its time at the completion of each call. You can reset the phones to speed up this process.

Hope this helps!


ischarcm Sun, 03/11/2007 - 07:35


Hi what is a while? Its been 2 hours almost and I have made and completed a call on my 7940. Still shows 8:34 and the correct time is 9:34. The computer time of my call manager publisher is 9:34 as well as my subscribers... I changed the time on them over two hours ago.... IP phone time is still incorrect...

Can you help??


tboynton Sun, 03/11/2007 - 07:49

Well,my phones have started to update themselves. Oddly enough, it is my java based phones that are taking the longest. My older model phones are all updated. I guess I wasn't patient enough.

ischarcm Sun, 03/11/2007 - 07:50

can you tell me how long it took them? The one sitting in front of me has still not updated and its been about 2 hours or so... I don't have access to any others right now...but Im thinking they are in the same boat...


cmcgeepenair Sun, 03/11/2007 - 07:54

I have 7940 and 7970 phones and they did not update as they should have. I even went to the CM and Subs (which updated fine) and moved them up a minute, completed a call, and the phones updated a minute. But, the hour digit is still an hour off. I have reset all phones but no luck. Any Ideas?

tboynton Sun, 03/11/2007 - 07:54

If I had to guess, I'd say atleast 5 hours. My callmanager's clocks were update via NTP around 2AM (or 3AM with DST). At 8AM they were not updated. I checked again @ 9:30AM and most of them were showing the correct time.

ischarcm Sun, 03/11/2007 - 08:07

WOW!!! I would not have guessed that long at all... That is ridiculous... I'll wait while and see then... Id say we have about 500 phones or so.

tboynton Sun, 03/11/2007 - 19:24

18 hours later and not all my java based phones are updated. All running newest code too. Oh well.

rob.huffman Sun, 03/11/2007 - 08:03

Hi Chris,

Can you try a **#** reset on your phone to see if it updates? This is a very slow process.


ischarcm Sun, 03/11/2007 - 08:05

ok, did that... **#**, saw phone reset, but still shows an hour off :(

cplundberg Sun, 03/11/2007 - 08:06

Yup, tried the **#**, I also physically unplugged the phone. No dice on either.

I did as Cisco suggested and reset all my phones, CCM service, and NTP service, but no help.

So far I only have one 7970 that has updated itself.

ischarcm Sun, 03/11/2007 - 08:10

I assume restarting CCM service will cause a disruption... being a hospital I don't wnat to do anything thats going to cause service interruption if I can at all avoid it...

cplundberg Sun, 03/11/2007 - 07:58

What CM and OS level are you running? Did you have to make any change for the updates to occur?

...I opened a tac case and Cisco told me to do the following (but it didn't work for me)

1. update device pool time zone to a new time zone, reset devices.

2. Change time zone back to correct, reset phones.

3. Reset CCM and NTP services on all CMs.

ischarcm Sun, 03/11/2007 - 08:02

im running ccm 3.3.3

OSImage 2000 2.4

OS Service Release 2000-2-5sr4

I have a tac case open, but have not heard back yet... We are a hospital, so it will be very difficult to reset all phones...

Where do you reset the CCM and NTP services?

cplundberg Sun, 03/11/2007 - 08:09

You can reset the CCM service from the CCM Services website or Windows services control panel, but the NTP service can only be reset via the Windows services control panel (start->run->services.msc)

marketstarit Sun, 03/11/2007 - 11:29

I have 7960, 7940 that have not updated time, but all me 7970 phones have? Any Ideas anyone?


mchandak Sun, 03/11/2007 - 11:31

On the newer loads, you need to hit the settings button first and then **#**.

rob.huffman Sun, 03/11/2007 - 11:37

Hi Kenton,

Press the Services button - then **#** This should work. This funtionality changed with later phone firmware loads.

Hope this helps!


michaethompson Sun, 03/11/2007 - 12:55

yeah, on the newer phone loads you need to go to a submenu (for example hit the services button) and then do **#** to reload.

bvanbenschoten Sun, 03/11/2007 - 14:34

In newer phone loads you need to press the "services" button first before the **#**.

cplundberg Sun, 03/11/2007 - 11:32

Here is what I ended up doing to fix it...

Go into the CCM database table "TypeTimeZone" and manually set the "stddate"

and "dstdate" to "0/11/0/1,2:0:0:0" and "0/3/0/2,2:0:0:0" respectively for each US timezone.

After that reset CallManager service and NTP service on all CallManagers...This will reset all devices so the get the correct time.

ischarcm Sun, 03/11/2007 - 11:39

what do those numbers represent, I am on eastern time, would I use the same set of numbers? Is everything going to change/function properly at next changeover?


goodwinscottns Sun, 03/11/2007 - 11:44

The direction I just got from TAC support was to UNCHECK the DST offset feature in Windows on all CallManagers ("Automatically adjust clock for daylight savings time changes"). This makes no sense to me as it would effectively eliminate the DST offset.

Has anyone else been advised to do this in combination with any other fixes?

We are running CM 4.2.3 on 2000.4.4aSR4. The server times updated perfectly, though the phones are all 1 hour off this AM.

cplundberg Sun, 03/11/2007 - 11:47

I agree with you this make no sense...The post I submitted at 10:32PST has details on what Tac gave me to fix the time. I am running the same CM and OS versions as you.

cplundberg Sun, 03/11/2007 - 11:52

DBEntry Current Value Proposed Value

stddate 0/10/0/5,2:0:0:0 0/11/0/1,2:0:0:0

dstdate 0/4/0/1,2:0:0:0 0/3/0/2,2:0:0:0

Changed Values for Central, Eastern, and Pacific Time Zones.

marketstarit Sun, 03/11/2007 - 11:53

Yep that is what mine are set to. And I am currently having the problem.

cplundberg Sun, 03/11/2007 - 12:03

Tac told me to go right to the DB table and edit the values. Then restart CM and NTP service on each CM in your environment (Pubs & Subs)

goodwinscottns Sun, 03/11/2007 - 12:25

OK, I have edited the TZ table in the CM database to be correct & have restarted the NTP service on Pub and Sub.

100% of my phones are registered to my subscriber at the moment. If I were to restart the CallManager service on my Subscriber, wouldn't that force a reboot of every phone & drop all calls in progress??

I don't see a way to force the correct time to be displayed on every phone without a total interruption of service. We have a large call center operation and can't just reset all phones during business hours.

If anyone has any ideas on how to accomplish the time update without a major service interruption, please let me know.

Thanks for your help guys. I would have been chasing my tail with TAC support all day otherwise...

mchandak Sun, 03/11/2007 - 12:28

unfortunately no, looks like there is no way except to restart CCM service for this to take effect

cplundberg Sun, 03/11/2007 - 12:30

Not sure you have any alternatives. I tried just reseting a device pool after making the table changes but it didn't work. They only way I found to get the update to push to the phones was to reset the CM service.

You could reset the CM service on your publisher, then move your more critical phones (call center phones) over to the pub in chunks (update the CM group on the device pool for these devices). It would be painful and time consuming, but it would get you where you need to be.

ischarcm Sun, 03/11/2007 - 11:59

ok mine are set currently to what the current values above were as well... I only need to be concerned with eastern time (US) is that all I should change? Make the changes and then what, stop and start CCM service? I only have to do this on the pub??

ischarcm Sun, 03/11/2007 - 12:18

worked for me... after struggling all day I really appreciate it!

cplundberg Sun, 03/11/2007 - 13:38

Using SQL enterprise manager on the publisher. Drill down to the current CM database, then open the table under the database.

williamka Mon, 03/12/2007 - 07:07

After going into SQL into the CCM database table "TypeTimeZone" and manually set the "stddate"

and "dstdate" to "0/11/0/1,2:0:0:0" and "0/3/0/2,2:0:0:0" respectively for each US timezone... I recieved the following error

'Transaction cannot start while in the Firehouse Mode' This is on the pub.

Has anyone else experienced this problem?

pcanters Mon, 03/12/2007 - 11:23

If you scroll all the way down to bottom of the table, you will be able to get the change to take.

Hopefully this will work.


This Discussion