tahequivoice Mon, 03/12/2007 - 05:58
User Badges:

Resetting the phones didnt help in our case, we are still looking into it, and this is for all phone models.

pharden Mon, 03/12/2007 - 06:02
User Badges:

There was an update for 7970,7961,and 41's but I did not see one for the 60's and 40's I can not beileve how many users are conserned about the time on thier phone!!

tahequivoice Mon, 03/12/2007 - 05:57
User Badges:

One of our clusters, which we did not upgrade, we set manually, all the phones switched to the correct time. We have 3 other clusters, which are on different trains, that did not change the times on the phones. One of the clusters has the latest service packs and was just built in December, the other is an older one that has just had the serivce packs applied, but not anything done to the CCM itself. They range from 4.0 to 4.2, the one that is working is 4.1(3)sr3a, the other is alos the same train and is not working. Not sure the reasoning why.

scottadamson Mon, 03/12/2007 - 06:26
User Badges:

i have a 7941 it is an hour behind. co-workers with 7940's are showing the +1 (DST). both pub and sub OS are showing correct time. i've changed the device pool with no luck. any further suggestions would be GTREATLY appreciated.

Scott Adamson

Rob Huffman Mon, 03/12/2007 - 07:31
User Badges:
  • Super Red, 40000 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Phillip,


This problem for 7940's and 7960's was discovered yesterday AM. Here is a good description of the fix from [email protected] (I guess this was part of the OS Upgrade not mentioned in the Manual Workaround);


If the issue is only with 7940/60 phones, then we have seen a lot of similar cases today and are working to get a permanent fix to the issue. However as a workaround, you could resolve it by going into the Start >> Programs >> Microsoft SQL Server >> Enterprise Manager >> CCM database >> Table >> "TypeTimeZone" >> Right Click Open Table >> Return All Rows and manually set the "stddate" and "dstdate" to "0/11/0/1,2:0:0:0" and "0/3/0/2,2:0:0:0" respectively for each US timezone.


CM Service needs to be restarted.


From this long detailed thread;


http://forums.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Unified%20Communications%20and%20Video&topic=IP%20Telephony&CommCmd=MB?cmd=display_location&location=.1dddd0fe/40


Hope this helps!

Rob

scottadamson Mon, 03/12/2007 - 08:51
User Badges:

i updated the device software for the 4.1x CMM (which did require a reboot). the 7941's, after some time time and a couple of reboots, corrected themselves. the 7940's dropped back to the pre-DST time (an hour early). URG! i just read the post about adjusting the SQL Database TimeZone table but after the server rebooted following the Device update (and a few calls dropped). i have to wait (and see if there is another option than change the SQL database).


thanks all

scott

tahequivoice Mon, 03/12/2007 - 09:22
User Badges:

OK, now this is totally fracked up. I just updated the firmware for the 7970's and tested it out on a lab phone before changing it system wide, and good thing I did. The time went an hour ahead!!! I reverted the phone back to its original load and it now displays the correct time.

scottadamson Mon, 03/12/2007 - 09:33
User Badges:

i know we can change the phone load per phone if we would like. where are the files located on the call manager and how do you find an old load to attempt to backward test?


what would be the syntax in the phone load field? thanks.


the 7940's are running

P00308000400

the 7941's are running

sccp41.1-2-1s


thoughts...

tahequivoice Mon, 03/12/2007 - 09:46
User Badges:

They are in the tftp directory under program files Cisco.

On the 7970 look under phone info for the file, it will start with term. In the tftp directory there should be filres that have term for the 70, 41 and 61 series that end with loads. On the 40/60 phones, settings 5, 3, 1 will give you the phone load. Thos are listed on the ccm as P00xxxx.loads.

pharden Mon, 03/12/2007 - 18:47
User Badges:

Looks like i needed the DEV39 patch. However I have ran it on pub and sub. rebooted several time the server. and Reset/restarted the phones in my Device pool. Still old time on 7940,7960. Waiting on TAC to call back... Damn I hate feeling lost!!!!!!!!

scottadamson Mon, 03/12/2007 - 19:39
User Badges:

solutions as i have found them:


ran 4.1 dev 39 patch. 7941 time corrected (had some continued issues with 7961's though did not force a reset).


this evening (after talking with TAC and making Type TimeZone changes to the SQL table) - i was unable to stop and start services through the day, i reapplied the DST patch to the PUB and restarted.


time corrected on the 7940s! restarted the SUB (after PUB came back online) and forced a reset on a 7961 that was out of sync (**#**) and rebooted with proper time.


all looks good.


moral. if applying the 4.1DEV39 pack, you will need to re-run DST patch (and reboot) to have all devices working properly. seems to the be the "simplest" process...

tgillon Tue, 03/13/2007 - 07:01
User Badges:

IS it true this is a bug and Cisco is working on a fix? I have 7940 and 7960 phones and the time display did not move ahead an hour, despite having all the latest updates and patches and the TypeTimeZone setting being correct for my time zone.

Actions

This Discussion