Can not upload IOS?

Unanswered Question
Mar 12th, 2007
User Badges:

I uploaded this IOS to over 200 routers, but one of them is keep returning an error message "Invalid checksum"


router#copy tftp flash:

Address or name of remote host []? x.x.x.x

Source filename []? c2600-ik9o3s-mz.123-21.bin

Destination filename [c2600-ik9o3s-mz.123-21.bin]?

Accessing tftp://x.x.x.x/c2600-ik9o3s-mz.123-21.bin...

Erase flash: before copying? [confirm]

Erasing the flash filesystem will remove all files! Continue? [confirm]

Erasing device... eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee ...erasedee

Erase of flash: complete

Loading c2600-ik9o3s-mz.123-21.bin from x.x.x.x (via Serial0/0.186): !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

[OK - 19741828 bytes]


Verifying checksum... invalid (expected 0xA57, computed 0xA53)

19741828 bytes copied in 6304.583 secs (3131 bytes/sec)

Router#dir

Directory of flash:/


No files in directory


33030144 bytes total (13288252 bytes free)


Any idea what's going on?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Danilo Dy Mon, 03/12/2007 - 07:15
User Badges:
  • Blue, 1500 points or more

I think you are trying to upload the image remotely.


You will encounter this error if the line is busy.


Since you already upload it to over 200 routers, I doubt that there is a problem with the image. However, it wouldn't hurt to run a checksum on the file in your TFTP server and compare it with the checksum from the url where you download the image.


Then, try to upload it again when the line is not busy.

Ahmede Mon, 03/12/2007 - 07:20
User Badges:

Thnaks for your reply.. In act we tried the upload 5 times.. One of them was at 3AM on Sundy morning and there were no activity on the link at all..

Anand Narayana Mon, 03/12/2007 - 07:29
User Badges:
  • Silver, 250 points or more

Hi Ahmed,

i had the similar kind of problem, the only difference is i was uploading the image vis XMODEM utility, because my IOS was corrupted, so i tried recovering using the XMODEM utility, it was uploading but finally with the error message "invalid check..." so finally we changed the flash & uploaded using the same procedure, it worked out, so if you ask me, try using the XMODEM utility if not try changing the FLASH as an last option.


Note: i tried this on Cisco 3640

Actions

This Discussion