7961 time change

Unanswered Question
Mar 12th, 2007

how can i manually change the time on my 7961 series phones

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
marcuscastellanos Mon, 03/12/2007 - 08:22

Censanian,

I have about 600 60/40's and about 20 61's. I updated the firmware version on the 61's at the server and they all updated (They needed a restart through ccm)

I don't know about a manual change (as in through the phone itself)

Good luck

censanian Mon, 03/12/2007 - 08:34

well im in a weird situation. I thought the phones would have updated at 2:00am this morning. At 7am this morning, I had to manually set my callmanager time ahead an hour (did not patch for DST - personal reasons) So all phones that pull time from CM are ok... BUT my 7961's are now an hour ahead of adjust dst time (as if they adjusted ahead 2 hours) Not sure what happend in between - and this is why I need to find out how to manually readjust time on my 7961's

marcuscastellanos Mon, 03/12/2007 - 08:43

I ran into the same problem on one of my 61's. I was using it as the test phone. I set the firmware, (rest phone manually (Time was fine, then reset the phone through ccm, and it jumped ahead the 2 hours))

If you manually reset the phone, it should reset to the correct time (that was the fix for the 1)

Hope this helps

The rest of my 61's are working fine.

rob.huffman Mon, 03/12/2007 - 08:51

Hi Cody,

My guess is that the Java based phones (7906G,7911G,7941G,7961G,7970 or 7971)need a firmware upgrade to 8.2.1.

Look at(Step 2).

To obtain the complete Daylight Savings Time (DST) Update for the Operating System, Unified CallManager Cluster, and the 7906, 7911, 7921, 7941, 7961, 7970, 7971 IP phone models, you must perform the following steps in order:

1. Apply the Operating System (OS) 2000.4.2sr14, 2000.4.3aSR7, 2000.4.4sr2 or HIGHER, found here:

http://www.cisco.com/cgi-bin/tablebuild.pl/cmva-3des

2. Apply either the 8.2.1 stand-alone phone load or the device pack for this release:

8.2.1 Stand-alone phone load found here:

http://www.cisco.com/cgi-bin/tablebuild.pl/ip-7900ser

Device Pack for Unified CallManager 4.1(3), found here:

http://www.cisco.com/cgi-bin/tablebuild.pl/callmgr-41

3. Apply the Unified CallManager Update, found here:

http://www.cisco.com/cgi-bin/tablebuild.pl/callmgr-41

From this doc;

http://ftp-sj.cisco.com/cisco/crypto/3DES/voice/callmgr/4.1/ciscocm.4-1-3-2007-DST-Update.1-0-1-readme.htm

Hope this helps!

Rob

censanian Tue, 03/13/2007 - 06:13

ive upgraded a 7961 to firmware 8-2-1, while my CM had the correct time... and after the fw upgrade, my phone still displays an hour ahead of current time. help please!!

is there not a way to force the phone to resync time, or reset time?

if these models dont pull time from CM, where do they pull it from in the first place?

rob.huffman Tue, 03/13/2007 - 06:17

Hi Cody,

Try resetting the phone from CCM. (Note: must be reset not restart). This DST is crazy isn't it :)

Let us know,

Rob

censanian Tue, 03/13/2007 - 06:35

i can confirm the same thing with my 7911's

i have upgraded firmware to 8-2-1, reset them, and theyre still an hour ahead

rob.huffman Tue, 03/13/2007 - 06:38

Hi Cody,

I'm not sure how this all works without the DST Patches :( Maybe you could try setting up a new Date/Time Group in CCM that is one hour behind your Local time. Assign this new Date/Time Group to a new Device Pool and assign the 7961's to this new Device Pool.

Just a thought,

Rob

censanian Tue, 03/13/2007 - 06:55

MIGHT HAVE FIGURED OUT A SOLUTION !!!!

resetting the phone from with CM reboots the phone, forced the upload of new firmware, and subsequent resets from CM did not fix time... however, if i physically went to the phone, unplugged the power, plugged power back in, let phone power up, it pulled the correct time

this worked on 3 phones so far, and will further test this.

im guessing even with a 'reset' from within CM, the power cable is still plugged into the phone and power is still being supplied to the phone, and its holding in its memory somewhere the time

why cant things be simple, and all phones models simply pull, and continuously pull, time from the CM? sheesh!

ok hope this helps other folks!

marcuscastellanos Tue, 03/13/2007 - 09:01

Censanian is correct. I had one phone which was an hour ahead, and reset the phone through ccm many times (and it was still an hour ahead). Once you go the phone and physically unplug it, the time resets to the correct time. This is an issue if you have multiple 61 phones (say 100 or more). Anyone have a workaround if you have multiple phones?

censanian Tue, 03/13/2007 - 09:08

please note, this is/was an issue for me and im only dealing with 3 7961's (60 voice phones in all!)

*edit* i missunderstood what you meant by "this is an issue" - yes it is an issue having to manually unplug/replug power to 100's of phones, as opposed to three... i thought you meant the time problem existed only if you had hundreds of 7961's

rob.huffman Tue, 03/13/2007 - 09:24

Hey Cody,

Great work! Looks like there is an actual Bug that applies to this problem;

Bug CSCsh124444

Symptom:

The time change for Daylight Savings time may not take affect automatically for a third-generation IP phone running SCCP or SIP loads older than 8.2(2).

Conditions:

The third-generation IP phones are 7970, 7971, 7961, 7941, 7911, and 7906. After upgrading to 8.2(1) or 8.0(4)SR3 to get the fix for the 2007 DST changes this issue may appear.

Workaround:

Reset the IP phone from the CCMAdmin for the phone to get the correct time.

Power cycling the phone will not fix the time.

Further Problem Description:

The root cause of the bug is in the conditions required for the phone to update the time zone. Without this fix the only time the phone will update the time zone is if the clock drifts more than 10 seconds off of the NTP server time.

The title is: Time zone rules do not update correctly on 3rd-gen phones

Integrated in: 008.002(001.010) 008.003(000.023)

I think the other reset that works is stopping CM Service and restarting CM Service

Hope this helps!

Rob

PS: Looks like we will be doing another Firmware Upgrade :)

censanian Tue, 03/13/2007 - 09:29

Thanks! Not bad work for me considering our voice guy took a new job few weeks ago, and ALLLLL of our voice stuff got dumped onto me!

What a pain this DST stuff has been!!!!

Thanks everyone for all the help!!!

censanian Tue, 03/13/2007 - 11:29

IMPORTANT NOTE:

i noticed this issue...

if i have a phone ive updated firmware on, then manually umplugged/replugged the power cable, and now has correct time.... that if i now go into CM and tell the phone to 'reset' - upon resetting, it takes a bad time again setting it an hour ahead of normal. i need to then AGAIN go and manually unplug/replug again and it will then pull correct time yet again.

jwells79 Thu, 03/15/2007 - 12:16

I am having the same issue. But all my 7940's and 70's are 1 hour ahead. I have a Tac case opened and will post here if I get a fix

Actions

This Discussion