ADSchemaSetup failed, Unity 4.2(1)

Unanswered Question
Mar 13th, 2007

Hi,

I am desparate already. I tried 2 times the same installation guide walkthrough and I receive the same error. I am trying to install Unity 4.2(1). Everything works fine until I arrive at the schema update step. I run the Schema Update from the CD (so that isn't a problem) but it keeps telling me the same error. Setup failed to initialize active directory and gives me 5 "tips" to check if everything is ok (it's the same error as someone else described here, but for him the solution was to run it from a cd not from the hard-but I AM running it from the cd). I also set the schema update allowed key to 1. Could you please help ?

Thank you,

Zsolt

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
zjanosi Tue, 03/13/2007 - 03:21

Hi,

I managed that problem (I have to run forestprep and domainprep beofore installing exchange, but that isn't specified anywhere in the 4 = install guide). Now I have another problem. In the permission wizard when I arrive at the select mailstore step (which supposedly I can skip) it says cannot find mailstore. I am logged on as Administrator which has full rights in the domain, enterprise and everything. Why is this ?

thank you

lolu.oshunbiyi@... Tue, 03/13/2007 - 09:41

Is this a voicemail only installation? I assume you have installed exchange after running forestprep & domainprep?

zjanosi Tue, 03/13/2007 - 12:13

Hi,

I have figured everything out and as I supposed I was the "bottleneck" in getting things done. First as you said, I didn't realize that I had to install voicemail only, to be able to install exchange on the same server, so I just took the first installation guide that I could and unfortunately it was for unified messaging (which supposes the exchange is on another server) so in the installation guide there was no thing about installing exhange, only installing the administration software. So when I realized I bumped two times the table baught myself a beer and now I am finishing the installation.

As for williamka. Make sure you installed the exchange correctly, and have run the exchange install PRECEDED by setup /forestprep and setup /domainprep (in this order). If you also have the active directory set up correctly, the schema extension should work without problems. Let mew know if you have questions.

regards

williamka Tue, 03/13/2007 - 10:30

I am running into the exact same issue with the same Unity version. The same 5 tips have been validated and the ADschema exe is not successful.

zjanosi Tue, 03/13/2007 - 12:13

Hi,

I have figured everything out and as I supposed I was the "bottleneck" in getting things done. First as you said, I didn't realize that I had to install voicemail only, to be able to install exchange on the same server, so I just took the first installation guide that I could and unfortunately it was for unified messaging (which supposes the exchange is on another server) so in the installation guide there was no thing about installing exhange, only installing the administration software. So when I realized I bumped two times the table baught myself a beer and now I am finishing the installation.

As for williamka. Make sure you installed the exchange correctly, and have run the exchange install PRECEDED by setup /forestprep and setup /domainprep (in this order). If you also have the active directory set up correctly, the schema extension should work without problems. Let mew know if you have questions.

regards

Actions

This Discussion