Serial interface help

Unanswered Question
Mar 14th, 2007
User Badges:

How do I get this to work on a 2801 router.

Apparently I am doing something wrong.


interface Serial0/0/0:0.757 point-to-point

ip address 216.68.4.10 255.255.255.0

ip ospf message-digest-key 1 md5 5T33LP1P3

frame-relay interface-dlci 757



Thanks!!!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
elovelace256 Wed, 03/14/2007 - 07:54
User Badges:

Bill here is the rest of the config


Current configuration : 3863 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname SPS_T1

!

boot-start-marker

boot-end-marker

!

logging buffered 51200 warnings

!

no aaa new-model

!

resource policy

!

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

ip subnet-zero

ip cef

!

!

!

!

ip domain name yourdomain.com

!

!

!

crypto pki trustpoint TP-self-signed-3709427094

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-3709427094

revocation-check none

rsakeypair TP-self-signed-3709427094

!

!

crypto pki certificate chain TP-self-signed-3709427094

certificate self-signed 01

3082024D 308201B6 A0030201 02020101 300D0609 2A864886 F70D0101 04050030

31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

69666963 6174652D 33373039 34323730 3934301E 170D3037 30333031 32313039

34385A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 37303934

32373039 3430819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

8100A329 405B54CE 365F754A 96A2F943 68401517 BF640B5D 575D7BD7 E0B4BA4A

4D3737F6 8FDFD2A2 EAF6A23C 9F424C04 F5B089A8 294A1113 AF356539 A20FCEBF

ABA84994 56AC18E7 37342747 10E20BB4 AAF742C1 8AF95D37 DF657AF9 56D1BAA0

C42E75A1 28BD05D8 D7B13B82 CA73D290 266ABCC0 A1BA8BB5 97FDFFA9 00525FEB

0A0F0203 010001A3 75307330 0F060355 1D130101 FF040530 030101FF 30200603

551D1104 19301782 15535053 5F54312E 796F7572 646F6D61 696E2E63 6F6D301F

0603551D 23041830 16801490 4CDE7B52 BFA0FB01 3EFECED3 34B805A4 D4806430

1D060355 1D0E0416 0414904C DE7B52BF A0FB013E FECED334 B805A4D4 8064300D

06092A86 4886F70D 01010405 00038181 0078C88B A2485871 53DC9CC3 57069AAC

D93F5D14 791FE09A A88BFBE6 29D3DCD9 788CBA69 FA6ADB50 EDDCB90F D95CAE03

45265487 8C2DC18D 9CDB72B9 31386011 07CE7FA2 EFDAF33E 2F90FD07 A0A2DE8F

120D66FB 2DA8360D 069A08DC C0965CF3 92A41A4D 53233A37 61FF8CE7 320AD8CA

A1E3A609 A6B0862C 4C8EB4F9 14CCE764 30

quit

username admin privilege 15 secret 5 $1$TlYy$kZkDi.U8Ph1RWvNkKXXfV0

!

!

!

!

!

interface FastEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0$

ip address 10.79.113.199 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

description $ES_LAN$

ip address 10.10.10.10 255.255.255.0

duplex auto

speed auto

!

interface Serial0/1/0

no ip address

shutdown

!

ip classless

ip route 10.79.0.0 255.255.0.0 10.79.113.3

ip route 10.79.1.0 255.255.255.0 10.79.133.1

ip route 10.79.5.0 255.255.255.255 10.79.113.3

!

ip http server

ip http access-class 23

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

access-list 23 permit 10.79.0.0 0.0.255.255

!

!

control-plane

!

line con 0

login local

line aux 0

line vty 0 4

access-class 23 in

privilege level 15

login local

transport input telnet ssh

line vty 5 15

access-class 23 in

privilege level 15

login local

transport input telnet ssh

Richard Burts Wed, 03/14/2007 - 08:29
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Eric


There seems to be a mismatch between your first post and this one. The first post was specifying:

interface Serial0/0/0:0.757 point-to-point

but in this post there is not serial0/0/0 at all. If you are trying to configure a subinterface, then what we really need to see is the physical interface under which the subinterface will be.


Also I am not understanding clearly what is not working (is it the subinteface, the IP address, the OSPF authentication, or the PVC/DLCI). Perhaps you can clarify that.


HTH


Rick

elovelace256 Wed, 03/14/2007 - 09:10
User Badges:

It is actually serial 0/1/0 (sorry misprint) What is happining when I enter config mode and type interface Serial0/0/0:0.757 point-to-point

it gives me an error:

SPS_T1(config)#interface Serial0/1/0:0.757 point-to-point

^

% Invalid input detected at '^' marker.

The marker is the 0 right after the colon.


Does this help? I am urgently needing this configured.

Richard Burts Wed, 03/14/2007 - 09:33
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Eric


I think that Bill was pointing you int the right direction in his post. Your configuration has not specified encapsulation so it is using the default encapsulation of HDLC and subinterfaces are not supported in HDLC. If you configure encapsulation frame-relay you should find that the subinterface is accepted then.


HTH


Rick

elovelace256 Wed, 03/14/2007 - 09:39
User Badges:

Rick,

I changed serial 0/1/0 to encapsulation ppp and entered the command

interface Serial0/1/0:0.757 point-to-point


but the error is still coming up at 0 after the colon :0.757



Richard Burts Wed, 03/14/2007 - 09:41
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Eric


Neither HDLC nor PPP support subinterfaces. The encapsulation that does support subinterfaces is frame-relay.


HTH


Rick

elovelace256 Wed, 03/14/2007 - 10:37
User Badges:

I changed to frame relay and the same problem exists.


Do I have to be under the interface serial 0/1/0 to create the sub interface?

In my mind I wouldn't think so

Richard Burts Wed, 03/14/2007 - 10:46
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Eric


If you have entered encapsulation frame-relay under interface serial0/1/0 the subinterface should work. You do not explicitly need to enter interface serial0/1/0 before you enter interface serial0/1/0.757.


Perhaps you can do a cut and paste from your terminal session when you are doing the configuration, so that we can see what is going on.


HTH


Rick

Actions

This Discussion